NURBS Modeling
# Table of contents

## 1 NURBS overview

- About
  - What are NURBS? ......................................................... 9
  - NURBS modeling overview .............................................. 9
  - The mathematics behind NURBS ....................................... 10
  - Degree of NURBS curves and surfaces ............................. 12
  - Parameterization of NURBS curves and surfaces ................. 12
  - Normals ........................................................................... 14
  - Periodic, closed, and open geometry................................. 15
  - Curvature and Continuity ............................................... 17
  - Components of NURBS curves .......................................... 19
  - Moving edit points vs. moving CVs ................................. 21
  - Multi-knots and CV multiplicity ...................................... 21
  - Tips for constructing NURBS curves ............................... 21
  - Displaying and selecting NURBS components .................... 22

## 2 Creating NURBS curves

- How do I?
  - Draw curves ................................................................. 25
  - Create a curve from a surface edge, isoparm, or curve-on-surface ........................................... 26
  - Create arcs ..................................................................... 26
  - Create a fillet curve between two existing curves .......... 27
  - Create a degree 3 curve to match degree 1 (scan) data .... 29

## 3 Creating NURBS surfaces

- How do I?
  - Create NURBS primitives ................................................ 31
  - Create a flat surface inside a curve ................................. 33
  - Skin a surface across profile curves ............................... 35
  - Sweep a profile curve along a path curve ....................... 36
  - Sweep one or more profile curves along two path curves (birail) ........................................ 37
  - Create a surface within bounding curves ....................... 38
  - Create a four-sided surface with continuity (Square) ...... 40
  - Create a surface using Revolve ...................................... 41
  - Extrude and bevel a surface from a curve ....................... 42
  - Duplicate NURBS surface patches ................................. 44
# Table of Contents

Create NURBS transition surfaces ................................................. 44
Round off the meeting point between two edges ............................. 44
Create a fillet between two surfaces ........................................... 45
Create a surface between two sets of boundary curves ..................... 46

4 **Editing NURBS.** .................................................................. 49

**How do I?**

- Reshape a curve or surface manually ........................................... 49
- Align a curve with a curve or surface ......................................... 51
- Align surface edges ................................................................. 53
- Smooth a curve ................................................................. 54
- Lock or unlock the length of a curve ........................................... 54
- Straighten, smooth, curl or bend a curve ................................. 55
- Extend a curve ................................................................. 56
- Extend a surface ................................................................. 57
- Select curve CVs: first, last or all ............................................ 58

**Edit NURBS curves and surfaces** ............................................. 58

- Join curves or surfaces together ............................................. 58
- Split a curve or surface (detach) ............................................... 59
- Insert additional edit points/isoparms in a curve or surface to add more CVs 60
- Create an offset copy of a curve or surface ............................ 61
- Reverse the direction of a curve or surface normals .................. 62
- Reduce the complexity of a curve or surface ......................... 62
- Control multi-knots and CV hardness ..................................... 63
- Automatically add spans to areas of a curve with high curvature ... 65
- Convert a curve or surface to uniform parameterization .......... 65
- Convert a surface to non-rational geometry ............................ 66
- Change a curve or surface’s degree or number of spans/patches .. 66
- Make a curve or surface open or closed .................................. 67
- Match the topology of one curve to another ......................... 68

5 **Trimming** ......................................................................... 69

**About**

- Trimming NURBS surfaces ................................................... 69
- NURBS Booleans ................................................................. 70
- Curves-on-surface ............................................................... 70
Table of Contents

How do I?
Create a curve-on-surface. .............................................. 71
Trim or untrim a NURBS surface ....................................... 73
Perform boolean operations on surfaces ............................. 74

6 Stitching ................................................................. 77
How do I?
Stitch multiple surfaces together ...................................... 77
Manually stitch surface edges together ............................... 78
Manually stitch surface points together ............................. 79

7 Sculpting surface meshes ........................................... 81
About
Using the Sculpt Geometry Tool for NURBS ..................... 81

8 NURBS menus ......................................................... 83
Reference
Edit Curves ............................................................... 83
Edit Curves > Duplicate Surface Curves .......................... 83
Edit Curves > Attach Curves ........................................ 83
Edit Curves > Detach Curves ......................................... 85
Edit Curves > Align Curves ........................................... 86
Edit Curves > Open/Close Curves .................................. 87
Edit Curves > Move Seam ............................................ 88
Edit Curves > Cut Curve .............................................. 88
Edit Curves > Intersect Curves ....................................... 89
Edit Curves > Curve Fillet ............................................. 90
Edit Curves > Insert Knot ............................................. 91
Edit Curves > Extend > Extend Curve ............................ 92
Edit Curves > Extend > Extend Curve on Surface ............. 94
Edit Curves > Offset > Offset Curve, Offset Curve on Surface .... 95
Edit Curves > Reverse Curve Direction .......................... 97
Edit Curves > Rebuild Curve ....................................... 97
Edit Curves > Fit B-spline ........................................... 100
Edit Curves > Smooth Curve ....................................... 101
Edit Curves > CV Hardness ......................................... 101
Edit Curves > Add Points Tool .................................... 102
Edit Curves > Curve Editing Tool ................................ 102
Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit Curves &gt; Project Tangent</td>
<td>102</td>
</tr>
<tr>
<td>Edit Curves &gt; Modify Curves &gt; Lock Length</td>
<td>104</td>
</tr>
<tr>
<td>Edit Curves &gt; Modify Curves &gt; Unlock Length</td>
<td>104</td>
</tr>
<tr>
<td>Edit Curves &gt; Modify Curves &gt; Straighten</td>
<td>105</td>
</tr>
<tr>
<td>Edit Curves &gt; Modify Curves &gt; Smooth</td>
<td>106</td>
</tr>
<tr>
<td>Edit Curves &gt; Modify Curves &gt; Curl</td>
<td>106</td>
</tr>
<tr>
<td>Edit Curves &gt; Modify Curves &gt; Bend</td>
<td>106</td>
</tr>
<tr>
<td>Edit Curves &gt; Modify Curves &gt; Scale Curvature</td>
<td>107</td>
</tr>
<tr>
<td>Edit Curves &gt; Selection &gt; Select Curve CVs</td>
<td>108</td>
</tr>
<tr>
<td>Edit Curves &gt; Selection &gt; Select First CV on Curve</td>
<td>108</td>
</tr>
<tr>
<td>Edit Curves &gt; Selection &gt; Select Last CV on Curve</td>
<td>108</td>
</tr>
<tr>
<td>Edit Curves &gt; Selection &gt; Cluster Curve</td>
<td>109</td>
</tr>
</tbody>
</table>

**Surfaces** | 109
---|
Surfaces > Revolve | 109
Surfaces > Loft | 113
Surfaces > Planar | 117
Surfaces > Extrude | 118
Surfaces > Birail | 124
Surfaces > Boundary | 127
Surfaces > Square | 128
Surfaces > Bevel | 129
Surfaces > Bevel Plus | 133

**Edit NURBS** | 137
---|
Edit NURBS > Duplicate NURBS Patches | 137
Edit NURBS > Project Curve on Surface | 137
Edit NURBS > Intersect Surfaces | 140
Edit NURBS > Trim Tool | 141
Edit NURBS > Untrim Surfaces | 141
Edit NURBS > Booleans > Union Tool, Difference Tool, Intersection Tool | 142
Edit NURBS > Attach Surfaces | 142
Edit NURBS > Attach Without Moving | 144
Edit NURBS > Detach Surfaces | 144
Edit NURBS > Align Surfaces | 146
## Table of Contents

- Edit NURBS > Open/Close Surfaces .............................................. 151
- Edit NURBS > Move Seam ......................................................... 153
- Edit NURBS > Insert Isoparms .................................................. 153
- Edit NURBS > Extend Surfaces .................................................. 155
- Edit NURBS > Offset Surfaces .................................................. 156
- Edit NURBS > Reverse Surface Direction .................................... 156
- Edit NURBS > Rebuild Surfaces .................................................. 156
- Edit NURBS > Round Tool .......................................................... 160
- Edit NURBS > Surface Fillet > Circular Fillet ................................ 161
- Edit NURBS > Surface Fillet > Freeform Fillet .............................. 163
- Edit NURBS > Surface Fillet > Fillet Blend Tool ......................... 164
- Edit NURBS > Stitch > Stitch Surface Points ............................ 169
- Edit NURBS > Stitch > Stitch Edges Tool .................................. 169
- Edit NURBS > Stitch > Global Stitch ......................................... 171
- Edit NURBS > Sculpt Geometry Tool ....................................... 175
- Edit NURBS > Surface Editing > Surface Editing Tool, Break Tangent, Smooth Tangent .................................................. 176
- Edit NURBS > Selection ............................................................. 176

### 9  NURBS nodes ........................................................................... 177

#### Reference

- StitchSrf node ................................................................. 177

#### Index .................................................................................... 179
What are NURBS?

NURBS (Non-Uniform Rational B-Splines) are one geometry type you can use to create 3D curves and surfaces in Maya. The other geometry types that Maya provides are polygon and subdivision surfaces.

- **Non-Uniform** refers to the parameterization of the curve. Non-Uniform curves allow, among other things, the presence of multi-knots, which are needed to represent Bezier curves.
- **Rational** refers to the underlying mathematical representation. This property allows NURBS to represent exact conics (such as parabolic curves, circles, and ellipses) in addition to free-form curves.
- **B-splines** are piecewise polynomial curves (splines) that have a parametric representation.

NURBS are useful for constructing many types of organic 3D forms because of the smooth and minimal nature of the curves they use to construct surfaces. NURBS surface types are widely used in the fields of animation, games, scientific visualization, and industrial design.

The NURBS 3D data type can easily be exported to CAD software applications by exporting the surfaces using the IGES file format. In addition, Maya can import many types of bezier and NURBS data types from many CAD software applications using the Autodesk® Direct Connect® translator plug-in.

If your requirements are to use the polygon surface type in your scenes you can initially construct your surfaces using NURBS and then convert them to polygons.

Related topics
- “NURBS modeling overview” on page 9
- “Components of NURBS curves” on page 19
- “Draw curves” on page 25
- “Convert NURBS surfaces to a polygon mesh” on page 53

NURBS modeling overview

To use NURBS in Maya you can do one of the following:

- Construct 3D models using NURBS primitives.

  Primitives are simple 3D objects created in the shape of common geometric forms such as cubes, spheres, cones, and so on. Primitives can be a great starting point for many 3D shapes. You can modify the attributes of NURBS primitives to modify their shape. You can also modify NURBS primitives by trimming away portions of their forms, beveling their edges, or by sculpting them into different shapes using the Maya Artisan sculpting tools.
• Construct NURBS curves that define the basic outline of the 3D form you wish to construct and then use the curves as a basis for constructing your NURBS surfaces.

Maya provides several options for constructing and modifying NURBS curves and surfaces:
• You can draw curves by placing control vertices, or edit points. The curve drawing tools are found in the Create menu.
• The features for editing NURBS curves are used by first selecting the Modeling menu set, and then selecting the desired curve editing feature from the Edit Curves menu.
• The features for creating NURBS surfaces are used by first selecting the Modeling menu set, and then selecting the desired surface creation feature from the Surfaces menu set.
• The features for modifying NURBS surfaces are used by first selecting the Modeling menu set, and then selecting the desired surface editing feature from the Edit NURBS menu set.

Related topics
- "Components of NURBS curves" on page 19
- "Draw curves" on page 25
- "Displaying and selecting NURBS components" on page 22
- "Degree of NURBS curves and surfaces" on page 12

The mathematics behind NURBS

Polynomial equations
Starting with the simplest mathematical representation, we all remember from geometry class that we can represent a (two dimensional) line with an equation like $y = 2x$. For each value of $x$, we multiply it by 2 to get the value of $y$, and plot the two values on a graph.

The generalized form of this type of equation is $ax + by = c$. The expression to the left of the equals sign is called a polynomial (“poly” means many. It refers to the fact that the expression has more than one term).

We can make more complicated expressions where $x$ is multiplied by itself, as $y = x \times x \times x$. Instead of writing out all the $x$s in a term, we usually just count them and write the count as a superscript. The superscript is called “the exponent”. So the expression above is written as $y = x^3$.

We can write polynomials with exponents, such as:
$y = ax^2 + bx + c$
(You may recall from math class that this is a quadratic equation). The exponent (the 2) on the first occurrence of $x$ means that the graph of this function is curved rather than straight.
Degree

The degree of a polynomial equation is the largest exponent in the equation. Recall that the largest exponent on the equation for a line was 1. (When a term has no visible exponent, that is the same as an exponent of 1.)

- The degree of a linear equation is 1.
- A quadratic equation, which has a term $x^2$, is degree 2.
- A cubic equation, which has a term $x^3$, is degree 3, and so on.

Parametric representations

There are two general ways to write an equation for a curve. The implicit representation combines every variable in one long, non-linear equation, such as:

$$ax^3 + by^2 + 2cxy + 2dx + 2ey + f = 0.$$ 

In this representation, to calculate the x and y values to plot them on a graph, we must solve the entire non-linear equation.

The parametric representation rewrites the equation into shorter, easily solved equations that translate one variable into values for the others:

$$x = a + bt + ct^2 + dt^3 + ...$$

$$y = g + ht + jt^2 + kt^3 + ...$$

Using this representation, the equations for x and y are simple. We just need a value for $t$, the point along the curve for which we want to calculate $x$ and $y$.

You can visualize parametric curves as being drawn by a point moving through space. At any time $t$, we can calculate the $x$ and $y$ values of the moving point. This is a very important point, because the concept of associating a parameter number with every point on the line is used by many tools. This corresponds to the $U$ dimension of the curve.

Complex curve types with NURBS

The lower the degree of a curve equation, the simpler the curve described. What if we want to represent complex curves? The simple answer might be to increase the degree of the curve, but this is not very efficient. The higher the degree of the curve, the more computations are required. Also, curves with degree higher than 7 are subject to wide oscillations in their shape, which makes them impractical for interactive modeling.

The answer is to join relatively low-degree (1 to 7) curve equations together as segments of a larger, more complex composite curve. The points at which the curve segments, or spans, join together is called an edit point.

Higher degree curves should not be completely discounted, however. Degree 5 and 7 curves have certain advantages such as smoother curvature and more “tension”. They are often used in automotive design.
Smooth joins
The degree of the curve determines the smoothness of the joins between spans. Degree 1 (linear) curves give positional continuity at the join. Degree 2 (quadratic) curves give tangent continuity. Degree 3 (cubic) curves give curvature continuity.

Degree of NURBS curves and surfaces
Degree is a mathematical property of a curve or of a surface that controls how many CVs per span are available for modeling. The degree is always represented mathematically as a positive whole number. Degree can be thought of as the curve or surface’s degree of freedom to bend. A degree 1 curve connects its edit points with straight lines in a polygonal fashion. A degree 2 curve can have one bend between edit points, and so on.

Maya has the ability to create curves with a degree of 1, 2, 3, 5, or 7. The default degree in Maya is 3, which has four CVs for the first curve span. A curve degree of 3 is sufficient for almost any modeling task. You may want to use degree 5 or 7 curves if you are producing 3D surfaces for subsequent export to a CAD application for industrial design purposes.

Surfaces can have different degrees across their width and length. For example, a surface could be degree 3 along its width, and degree 5 along its length.

The degree of your curves can affect data transfer to other software packages. Some other packages cannot accept curves with degree higher than 3.

Parameterization of NURBS curves and surfaces
What are parameters?
Parameters are the unique numeric values (like coordinates) of points on a curve or surface. Parameters let you refer to specific points along the length of a curve. The higher the parameter, the further is the point along the curve.

Just as points in space have three dimensions, called X, Y, and Z, the parameters of a point are measured along the one internal dimension (length) of the curve. We call this dimension U.
Since surfaces have two internal dimensions (length and width), we need another parameter (in addition to $U$) to specify a point on a surface. We call this parameter $V$.

Just as every point along the length of a curve has a $U$ parameter, every point across a surface has $U$ and $V$ parameters.

**What is parameterization?**

The method the application uses to number the points along a curve is called the curve’s *parameterization*. There are two parameterization methods available: *uniform* and *chord-length*.

Each method has advantages and disadvantages depending on how the curve will be used. You can choose which parameterization method to use when you create a new curve, and you can rebuild existing curves to use a specific parameterization.

Different actions can create curves or surfaces with different parameterization methods, often as a user-configurable option. For example, the CV Curve Tool and EP Curve Tool use uniform knot spacing by default. The Pencil Tool uses chord length knot spacing.

**Uniform**

Uniform parameterization assigns integral parameter values to the edit points, and evenly distributes parameters along the spans between edit points. So the first edit point is always parameter 0.0, the second edit point is always 1.0, the third is always 2.0, and so on.

A bonus feature of uniform parameterization is that the parameter value of the last edit point is the also the number of spans in the curve. However, unlike chord-length parameterization, the parameters of a uniform curve have nothing to do with the actual length of the curve.

Though the default values for uniform parameterization range from 0 to the total number of spans, you can use Rebuild Curve/Rebuild Surface to change the range to 0 to 1. (The 0 to 1 scheme is common in other computer graphics packages. Some users may want to use it for the sake of familiarity.)

**Chord-length**

Chord-length parameterization assigns parameter 0.0 to the start of the curve, then increases the parameter value proportionally to the *chord length*, or the shortest linear distance, between the surrounding edit points.
Unlike uniform parameterization, the parameters of a chord-length curve are irregularly spaced between the edit points, and the edit points do not have integral parameters.

**Comparison**

Each parameterization method has advantages and disadvantages, depending on how you will use the curve or surface.

<table>
<thead>
<tr>
<th>Type</th>
<th>Pros</th>
<th>Cons</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chord-length</td>
<td>Parameter value gives some indication of the point’s relative position along the curve. Distributes curvature better. Minimizes stretching and squeezing of textures.</td>
<td>Parameters are not obvious. Surfaces built from chord-length curves can be more complex because of cross-knot insertion.</td>
</tr>
<tr>
<td>Uniform</td>
<td>Easy to reckon parameters (for example, 1.5 is about half-way between edit points at 1.0 and 2.0).</td>
<td>In many cases, interpolation between edit points is not as good. Can lead to unpredictable stretching of textures during rendering.</td>
</tr>
</tbody>
</table>

Just as with degree, surfaces can have different parameterization methods for their U and V dimensions. For example, the U isoparms of a surface can be degree 3 with uniform parameterization, while the V isoparms are degree 1 with chord-length parameterization.

To avoid problems manipulating and texturing a joined surface, make sure the joined surfaces use the same parameterization (uniform or chord length). If both surfaces use uniform parameterization, make sure that both use the same parameter range (0 to 1 or 0 to total number of spans).

**Viewing parameters**

When you select a curve or surface point, the U and V (for surfaces) values are shown in the status line as you drag.

**Normals**

Normals are imaginary lines perpendicular to each point on a curve or surface.
About > Periodic, closed, and open geometry

The direction of U and V isoparms on a surface determines the direction of the surface’s normals.

Normals are a mathematical side-effect of NURBS. They are often used as a way of specifying which side of a surface points “inside” or “outside” (for example, when creating shells).

Normals are also an indirect indicator of the shape of a curve or surface. Since they are always perpendicular to the curve or surface, the way normal lines point toward or away from each other can reveal subtle curvature.

Periodic, closed, and open geometry

A NURBS curve or surface can have a periodic, closed, or open form. The form affects the how the object deforms.

Curves

- An open curve usually has its start and end edit points in different positions—it typically doesn’t form a loop. If you snap the start and end edit points of an open curve to the same position, it’s still an open curve, because you can still drag these points away from each other.
- A closed curve is a loop with coinciding start and end edit points. Where start and end edit points meet is also called a seam. If you move the start edit point, the end edit point moves with it (and vice versa).
- A periodic curve is also a loop with a seam, but it has two unseen spans at the end of the curve that overlap the first two spans. The unseen spans help maintain continuity along the seam.

For example, suppose you create a circle primitive with four spans (sections). A circle primitive is a periodic curve. If you display the circle’s edit points, you’ll see only four spans. There are actually six spans, but the last two overlap the first two.
About > Periodic, closed, and open geometry

In contrast to a periodic curve, a closed curve can have a sharp corner at the seam because it lacks the extra spans.

The figure below shows similar closed and periodic curves, both originally circles. For each, we moved the CV next to the seam inward. The periodic curve keeps its continuity, but the closed curve's tangency is broken.

To see whether a curve is periodic, closed, or open, select the object, display the Attribute Editor, and examine the contents of the Form text box.

Note that if you use Edit Curves > Open/Close Curves to “close” an open curve, you create a periodic rather than a closed curve. To create a closed curve, use Edit Curves > Detach Curves on any edit point of a periodic curve.

**NURBS surfaces**

*Periodic and closed surfaces* work like their curve counterparts, except they have two parametric directions (U and V) instead of one (U).
If you create a surface from a periodic curve, the surface is periodic in one direction (U or V).

To see whether a surface is periodic, closed, or open, select the object, display the Attribute Editor, and examine the contents of the Form U and V text boxes. A surface is considered periodic whether it’s periodic in U, V, or both.

If you use Edit NURBS > Open/Close Surfaces on an open surface, you create a periodic rather than a closed surface. To create a closed surface, use Edit NURBS > Detach Surfaces on an isoparm of a periodic surface.

Curvature and Continuity

Curvature

Curvature is a measure of how much a curve curves.

Curvature is measured by fitting a circle into the curve, then taking the reciprocal of the circle’s radius. In this figure, at point x the curve is best described by a circle with radius r. At this point, the curvature is 1/r.

(We use the reciprocal, 1/r, instead of just r because a flat line has an infinite radius. Taking the reciprocal gives us 0 instead of infinity.)
Continuity for NURBS curves and surfaces

Continuity is a measure of how smoothly two curves or surfaces “flow” into each other at their meeting point. The type of curvature your curves and surfaces have may be important if you need to subsequently export your Maya NURBS surfaces to a CAD software application.

Positional (G0)

The endpoints of the two curves or surfaces meet exactly. Note that the two curves or surfaces can meet at any angle and still have positional continuity.

Tangent (G1)

Curves or surfaces that have tangent continuity also have positional continuity, plus the end tangents match at the common endpoint. The two curves will appear to be travelling in the same direction at the join, but they may still have very different apparent “speeds” (rate of change of the direction, also called curvature).

For example, in this figure, the two curves have the same tangent (the double-arrow line) at the join (the dot). But the curve to the left of the join has a slow (low) curvature at the join, while the curve to the right of the join has a fast (high) curvature at the join.
Curvature (G2)

Curves or surfaces that are curvature continuous have tangent continuity, plus the curvature of the two curves matches at the common endpoint. The two curves appear to have the same “speed” at the join.

Components of NURBS curves

The easiest way to display and select a curve component is to press the right mouse button on an object, choose the component type, then select the component.

CVs

CVs (control vertices) control how the curve is “pulled” from a straight line between edit points. They are the most basic and important means for controlling the shape of a curve. Lines between consecutive CVs form the control hull.

The number of CVs is equal to the degree of the curve plus one. So, for example, a degree 3 curve has four CVs per span. To increase the number of CVs to gain more control over curve shape, you can increase the number of spans by inserting edit points or increase the curve’s degree.

Maya draws CVs differently to let you tell the difference between the start and the end of a curve. The first CV (at the start point of the curve) is drawn as a box. The second CV is drawn as a small “U”, to show the increasing U dimension from the start point. All other CVs are drawn as small dots.

Multiple spans

Longer and more complex curves require more than a single span curve. As you draw what appears to be a single long curve, the application is actually adding several curve spans together.
Edit points

You can tell when a curve is made from multiple spans in several ways. One is to look for edit points on the curve. Edit points mark the connection point between two spans. Maya draws edit points as small Xs.

Unlike the on-curve control points of Bezier curves (used in many 2D illustration programs), NURBS edit points are not usually used for editing curves. CVs control the shape of a NURBS curve, and edit points are just indicators of how many spans a curve has.

There are, however, a few tasks that use edit points:

- If you want more control in a curve, you can insert an edit point to increase the number of spans in the curve and give you more CVs to work with.
- You can also delete edit points to decrease the number of spans in a curve (and probably change the shape of the curve).
- It is possible to move edit points to change the shape of a curve, but you should avoid doing this except for minor adjustments.

Hulls

As a curve gets more spans/edit points, you might lose track of the order of the CVs. To show the relationship between CVs, Maya can draw lines between them. These lines are called hulls.

Hulls are useful:

- To show the order of CVs in a crowded scene.
- To show the shape of the CVs when your object is so crowded with CVs that you can’t determine exactly which adjacent CVs will be affected when you tweak part of a model.
- To select an entire row of CVs at once.
Moving edit points vs. moving CVs

In theory, moving edit points would be an excellent way to edit a curve, since they lie on the curve itself. Unfortunately, it doesn’t work out that way. This is because the shape of the curve determines the positions of edit points, not the other way around.

Maya does allow you to move edit points by “reverse engineering” the curve from the edit point. When you move an edit point, the Move tool tries to find a curve which passes through the new edit point location.

Because this process is time-consuming and has an infinite number of solutions, the tool must place constraints on how moving the edit point affects the curve. Because of these constraints, you usually cannot make major changes well by moving edit points. Moving edit points is best for small scale reshaping.

Even though it is slightly less intuitive, the only way to reshape the curve with complete power is by moving CVs.

Multi-knots and CV multiplicity

A multi-knot is multiple edit points at the same location in space.

CV multiplicity is multiple CVs at the same location in space.

Multi-knots and CV Multiplicity achieve similar effects (sharper bends in curves), even though they are different mathematically.

Multi-knots are usually the result of curve or surface editing operations that require a sharp turn in a curve.

Multi-knots and CV multiplicity are generally undesirable. Some tools cannot work with them, they do not build very good surfaces or animate predictably, and some other software packages will not accept models with multi-knots.

Tips for constructing NURBS curves

To create quality NURBS surfaces you need to construct quality NURBS curves. These guidelines will help you create good NURBS curves.

Create simple curves

Use the simplest curves that can describe the shape you want. This means construct curves with the least amount of CVs or edit points possible. Simpler curves mean simple, faster rendering surfaces.

One effective method for achieving simple curves is:

1. Begin a curve by drawing a single span.
2. Move the interior CVs on the curve to achieve the shape you want.
3. If you can’t achieve the shape you want, add an interior edit point to create more CVs.
4 Continue this process until you have the curve shape you need. This iterative process ensures your curve only has as many spans as are absolutely necessary.

You can also use the Rebuild curve tool to simplify existing curves. The tool can simplify a curve while maintaining its shape within a tolerance you set.

Note the curve’s parameterization

It is often best to build curves with uniform parameterization, because it makes inserting edit points and detaching curves at exact locations easier.

- When drawing Edit point curves with Uniform parameterization, the resulting CVs may be placed awkwardly. To fix this, move the CVs to prevent crossing hull lines.
- Try to consistently use either Uniform or Chord length parameterization when drawing curves. If you mix and match curve styles, it could result in cross knot insertion when the curves are used to build a surface.

Plan your surfaces in advance

When creating curve, plan ahead to the surfaces that you want. Try to have the same number of spans in all the construction curves for building a surface. A simple way to achieve this is to start with one curve, then duplicate it to create more construction curves.

When you create a surface from curves with different numbers of spans, the new surface will have an extra isoparametric curve corresponding to every extra edit point. This is known as cross knot insertion. It makes the new surface more difficult to edit and more complex.

Displaying and selecting NURBS components

The easiest way to display and select a NURBS component is to press the right mouse button on the object, choose the component type from the marking menu that appears. With the selection type set, you can then select the component on the object.

CVs

Like curves, NURBS surfaces have CVs that control the shape of the surface. Each patch has a certain number of CVs, controlled by the degree of the curve. To increase the number of CVs you can insert extra isoparms or increase the degree of the surface.

Isoparms

Isoparametric curves (or isoparms) are lines running along the surface in the U and V directions, showing the shape of the surface as defined by the CVs.
Patches

The area enclosed by four adjacent isoparms is called a patch.
Creating NURBS curves

How do I? Draw curves

To draw a NURBS curve by placing CVs

1. Select Create > CV Curve Tool.
2. Click to place the CVs.
   • The first CV looks like a hollow box. The second CV looks like a letter U. Maya draws hulls between the CVs as you place them.
   • For each CV after the third one you place, Maya draws the shape of the curve.
   • To remove the last CV you placed, press Delete.
   • To switch to editing CVs, press Home or Insert. A manipulator appears on the previous CV. Use the manipulator to move the CV, press Delete to delete a segment, or click another CV to edit it. Press Home or Insert again to return to adding CVs.
3. Press Enter to finish the curve.

To draw a NURBS curve by placing edit points

Use this tool if you want the curve to pass through certain points. It calculates the positions of CVs based on where you want the edit points.

2. Click to place the edit points.
   • For each edit point after the first one you place, Maya draws the shape of the curve.
   • To switch to editing edit points, press Home or Insert. A manipulator appears on the previous point. Use the manipulator to move the point, press Delete to delete a segment, or click another point to edit it. Press Home or Insert again to return to adding point.
3. Press Enter to finish the curve.

Draw a NURBS curve freehand

1. Select Create > Pencil Curve Tool.
2. Drag to sketch a curve. When you release the mouse button Maya creates the curve.
3. The Pencil Curve tool creates a curve with a large number of data points. Use Edit Curves > Rebuild Curve to simplify the curve.
   • As you draw the curve, Maya puts points in the view if they are at least five screen pixels from the previous point.
Create a curve from a surface edge, isoparm, or curve-on-surface

To create a new curve from a surface component curve
1. Select an edge, isoparm, or curve-on-surface.
2. Select Edit Curves > Duplicate Surface Curves.
   When construction history is on, the curve remains linked to the original surface. Transformation is relative to the original surface, and changes to the component curve from which it was created change the duplicated curve.

**Tip**
You can duplicate an isoparm and use it as a wire deformer for the surface.

Create arcs

To create a two-point arc
This tool allows you to create up to 180 degrees of arc by specifying two endpoints and then manipulating the center point/radius.
1. Select Create > Arc Tools > Two Point Arc Tool.
2. Click to place the first endpoint, an on-curve point, and the second endpoint of the arc.
   Maya shows a manipulator for the new arc.
3. Do any of the following:
   • Drag any of the points to move them.
How do I? > Create a fillet curve between two existing curves

- Press Enter to finish the arc.

To create a three-point arc

1. Select Create > Arc Tools > Three Point Arc Tool.
2. Click to place the three endpoints of the arc.
   Maya shows a manipulator for the new arc.
3. Do any of the following:
   - Drag the endpoints or center point to move them.
   - Click the circle to switch the direction the arc travels between endpoints.
   - Press Enter to finish the arc.

Edit an arc after creation

1. In the channel box, select the CircularArc node associated with the arc you want to change.
2. In the toolbox, click the Show Manipulator tool.
   The arc manipulator will appear.

Notes

- You cannot create a complete circle with the Arc Tools.
- Points in the arc cannot have the exact same position.

What if...?

I want to create a circle?

Use Create > NURBS Primitives > Circle.

Related topics

- "Create a fillet curve between two existing curves” on page 27
- "Create > Arc Tools > Three Point Circular Arc, Two Point Circular Arc” on page 256

Create a fillet curve between two existing curves

You can create a circular or freeform fillet. The freeform fillet offers more position and shape control.
Creating NURBS curves

How do I? > Create a fillet curve between two existing curves

To create a circular fillet curve between two curves

1. Select curve points on each curve about where you want the fillet to begin and end. (The radius you enter for the fillet will determine the actual start and end points.)

2. Select Edit Curves > Curve Fillet > \( \text{T} \).

3. Click Circular and enter the Radius for the fillet.

4. To trim the curves back to the fillet end points, turn on Trim. When Trim is on, you can also turn on Join to join the curves together into one new curve.

5. Click Apply.

To create a freeform fillet curve between two curves

1. Select a curve point on each curve to specify the start and end points of the fillet.

2. Select Edit Curves > Curve Fillet > \( \text{F} \).

3. Click Freeform.

4. To trim the curves back to the fillet end points, turn on Trim. When Trim is on, you can also turn on Join to join the curves together into one new curve.

5. Click Apply.

Note: You cannot create a fillet using a curve-on-surface.
What if...?

Maya does not create a fillet curve?

- Maya may not create a curve if it’s not possible to fillet the selected curve with the radius you entered. Try entering a different radius and click Apply again.
- Try reshaping the curves so they intersect.

Related topics

- “Create arcs” on page 26
- “Edit Curves > Curve Fillet” on page 90

Create a degree 3 curve to match degree 1 (scan) data

1. Select the degree 1 curve.
2. Choose Edit Curves > Fit B-Spline.

Related topics

- “Edit Curves > Fit B-spline” on page 100
2 | Creating NURBS curves
How do I? > Create a degree 3 curve to match degree 1 (scan) data
3 Creating NURBS surfaces

How do I? Create NURBS primitives

You can create pre-defined 3D geometric shapes called primitives in Maya. Primitives can be used as-is or as a starting point for 3D modeling.

There are three main ways to create NURBS primitives:

- "Create NURBS primitives using the Create menu" on page 31
- "Create NURBS primitives using the Shelf" on page 31
- "Create a NURBS primitive interactively" on page 32

Create NURBS primitives using the Create menu

Related topics

- "Create > NURBS Primitives" on page 234

To create NURBS primitives using the Create menu

1 Select Create > NURBS Primitives, then select the primitive’s option box from the list of primitives. For example, Sphere > □, Cube > □, Cone > □, Cylinder > □, and so on.

   When you select the □ beside the primitive, its associated options window appears.

2 In the primitive options window, change the attributes of the NURBS primitive. For example, you can set attributes that specify the size and scale, how the primitive is subdivided, and so on.

   For more information on primitive options, see "Create > NURBS Primitives" on page 234.

   Note: You can modify primitive attributes after creating it using either the Channel Box or the Attribute Editor.

3 Click Create.

   The primitive object appears at the origin of the scene view.

Create NURBS primitives using the Shelf

You can create NURBS primitives using the Shelf. The Shelf provides easily-selectable primitive icons. You can also set a primitive’s options and then save a custom version of a primitive to the Shelf for future use. For more information see "Add a tool, action, or MEL script to a shelf" on page 147.
To create NURBS primitives using the Shelf

1. In the scene view, select the Surfaces tab on the Shelf to display the surfaces primitive icons.
2. Click a surfaces primitive icon.

The primitive object appears at the origin of the scene view.

Create a NURBS primitive interactively

Using your mouse, you can create, position, and scale primitives, without having to use transformation tools. Select Create > NURBS Primitives > Interactive Creation. This option stays on until you turn it off. If you want to create multiple primitives interactively, turn off Create > NURBS Primitives > Exit on Completion.

As well, you can create a NURBS primitive with just a single click.

Options can be set for single-click and click-drag NURBS creation, using the NURBS Tool settings (Create > Polygon Primitives > Shape). 

To interactively create NURBS primitives using your mouse

1. Select Create > NURBS Primitives > Interactive Creation if it is not already on.
2. Select Create > NURBS Primitives to choose the primitive type or select the primitive type from the shelf.
   - If you want to change the settings that the polygon primitive is created with, such as Axis or Number of Spans, select Create > NURBS Primitive > Shape.
3. In the scene view, do one of the following:
   - Click-drag to create the primitive (Sphere, Plane, Torus, Circle, Square).
   - Click-drag to initially create a 2D base of the primitive. Then click-drag a second time to scale the 2D base into a 3D primitive object (Cube, Cylinder, Cone).

Holding down the Shift and Control keys during primitive creation has the following effects:

<table>
<thead>
<tr>
<th>Modifier key</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>(None)</td>
<td>Grows plane and cube primitives from the corner. Grows all other primitives from the center.</td>
</tr>
<tr>
<td>Control</td>
<td>Grows plane and cube primitives from the center. (No effect on all other primitives.)</td>
</tr>
<tr>
<td>Shift</td>
<td>Constrains all primitives to three-dimensional equilateral proportions and grows them from the base.</td>
</tr>
</tbody>
</table>
**3 | Creating NURBS surfaces**

How do I? > Create a flat surface inside a curve

---

**Modifier key** | **Effect**
---|---
Control + Shift | Constrains all primitives to three-dimensional equilateral proportions and grows them from the center.

**To create a NURBS primitive with a single click using the options you select**

1. Select Create > NURBS Primitives > Interactive Creation if it is not already on.

   If you want to change the settings that the NURBS primitive is created with, such as Axis or Number of Spans, select Create > NURBS Primitive > Shape.

   There are specific Single-click settings for primitive creation.

2. Click in the scene view to create primitives.

**To create multiple NURBS primitives interactively or with a single click**

Turn Create > NURBS Primitives > Exit on Completion on.

**Other options**

As well, during interactive primitive creation, you can snap the polygon to existing objects in the scene. You have the following options (click the icon in the Status line or press the hotkey). Snap to:

- grid
- curves
- CV, vertex, or pivot
- live object

These snap options allow you, during the creation of your primitive, to snap to a projected point on the line or plane defined by any other object in your scene.

For more information, see "Snap to the grid, a curve, points, or a view plane" on page 72 and "Snap all creation tools to a surface or construction plane" on page 73 in the Basics book.

**Create a flat surface inside a curve**

The Planar action creates a flat, trimmed NURBS surface inside a curve.

1. Select a closed, planar curve, or multiple curves that form a closed, planar region.

   You can select multiple curves that form an enclose region by overlapping. They do not need to be connected end-to-end.
How do I? > Create a flat surface inside a curve

2 Choose Surfaces > Planar.

Notes

- You can use the Keep Outside attribute to create a trimmed surface with a hole cut of the enclosed region instead of a trimmed surface inside the enclosed region.
- You can edit the input curves to change the shape of the surface, but the surface must remain planar.
- Although a planar surface can include cut-out areas and holes, all curves must be co-planar even if they appear to create separate parts of the surface.

Related topics

- "Skin a surface across profile curves" on page 35
- "Create a surface within bounding curves" on page 38
- "Surfaces > Planar" on page 117
Skin a surface across profile curves

You can use the Loft action to create a surface between a series of cross-section or “profile” curves. The profile curves can be normal 3D curves, surface isoparms or edges, trim edges, or curves-on-surface.

To make a surface between profile curves

1. Pick the profile curves in order.
2. Select Surfaces > Loft.

Tip
If you need a uniform transition of the surface as it lofts through each profile curve (for example, a boat hull), space the curves evenly.

To add additional curves to a lofted surface

1. Select one of the curves you used to create the lofted surface.
   Maya displays the lofted surface in the construction history color to show its connection to the curve.
2. Select the curve you want to add, then select Surfaces > Loft.

Related topics

- “Sweep a profile curve along a path curve” on page 36
Sweep a profile curve along a path curve

The Extrude action creates a surface by sweeping a cross-section (or “profile”) curve along a path curve. The curves can be normal 3D curves, surface isoparms or edges, trim edges, or curves-on-surface. The ends of the extruded surface are open; however, you can create caps at each end using Surfaces > Planar.

To extrude a profile curve along a path curve

1. Select the profile curve or curves. Then select the path curve. Maya uses the key curve (the last curve you select) as the path.
2. Select Surfaces > Extrude.
3. Select the extrude node and choose the Show Manipulators tool to manipulate the extrude.

Tip
If the path curve changes direction abruptly, the cross section may twist around the path. If this happens, insert edit points in the path curve so its direction change is spread out across more CVs.
3 | Creating NURBS surfaces

How do I? > Sweep one or more profile curves along two path curves (birail)

To cap the end of an extruded surface

1. Select the isoparm at the end of the extruded surface.
   To do this, press the right mouse button on the extruded surface, and choose Isoparm from the marking menu. Then click the end of the extruded surface.

2. Select Surfaces > Planar to create a cap.

Related topics

- "Create a flat surface inside a curve" on page 33
- "Skin a surface across profile curves" on page 35
- "Sweep one or more profile curves along two path curves (birail)" on page 37
- "Surfaces > Extrude" on page 118
- "Surfaces > Planar" on page 117

Sweep one or more profile curves along two path curves (birail)

1. Select Surfaces > Birail > Birail n Tool based on how many profile curves you want to use (1, 2, or 3-or-more).

2. Click the curve(s) you want to use a profile curves, then click the two rail curves.
   Instructions appear on the help line at each step.
Create a surface within bounding curves

1. Select the boundary curves.
   If you select only three curves, Maya will create a “three-sided” surface (see notes below).

2. Choose Surfaces > Boundary.

Related topics
- "Skin a surface across profile curves" on page 35
- "Sweep a profile curve along a path curve" on page 36
- "Surfaces > Birail“ on page 124
If you turn on the Partial option to use a subsection of the curves, you can control which part of each curve Maya revolves by selecting the subcurve node in the channel box and editing the minValue and maxValue attributes. If you have the Show Manipulator tool selected, handles appear on the curves to allow you to drag the values.

Notes

- The order you select the input curves does not matter to the shape of the surface. However, order can affect parameterization of the curves and the resulting surface. Some of the curves may be reversed to make sure their start and end points match. The first curve you select is used for the surface U parameters. If you select opposing pairs of curves in order (that is select the first curve, then select the curve on the opposite side, then the third curve, then the curve opposite it), you can determine which curves will control which parameters.

- A three-sided surface is actually a 4-sided surface with one side collapsed to a zero length multi-knot (sometimes called a degenerate surface). These kinds of surfaces can sometimes be problematic in rendering and data transfer. If the end points of two side curves do not meet exactly, a short straight line segment will result instead of a zero length line.

- For a three-sided boundary surface, the zero-length side always appears where the first curve meets the second curve.

Related topics

- “Create a four-sided surface with continuity (Square)” on page 40
- “Create a surface between two sets of boundary curves” on page 46
- “Surfaces > Boundary” on page 127
Create a four-sided surface with continuity (Square)

Square creates a four-sided surface by filling a region defined by four intersecting boundary curves. The resulting surface can maintain continuity with surrounding surfaces depending on the options that you set. You can use a curve, isoparm, surface edge, or curve-on-surface as curve types for the square surface boundaries.

In order for a square surface to be created, the following conditions must exist:

- The four boundary curves must intersect.
- You must select the curves in either a clockwise or counter-clockwise direction.

**To create a square surface**

1. Make sure the four boundary curves intersect.
2. Select the four curves in a specific order (either clockwise or counterclockwise).
   - The first curve you select sets the U direction for the surface and the second curve sets the V direction.
3. Select Surfaces > Square.
4. In the toolbox, click Show Manipulators to view the continuity indicators.
   - Click the indicator on a side to set the requested continuity, or open the channel box and set the square surface’s continuityTypeN attribute (the numbers indicate the order you clicked the curves).

Maya will still attempt to create a surface even if it cannot achieve the requested continuity options.

**Troubleshooting square surfaces**

If a square surface fails to be created as you expect, you should check the following:

- Ensure that the four boundary curves intersect.
  - You can ensure the curves intersect by either snapping their end points to a common grid line, or by magnet snapping the end point of one curve to the end point of another.
- Check the validity of the curves you’re using as boundary curves.
  - For example, you cannot create a surface inside boundary curves with sharp corners, CV multiplicity, or multi-knots. A boundary curve should also not intersect with itself.
- If a surface fails to build, try selecting the curves in a different order.
  - You should ensure that the curves are shift-selected in either a clockwise or counter-clockwise direction. A drag selection, where you define a bounding box around the curves, will not work.
3 | Creating NURBS surfaces
How do I? > Create a surface using Revolve

- Check your positional and tangential tolerances in Window > Settings/Preferences > Preferences.
  Specifically check that the general Settings positional and tangential preferences are not set at a much larger value than your Square tolerance. If this is the case, Square may not be able to achieve the positional and tangency conditions specified.

Related topics
- "Continuity for NURBS curves and surfaces" on page 18
- "Create a surface within bounding curves" on page 38
- "Surfaces > Square" on page 128

Create a surface using Revolve

1. Draw a curve representing the cross-section (or “profile”) of the surface you want to create.
2. Select the curve and choose Surfaces > Revolve > ☐.
3. Set the revolve options:
   - Choose the initial axis around which to sweep the surface.
   - If you only want to revolve a subsection of the curve, set Curve Range to Partial.
4. In the toolbox, click the Show Manipulator tool to manipulate the surface.

If you turn on the Partial option to revolve a subsection of the curve, you can control which part of the curve Maya revolves by selecting the subcurve node in the channel box and editing the minValue and maxValue attributes. If you have the Show Manipulator tool selected, handles appear on the curve to allow you to drag the values.

Tips
- If you move the axis endpoints, the axis direction is modified. However, if you move the axis midpoints, the radius of the revolved surface is modified without affecting the axis direction.
Extrude and bevel a surface from a curve

Use Surfaces > Bevel to create an extruded surface with a beveled edge from any curve, including text curves and trim edges. For example, to create a ledge on a building, or the rolled edges on an upholstered chair.

Create a simple extrude and bevel

1. Select the curve.
   You can create beveled surfaces from normal 3D curves, isoparms, and surface edges.

2. Choose Surfaces > Bevel.

3. In the toolbox click the Show Manipulators tool to manipulate the beveled surface.

   If you turned on the Partial option, click the curve or isoparm heading in the channel box to show additional attributes for using only a subsection of the curve.
Bevel Plus

Bevel Plus has various features beyond Surfaces > Bevel operation:

- Creates a completely solid surface, including a cap on either end of the beveled curve. The surface will not break when you deform it, which is ideal for flying logos.
- Gives you various style options for the bevel shape.
- Gives you more control over the tessellation of the surface.

Bevel Plus is useful for creating solid letters and logos.

To bevel with Bevel Plus

1. Select a single curve. For shapes with a hole (such as a letter a), select the outer curve first and the inner curve second.

2. Choose Surfaces > Bevel Plus > □.
3. Set the options.
4. Click Bevel.
Related topics

- “Sweep a profile curve along a path curve” on page 36
- “Round off the meeting point between two edges” on page 44
- “Create a fillet between two surfaces” on page 45
- “Surfaces > Bevel” on page 129
- “Surfaces > Bevel Plus” on page 133

**Duplicate NURBS surface patches**

**To duplicate surface patches**

1. Select the patch or patches.
2. Select Edit NURBS > Duplicate NURBS Patches.

**Create NURBS transition surfaces**

**Round off the meeting point between two edges**

1. Select Edit NURBS > Round Tool.
2. Drag a selection box across the common edges between surfaces.
3. When you click a common edge, a radius manipulator appears. Drag the handles at the ends of the manipulator arms to change the rounding radius.
   To deselect an edge, click the manipulator on the edge and press Delete.
4. When you are done marking edges to be rounded, press Enter.

You can edit the radii of the fillets after you create them by selecting the Round node and using the channel box, attribute editor, or Show Manipulator tool.
If a fillet cannot be built with the current radius, the manipulator for that edge is drawn in red.

Notes

• Overlapping radii will fail or create unpredictable results.
  You can correct this by editing the radii with the Show Manipulator tool after the fillets are created. If the angle between the two surfaces is less than 15 degrees or greater than 165 degrees, the fillets produced might be inadequate.
• The edges you round must be from separate surfaces.
• If the edges have different lengths, a fillet surface will be created only for the shorter edge.
• Corners are points where pairs of edges meet. You cannot use the Round Tool on more than three pairs of corners.
  For example, you can use the Round Tool on all edges of a cube, but you cannot use it on the tip of a pyramid, where four edge pairs meet at the top.
• Acute corners may fail as the fillets begin to self-intersect.
• The radius manipulator approximates the profile of the fillet only when the surfaces meet at an angle of nearly 90 degrees.

Related topics

❖ "Extrude and bevel a surface from a curve" on page 42
❖ "Create a fillet between two surfaces" on page 45
❖ "Edit NURBS > Round Tool" on page 160

Create a fillet between two surfaces

Create a circular fillet

1 Select two intersecting surfaces.
2 Select Edit NURBS > Surface Fillet > Circular Fillet > ．
3 Do any of the following:
3 | Creating NURBS surfaces
How do I? > Create a surface between two sets of boundary curves

- Use the channel box, attribute editor, or Show Manipulator tool to change the radii.
- Select one of the surfaces and choose Edit NURBS > Reverse Surface Direction to change which side of the surface the fillet is built on.

Create a freeform fillet

1. Select an isoparm or curve-on-surface on each surface as the start and end points of the fillet.
2. Select Edit NURBS > Surface Fillet > Freeform Fillet.
3. Do any of the following:
   - Use the channel box, attribute editor, or Show Manipulator tool to edit the fillet.
   - To manipulate the isoparms used to create the fillet, select the one of the curveFromSurface nodes.

Related topics
- "Round off the meeting point between two edges" on page 44
- "Create a surface between two sets of boundary curves" on page 46
- "Edit NURBS > Surface Fillet > Circular Fillet" on page 161
- "Edit NURBS > Surface Fillet > Freeform Fillet" on page 163

Create a surface between two sets of boundary curves

You can build a blend between two boundaries defined by sets of surface curves. For example, you can use this tool to create a surface that forms a smooth juncture between a creature’s arm and torso.

1. Select Edit NURBS > Surface Fillet > Fillet Blend Tool.
2. Click the surface curves that form the first boundary, then press Enter. You can use isoparms, edges, or curves-on-surface.
3. Click the surface curves that form the second boundary, then press Enter.
If you edit the surfaces that provided the input curves for the blend, the blend updates automatically.

| Note | If you use the manipulator handles to adjust a fillet blend between straight lines (such as the edges of two planes), twisting and unexpected results may occur. |

**Troubleshooting a fillet blend surface**

If the resulting fillet blend surface is twisted, you can try the following:

- Reverse the direction of the surface curves at one end of the blend.
- If reversing the curves is undesirable, use the Reverse Direction Left/Right attribute to reverse the surface after it is created.

**Related topics**

- "Round off the meeting point between two edges" on page 44
- "Create a fillet between two surfaces" on page 45
- "Edit NURBS > Surface Fillet > Fillet Blend Tool" on page 164
3 | Creating NURBS surfaces
How do I? > Create a surface between two sets of boundary curves
**How do I?**

Reshape a curve or surface manually

To move CVs on a curve or surface

1. Choose the Move tool.
2. Press the right mouse button on the curve or surface and choose Control Vertex.
3. Select the CVs you want to edit and use the manipulator to move them.

| Tip | With a CV selected you can press the up and down keys to select the next/previous CV in the row. On a surface, press the left and right keys to select the next/previous CV in the column. |

| Note | Avoid tweaks (moving CVs) on objects with history. If you tweak an object with history, the tweak is applied to a specific component ID. Subsequent changes to the object’s history can cause the component IDs to change, altering the effect of the tweak. For example, if you revolve a curve to create a surface, then tweak CV number 3 on the surface, the tweak will always apply to CV number 3. If you later change the revolve node attributes to reduce the number of segments on the surface, the CV that you tweaked will now have a new number, and the tweak will no longer be applied to it. The tweak will be applied to the CV that is now number 3, which may be in a different location on the surface. |

To reshape a curve with the Curve Editing tool

1. Select Edit Curves > Curve Editing Tool.
2. Click the curve.
How do I? > Reshape a curve or surface manually

3 Do any of the following:
   • Drag the parameter position handle to move the manipulator along the curve.
   • Drag the point position handle to move this point. The curve will reshape so the curve passes through the point as you move it.
   • Drag the tangent direction handle to change the direction of the curve at this point.
   • Drag the tangent scale handle to change the “speed” of the curve at this point.
   • Click a dashed line to align the tangent at this point with one of the axes.

To reshape a surface with the Surface Editing tool
1 Select Edit NURBS > Surface Editing > Surface Editing Tool.
2 Click the surface.
   Tangent scale manipulator
   Tangent direction handle
   Tangent direction toggle
   Parameter position
   Point position
   Tangent world axis selector

3 Do any of the following:
   • Drag the parameter position handle to move the manipulator across the surface.
   • Drag the point position handle to move this point. The surface will reshape so the surface touches the point as you move it.
   • Click the tangent direction toggle (the double circle) to switch between editing the U, V, and Normal tangent.
   • Drag the tangent direction handle (the box) to change the tangent of the surface at this point.
   • Drag the tangent scale handle to change the “speed” of the tangent at this point.
   • Click a dashed line to align the tangent at this point with one of the axes.
To reshape a curve or surface with the Soft Modification tool

See the following:

- "Smooth a curve" on page 54
- "Extend a surface" on page 57
- "Sculpt a NURBS or polygon surface mesh" on page 128
- “What is soft modification?” in the Deformers guide
- “Use the Soft Modification Tool” in the Deformers guide
- “What are deformers?” in the Deformers guide

Align a curve with a curve or surface

Make a curve tangent or curvature continuous with a surface

1 Select the surface and then the curve.
2 Select Edit Curves > Project Tangent > □.
3 Set Construction to Tangent or Curvature.
4 Click Project.

Select the project tangent node and click the Show Manipulator tool to manipulate curvature scale, tangent scale, or tangent rotation.

Tips

The Surface Editing Tool deforms a region within two spans of the manipulator. Deformation decreases with distance from the tool position.

You can use Snap to curve to snap the manipulator to an isoparm, or Snap to grid to snap to a patch corner. The snapping occurs to the isoparms or patch corners that appear when you display the object with Display > NURBS Smoothness > Rough—not the isoparms or patch corners that appear only with finer Smoothness settings.
To make a curve tangent or curvature continuous with a curve intersection

1. Choose Edit Curves > Project tangent > □.
2. Click the curve or surface edge you want to modify, near the end which intersects the surface.
3. Click two intersecting curves that define a plane.

To make a curve tangent or curvature continuous with another curve

1. Make sure the endpoint of the curve you want to make tangent intersects the curves that define the plane.
2. Select the curve you want to reshape first, then select the other curves. The projected tangent is based on the key curve (the curve you select last, highlighted in green).
3. Select Edit Curves > Project Tangent > □.
4. Set Construction to Tangent or Curvature.
5. Click Project.

Edit a project tangent action

Select the project tangent node and click the Show Manipulator tool to manipulate curvature scale, tangent scale, or tangent rotation.

To align the ends of two curves

1. Select the points on the curves (or isoparms) where you want to align the curves.
2. Select Edit Curves > Align Curves.
What if...?

I can't project tangents at both ends of a curve?

The project tangent action “takes over” a few CVs at the end of the curve to maintain continuity. If there aren’t enough interior CVs to avoid overlap, you can’t use project tangent at both ends. Try inserting edit points to increase the number of CVs on the curve.

Related topics

- “Continuity for NURBS curves and surfaces” on page 18
- “Align surface edges” on page 53
- “Join curves or surfaces together” on page 58
- “Edit Curves > Align Curves” on page 86
- “Edit Curves > Intersect Curves” on page 89
- “Edit Curves > Project Tangent” on page 102

Align surface edges

To align surfaces

1. Select an edge on the first surface.
2. Shift-select an isoparm on the other surface. You can align the edge of the first surface to any isoparm on the second surface.
3. Select Edit NURBS > Align Surfaces.

Limitations

- You cannot align edges that are closed or periodic.
- You cannot align a surface to itself.
- Exact tangency or curvature continuity cannot be guaranteed if surfaces are rational.
- You cannot align to a trimmed edge. Align Surfaces uses the original surface edge, not its trimmed shape.

Related topics

- “Align a curve with a curve or surface” on page 51
- “Join curves or surfaces together” on page 58
Smooth a curve

The Smooth Curve action smooths out sharp changes in direction in a curve. This can be especially useful for curves created with the Pencil Curve tool and curves created from scan or translated data.

You cannot smooth a closed curve, surface isoparm, or curve-on-surface. Smooth Curves doesn’t change the number of CVs.

To smooth a curve or a selection of CVs

1. Select the curve, or select only the CVs you want to smooth.
2. Select Edit Curves > Smooth Curve.
   - To control the amount of smoothing, choose Edit Curves > Smooth Curve > ⬣ and set the Smoothness option. Lower values do less smoothing. The default value is 10.

Related topics

- “Smooth a surface mesh” on page 131
- “Display > NURBS” on page 299
- “Straighten, smooth, curl or bend a curve” on page 55
- “Edit Curves > Smooth Curve” on page 101

Lock or unlock the length of a curve

You can lock the length of a curve so that it maintains a constant hull length, even when you edit the curve (for example, by moving a CV).

To lock/unlock the length of a curve

1. Select the curve (or CVs).
2. Press and hold down the l (lower case L) key.
3. Modify the curve, and it will maintain a constant hull length.
4. To unlock the length, release the l (lower case L) key.

Note

You can also lock/unlock the length of a curve by selecting the curve (or CVs), and selecting Edit Curves > Modify Curves > Lock Length or Edit Curves > Modify Curves > Unlock Length, but be careful you don’t forget to unlock the length. Using the hotkey is better, because you’re not likely to forget to unlock the length.
Note  When you first lock the length of a curve, a Lock Length attribute is added to the curveShape node. You can thereafter lock/unlock the length of the curve by turning on/off the Lock Length attribute.

Related topics
- "Edit Curves > Modify Curves > Lock Length" on page 104
- "Edit Curves > Modify Curves > Unlock Length" on page 104

Straighten, smooth, curl or bend a curve

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Straighten a curve.</td>
<td>Select the curve (or CVs) and choose Edit Curves &gt; Modify Curves &gt; Straighten.</td>
</tr>
<tr>
<td>Smooth a curve.</td>
<td>Select the curve (or CVs) and choose Edit Curves &gt; Modify Curves &gt; Smooth.</td>
</tr>
<tr>
<td>Curl a curve.</td>
<td>Select the curve (or CVs) and choose Edit Curves &gt; Modify Curves &gt; Curl.</td>
</tr>
<tr>
<td>Bend a curve.</td>
<td>Select the curve (or CVs) and choose Edit Curves &gt; Modify Curves &gt; Bend.</td>
</tr>
<tr>
<td>Reduce or exaggerate a curve’s curvature.</td>
<td>Select the curve (or CVs) and choose Edit Curves &gt; Modify Curves &gt; Scale Curvature.</td>
</tr>
</tbody>
</table>

Tip  Because Straighten, Smooth, Bend, and Scale Curvature are actions that you apply to curves, you cannot interactively adjust their effect as you would with a tool. However, you can set the scaling of the tool very low (for example, set Straightness to 0.1) and repeatedly apply the action until the curve has the desired shape.

Related topics
- "Edit Curves > Modify Curves > Straighten" on page 105
- "Edit Curves > Modify Curves > Smooth" on page 106
- "Edit Curves > Modify Curves > Curl” on page 106
- "Edit Curves > Modify Curves > Bend” on page 106
Extend a curve

Add CVs or edit points to the end of a curve

1. Select the curve to add CVs, or select the last edit point to add edit points.
2. Select Edit Curves > Add Points Tool.
3. Click in the view to add new CVs or edit points.
4. Press Enter to finish the curve.

Extend a curve or curve-on-surface a certain distance

1. Select the curve.
2. Choose Edit Curves > Extend > Extend Curve > or Edit Curves > Extend > Extend Curve On Surface >.
3. Click Distance (or Parametric Distance for a curve-on-surface) and enter the distance you want to extend the curve. You can interactively change the distance in the channel box or attribute editor after you extend.
   
   For curves-on-surface the Parametric Distance sets a fraction of the surface length in the direction the curve runs. For instance, a value of 0.5 extends the curve length by roughly half the length of the surface in the direction the curve runs.
4. Do one of the following:
   - Click Linear to extend the curve in a straight line.
   - Click Circular to extend the curve in an arc.
   - Click Extrapolate to maintain tangent continuity with the current shape of the curve.
5. Set Extend Curve At to choose which end (or Both ends) to extend from.
6. To make the extension part of the current curve, turn on Join to Original. Turn this option off to make the extension a new curve.
7. Click Extend.

Extend one end of a curve or curve-on-surface out to exact coordinates

1. Select the curve.
2. Choose Edit Curves > Extend > Extend Curve > or Edit Curves > Extend > Extend Curve On Surface >.
3 Click Point (or UV Point for a curve-on-surface).
4 Set Extend Curve At to choose which end to extend from.
5 To make the extension part of the current curve, turn on Join to Original. Turn this option off to make the extension a new curve.
6 Click Extend.

Tip
When Keep Original is on in the Extend Curve option box, Maya will create an extend node on the curve. You can select the extend node in the channel box or attribute editor to tweak the extend operation, including distance, interactively.

Related topics
- “Extend a surface” on page 57
- “Edit Curves > Extend > Extend Curve” on page 92

Extend a surface

Extend a surface a certain distance
1 Select the surface.
2 Choose Edit Curves > Extend > Extend Surfaces.
3 Enter the distance you want to extend the curve. You can change the distance interactively in the attribute editor after you extend.
4 Do one of the following:
   • Click Tangent to add new isoparms as you extend.
   • Click Extrapolate to extend the shape without adding isoparms.
5 Choose which edge(s) you want to extend from.
   • Set Extend Side to Start, End, or Both.
   • Set Extend Direction to U, V, or Both.
   You can change the side controls interactively in the channel box or attribute editor after you extend.
6 Turn off Join to Original.
7 Click Extend.

Notes
- You cannot extend a trimmed surface.

Related topics
- “Extend a curve” on page 56
- “Edit NURBS > Extend Surfaces” on page 155
Select curve CVs: first, last or all

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select all CVs on a curve.</td>
<td>Select the curve and choose Edit Curves &gt; Selection &gt; Select Curve CVs (or press Ctrl + the right mouse button and choose To CVs).</td>
</tr>
<tr>
<td>Select the first CV on a curve.</td>
<td>Select the curve and choose Edit Curves &gt; Selection &gt; Select First CV on Curve (or press Ctrl + the right mouse button and choose To First CV).</td>
</tr>
<tr>
<td>Select the last CV on a curve.</td>
<td>Select the curve and choose Edit Curves &gt; Selection &gt; Select Last CV on Curve (or press Ctrl + the right mouse button and choose To Last CV).</td>
</tr>
</tbody>
</table>

Related topics
- “Edit Curves > Selection > Select Curve CVs” on page 108
- “Edit Curves > Selection > Select First CV on Curve” on page 108
- “Edit Curves > Selection > Select Last CV on Curve” on page 108

Edit NURBS curves and surfaces

Join curves or surfaces together

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Join curves at the ends that are closest.</td>
<td>Select the curves and choose Edit Curves &gt; Attach Curves.</td>
</tr>
<tr>
<td>To...</td>
<td>Do this</td>
</tr>
<tr>
<td>--------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Join two surfaces at the edges that are closest. | Select the surfaces.  
To move the surfaces together, choose Edit NURBS > Attach Surfaces.  
To fill the distance between the surfaces with new surface area, choose Edit NURBS > Attach Without Moving. |
| Join two curves at specific points. | Select a curve point on each curve where you want them to join and choose Edit Curves > Attach Curves. |
| Join two surfaces at specific isoparms. | Select an isoparm on each surface where you want them to join and choose Edit NURBS > Attach Surfaces. |

**Related topics**
- "Align surface edges" on page 53
- "Split a curve or surface (detach)" on page 59
- "Edit Curves > Attach Curves" on page 83
- "Edit NURBS > Attach Surfaces" on page 142

### Split a curve or surface (detach)

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
</table>
| Split a curve at some point. | Select the curve point at which you want to split the curve and choose Edit Curves > Detach Curves.  
When construction history is on, you can select the detach node and use the Show Manipulator tool to edit the detach point. |
| Split a surface at an isoparm. | Select the isoparm at which you want to split the surface and choose Edit NURBS > Detach Surfaces.  
You can select multiple isoparms to split the surface into multiple parts. |
### How do I? > Insert additional edit points/isoparms in a curve or surface to add more CVs

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Split a curve wherever it crosses another curve in a view.</td>
<td>Select the curves in the view where they overlap, then choose Edit Curves &gt; Cut Curve. You cannot split a curve with an isoparm or curve-on-surface. Use Edit Curves &gt; Duplicate Surface Curves to create a new curve from the isoparm or curve-on-surface you want to use.</td>
</tr>
</tbody>
</table>

**Related topics**
- "Join curves or surfaces together" on page 58
- "Edit Curves > Detach Curves" on page 85
- "Edit NURBS > Detach Surfaces" on page 144

### Insert additional edit points/isoparms in a curve or surface to add more CVs

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert an edit point in a curve to add more CVs.</td>
<td>Select the curve point at which you want to insert the edit point and choose Edit Curves &gt; Insert Knot.</td>
</tr>
<tr>
<td>Insert an isoparm in a surface to add more CVs.</td>
<td>Select the isoparm at which you want to insert a new patch isoparm and choose Edit NURBS &gt; Insert Isoparms. You can select multiple isoparms to insert at once.</td>
</tr>
</tbody>
</table>

When the Keep Original option is on in the option box (Edit Curves > Insert Knot >  or Edit NURBS > Insert Isoparms > ) you can select the Show Manipulator tool to reposition the new edit point or isoparm after you insert it.

**Related topics**
- "Edit Curves > Insert Knot" on page 91
- "Edit NURBS > Insert Isoparms" on page 153
Create an offset copy of a curve or surface

Creates a copy of a curve or surface that is offset from the original (every point on the copy is a specific distance from the corresponding point on the original).

Create an offset copy of a curve

1. Do one of the following:
   - Select a curve or isoparm, then choose Edit Curves > Offset > Offset Curve.
   - Select a curve-on-surface, then choose Edit Curves > Offset > Offset Curve On Surface.

2. An offset curve is created at a default offset distance of 1.0.

3. In the toolbox, click the Show Manipulator tool and use the manipulator to change the offset distance.

Create an offset copy of a surface

1. Select the surface.
2. Select Edit NURBS > Offset Surfaces > .
3. Do one of the following:
   - To preserve surface curvature, set Method to Surface Fix.
   - To preserve CV layout, set Method to CV Fix.

4. Enter a distance to offset. You can change the distance interactively in the channel box or attribute editor after you offset.

5. Click Extend.
Related topics
- "Edit Curves > Offset > Offset Curve, Offset Curve on Surface" on page 95
- "Edit NURBS > Offset Surfaces" on page 156

Reverse the direction of a curve or surface normals

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reverse the direction of a curve.</td>
<td>Select the curve and choose Edit Curves &gt; Reverse Curve Direction.</td>
</tr>
<tr>
<td>Reverse the direction(s) and normals of a surface.</td>
<td>Select the surface and choose Edit NURBS &gt; Reverse Surface Direction &gt; □ and choose the surface direction to reverse, or swap to swap U and V.</td>
</tr>
</tbody>
</table>

Related topics
- "Normals" on page 14
- "Components of NURBS curves" on page 19
- "Edit Curves > Reverse Curve Direction" on page 97
- "Edit NURBS > Reverse Surface Direction" on page 156

Reduce the complexity of a curve or surface

Reduce the complexity of a curve

1. Select the curve.
2. Choose Edit Curves > Rebuild Curve > □.
3. Set Rebuild Type to Reduce.
4. To use the global tolerance set in the preferences, click Global. To set a tolerance manually, click Local and enter a tolerance value.
   The tolerance controls how close points on the reduced curve must be to the original. Higher numbers allow more reduction by loosening how closely the reduced curve must match the original.
5. Click Rebuild.
Reduce the complexity of a surface

1. Select the curve.
2. Choose Edit NURBS > Rebuild Surfaces > \textsuperscript{\textbullet}.
3. Set Rebuild Type to Reduce.
4. To use the global tolerance set in the preferences, click Global. To set a tolerance manually, click Local and enter a tolerance value.
   The tolerance controls how close points on the reduced curve must be to the original. Higher numbers allow more reduction by loosening how closely the reduced curve must match the original.
5. Click Rebuild.

Related topics
- "Control multi-knots and CV hardness" on page 63
- "Automatically add spans to areas of a curve with high curvature" on page 65
- "Edit Curves > Rebuild Curve" on page 97
- "Edit NURBS > Rebuild Surfaces" on page 156

Control multi-knots and CV hardness

Multi-knots are multiple edit points at the same location that create a sharp bend or corner in a curve. For example, the Create > Text tool creates curves with multi-knots to represent letters with sharp corners.

To set the hardness of a CV

"Hardening" a CV creates multiknots that make the curve take a sharp turn at the CV.

1. Select the CVs.
   You can only harden a CV if the previous and next CVs on the curve are not hardened.
2. Select Edit Curves > CV Hardness > \textsuperscript{\textbullet}.
3. Do one of the following:
   - Click Full to make this a hard CV, resulting in a sharp bend in the curve.
   - Click Off to make this a normal CV, resulting in a normal (softer) bend of the curve.
4. If you turn on Keep Original, Maya will create a new curve with the hardness applied to the CV. In the dependency graph, you can see a node that takes the original curve, hardens the CV, and outputs a new curve.

You can select this node and turn the hardness on or off using the Multiplicity slider in the attribute editor.
If you turn off Keep Original, the operation applies to the CV on the original curve and is not editable.

5 Click Harden.

**To add or remove a tangent break at an isoparm**

A tangent break inserts multi-knots along an isoparm to break tangent continuity. This lets you make a sharp bend in the surface along the isoparm. The shape of the surface doesn’t immediately change.

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Break tangency along an isoparm.</td>
<td>Select the isoparm and choose Edit Surfaces &gt; Surface Editing &gt; Break Tangent.</td>
</tr>
<tr>
<td>Break tangency along isoparms in both directions.</td>
<td>Select a surface point and choose Edit Surfaces &gt; Surface Editing &gt; Break Tangent.</td>
</tr>
<tr>
<td>Break an arbitrary tangent.</td>
<td>Use the Surface Editing tool to select the tangent direction, then choose Edit Surfaces &gt; Surface Editing &gt; Break Tangent.</td>
</tr>
<tr>
<td></td>
<td>&quot;Reshape a curve or surface manually&quot; on page 49</td>
</tr>
<tr>
<td>Smooth a broken a tangent.</td>
<td>Select the isoparm and choose Edit Surfaces &gt; Surface Editing &gt; Smooth Tangent.</td>
</tr>
</tbody>
</table>

**Note**

Edit Surfaces > Surface Editing > Break Tangent sometimes doesn’t work for U direction isoparm of closed surface.

If this happens, use Edit NURBS > Move Seam first.

**To remove multi-knots from a curve**

1 Select the curve.
2 Choose Edit Curves > Rebuild Curve > 🔧.
3 Set Rebuild Type to No Multiple Knots.
4 Click Rebuild.
How do I? > Automatically add spans to areas of a curve with high curvature

To remove multi-knots from a surface

1. Select the curve.
2. Choose Edit NURBS > Rebuild Curve > □.
3. Set Rebuild Type to No Multiple Knots.
4. Click Rebuild.

Related topics
- "Edit Curves > CV Hardness" on page 101
- "Edit NURBS > Rebuild Surfaces" on page 156
- "Edit NURBS > Surface Editing > Surface Editing Tool, Break Tangent, Smooth Tangent" on page 176

Automatically add spans to areas of a curve with high curvature

This action inserts more edit points/CVs in areas of high curvature. This gives you finer control for reshaping the curve.

1. Select the curve.
2. Choose Edit Curves > Rebuild Curve > □.
3. Set Rebuild Type to Curvature.
4. Click Rebuild.

Related topics
- "Edit Curves > Rebuild Curve" on page 97

Convert a curve or surface to uniform parameterization

Convert a curve to uniform parameterization

1. Select the curve.
2. Choose Edit Curves > Rebuild Curve > □.
3. Set Rebuild Type to Uniform.
4. Click Rebuild.

Convert a surface to uniform parameterization

1. Select the surface.
2. Choose Edit NURBS > Rebuild Surfaces > □.
3. Set Rebuild Type to Uniform.
4. Click Rebuild.
How do I? > Convert a surface to non-rational geometry

**Related topics**
- "Parameterization of NURBS curves and surfaces" on page 12
- "Edit Curves > Rebuild Curve" on page 97
- "Edit NURBS > Rebuild Surfaces" on page 156

**Convert a surface to non-rational geometry**

1. Select the surface.
2. Choose Edit NURBS > Rebuild Surfaces > .
3. Set Rebuild Type to Non-Rational.
4. Click Rebuild.

**Related topics**
- "Edit Curves > Rebuild Curve" on page 97
- "Edit NURBS > Rebuild Surfaces" on page 156

**Change a curve or surface’s degree or number of spans/patches**

**Change a curve’s degree or overall number of spans**

1. Select the surface.
2. Choose Edit NURBS > Rebuild Curve > .
3. Set Rebuild Type to Uniform.
4. Set the Number of Spans and Degree options.

**Change a surface’s degree or overall number of patches**

1. Select the surface.
2. Choose Edit NURBS > Rebuild Surfaces > .
3. Set Rebuild Type to Uniform.
4. Set the Number of Spans U, Number of Spans V, Degree U, and Degree V options.

**Divide surface patches by inserting isoparms**

- "Insert additional edit points/isoparms in a curve or surface to add more CVs” on page 60

**Related topics**
- "Degree of NURBS curves and surfaces” on page 12
### Make a curve or surface open or closed

<table>
<thead>
<tr>
<th>To...</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Join the ends of a curve together to make a periodic (closed) curve.</td>
<td>Select an open curve and choose Edit Curves &gt; Open/Close Curves.</td>
</tr>
<tr>
<td>Make a periodic (closed) curve non-periodic.</td>
<td>Select the start CV (the CV that looks like a hollow box) and choose Edit Curves &gt; Detach Curves.</td>
</tr>
<tr>
<td>Separate the ends of a periodic (closed) curve.</td>
<td>Select a closed curve and choose Edit Curves &gt; Open/Close Curves. Maya opens the curve and reshapes it so its endpoints are separated.</td>
</tr>
<tr>
<td>Join edges of a surface to make a periodic (closed) surface.</td>
<td>Select an open surface and choose Edit NURBS &gt; Open/Close Surfaces &gt;  [ ]. Click U, V, or Both to choose which edges to join.</td>
</tr>
<tr>
<td>Move the seam of a closed (periodic) curve.</td>
<td>Select an curve point on the curve and choose Edit Curves &gt; Move Seam. The seam will move to the edit point nearest your selected point.</td>
</tr>
<tr>
<td>Move the seam of a closed (periodic) surface.</td>
<td>Select an isoparm on the surface and choose Edit NURBS &gt; Move Seam. The seam will move to the patch isoparm nearest your selected isoparm.</td>
</tr>
<tr>
<td>Change the direction in which a surface is periodic.</td>
<td>Select the surface and choose Edit NURBS &gt; Open/Close Surfaces &gt;  [ ]. Click U, V, or Both to choose which edges are periodic.</td>
</tr>
</tbody>
</table>

### Related topics
- "Periodic, closed, and open geometry" on page 15
Match the topology of one curve to another

1. Select the curve you want to rebuild and then the curve it should match.
2. Choose Edit Curves > Rebuild Curve > □.
3. Set Rebuild Type to Match Knots.
4. Click Rebuild.

Related topics
- "Edit Curves > Rebuild Curve” on page 97
Trimming NURBS surfaces

NURBS surfaces are intrinsically four-sided patches that do not allow for the creation of holes in the same fashion as polygon surface types. You can visually simulate irregular shapes and holes when using NURBS by trimming the surfaces.

Trimming lets you visually cut or divide a surface by using a special type of curve called a curve-on-surface. You can create a curve-on-surface using a variety of techniques. When you subsequently trim the surface, the region of the surface that is trimmed away is not actually discarded. It exists in a hidden form that does not render or affect modeling. You can recover the trimmed part of a surface using the Untrim tool.

It is possible to trim multiple intersecting surfaces at once using the Booleans feature. For more information please see “NURBS Booleans” on page 70.

**Note**

Many features in Maya create surfaces that result in trimmed surfaces. The modeling features that create trimmed surfaces include:

- Create > Text
- NURBS > Planar
- Edit NURBS > Booleans
- Edit NURBS > Round
- Edit NURBS > Surface Fillet

**Related topics**

- “Create a curve-on-surface” on page 71
- “Trim or untrim a NURBS surface” on page 73
- “NURBS Booleans” on page 70
- “Perform boolean operations on surfaces” on page 74
NURBS Booleans

Booleans are a feature you can use to trim multiple NURBS surfaces in one operation. Booleans provide a faster workflow by letting you trim multiple surfaces at once versus having to intersect each surface separately.

Three types of boolean operations possible in Maya:

- **Union booleans** - Combines two or more objects and discards the regions that overlap.
- **Intersection booleans** - Combine two or more objects and keeps only the regions that overlap.
- **Difference booleans** - Combines two or more objects and subtracts the overlapping region from the first object.

Related topics

- “Trimming NURBS surfaces” on page 69
- “Perform boolean operations on surfaces” on page 74

Curves-on-surface

*Curves-on-surface* are special curves that are primarily used to define the regions on a NURBS surface for trimming. Curves-on-surface reside in the UV space of a surface, rather than in the XYZ space of the scene.

You can create curves-on-surface by:

- **Projecting** an existing XYZ world space curve onto a surface.
- **Intersecting** existing surfaces together. The curve-on-surface is created along the region of intersection.
- **Drawing** directly on the surface. Click the magnet icon on the toolbar to make a surface “live”, then use the curve creation tools to draw a curve-on-surface directly on the surface.
For a region to trim successfully, the curve-on-surface must fully enclose a region on the surface to be trimmed, or bisect the surface to be trimmed.

Curves-on-surface are primarily used to trim surfaces, and can also be used as an edge for new surfaces.

Curves on surface (along with their edit points) have a special Move manipulator. When you move a curve on surface, the manipulator constrains the curve on surface to the surface and allows movement across the surface in U and V.

**Related topics**
- "Create a curve-on-surface" on page 71
- "Trim or untrim a NURBS surface" on page 73
- "Trimming NURBS surfaces" on page 69

**How do I?**

**Create a curve-on-surface**

Maya provides several techniques for creating a curve-on-surface:

- “Draw a curve-on-surface by placing edit points”
- “Project a curve onto a surface along the view direction”
- “Project a curve onto a surface along the surface’s normals”
- “Intersect two surfaces to create a curves on surface”

**Draw a curve-on-surface by placing edit points**

1. Select the surface on which you want to draw a curve-on-surface.
2. In the toolbar, click the “Make the selected object live” icon.
How do I? > Create a curve-on-surface

3 Choose Create > CV Curve Tool or Create > EP Curve Tool.
4 Draw a curve on the live surface.
5 When the curve is finished, click the “Make selected object live” icon again.

Project a curve onto a surface along the view direction
1 Select a surface and one or more curves.
   Select the objects in a view pointing in the direction you want to project. For example, if you want to project along Y, select the objects in the Top view.
2 Select Edit NURBS > Project Curve on Surface > and set Project Along to Active View.
3 Click Project.

Project a curve onto a surface along the surface’s normals
1 Select a surface and one or more curves.
2 Select Edit NURBS > Project Curve on Surface > and set Project Along to Active View.
3 Click Project.

Intersect two surfaces to create a curves on surface
1 Select two surfaces.
2 Select Edit NURBS > Intersect Surfaces.
   The default is to create curves-on-surface on both surfaces. To only create curves-on-surface on the first or second surface, open the option box (Edit NURBS > Intersect Surfaces > ) and set the Create Curves For option.
Notes

- If a curve on surface has been created using project curve or intersect surfaces with construction history enabled, performing delete components on such curves before deleting construction history may create data loss when saving into a file. Delete construction history before deleting components.

Related topics

- “Trim or untrim a NURBS surface” on page 73
- “Edit NURBS > Project Curve on Surface” on page 137
- “Edit NURBS > Intersect Surfaces” on page 140
- “Curves-on-surface” on page 70

Trim or untrim a NURBS surface

Trimming removes (actually hides) any region of a surface that is bounded or bisected by a curves-on-surface. Trimming a surface lets you create complex edges and holes in NURBS surfaces. You must create curves-on-surface before you can trim the surface.

Trim a surface

1. Choose Edit NURBS > Trim Tool.
2. Click the surface you want to trim.
   - A “trim grid” appears on the surface.
3. Click the regions (defined by curves-on-surface) of the surface you want to keep (you do not need to hold Shift to click multiple regions).
   - As you click, regions that will be trimmed away are dotted, and regions that will be kept are solid.
   - If you want to change the tool so you click the parts of the surface you want to trim off, open the option box (Edit NURBS > Trim Tool >  □  ) and set Selected State to Discard.
4. Press Enter to trim.

Tip

A seam can divide a region in two. Make sure when you click a region bisected by the seam that both sides are marked.
How do I? > Perform boolean operations on surfaces

**Untrim a surface**

1. Select the surface or surfaces you want to untim.
2. Choose Edit NURBS > Untrim Surfaces.

   The default is to remove all trims from the surface, restoring it to its original state. To only reverse the most recent trim operation, open the option box (Edit NURBS > Untrim Surfaces > □) and set Untrim to Last.

If you turned on the Shrink Surface option when you trimmed the surface, Untrim cannot restore the original shape of the surface.

**Notes**

- If a NURBS primitive cone or cylinder with cap(s) is to be involved in a subsequent trimming operation, they must be created with the Extra Transformation option set to on, or the surface for trim will only be selectable in the outliner/hypergraph and not in the view.

**Related topics**

- “Trimming NURBS surfaces” on page 69
- “NURBS Booleans” on page 70
- “Curves-on-surface” on page 70
- “Create a curve-on-surface” on page 71
- “Perform boolean operations on surfaces” on page 74
- “Edit NURBS > Trim Tool” on page 141
- “Edit NURBS > Untrim Surfaces” on page 141

**Perform boolean operations on surfaces**

Boolean operations are actions that trim surfaces to create the appearance of a union, intersection, or subtraction between two objects.

**To perform a boolean operation on a surface**

1. Choose an action from the Edit NURBS > Booleans submenu.
   - Union trims the surfaces so they appear to be merged.
   - Difference trims the surfaces so that the volume of the second surface appears to be subtracted from the first.
   - Intersection trims the surfaces so that only their shared volume remains.

2. Click the first surface and press Enter. Then click the second surface.

   The order in which you click the surfaces only matters for the Subtract tool. Maya subtracts the second surface you click from the first.
Maya groups the combined surfaces.

You can make the following adjustments after creating the Boolean shape:

- To change the Boolean operation, such as changing Difference boolean to an Intersection boolean, select the boolean node in the Channel Box and change the Operation option.
- You can select the node of one of the original objects in the outliner or hypergraph.

Note: The only way to retrieve the original objects after a Boolean operation is to use Undo.

Troubleshooting boolean operations

If you get a “node a valid NURBS shell” error it means the boolean tool cannot create meaningful geometry from the surfaces you clicked.

For example, in the following illustration, the horizontal cylinder does not enclose a space that can be combined with the vertical cylinder. If you move the horizontal cylinder up, the boolean actions will work.
5 | Trimming
How do I? > Perform boolean operations on surfaces

**Related topics**
- "Trim or untrim a NURBS surface" on page 73
- "Edit NURBS > Booleans > Union Tool, Difference Tool, Intersection Tool" on page 142
How do I? Stitch multiple surfaces together

Global Stitch is useful for preventing adjacent surfaces from splitting apart during animation in situations where deformations could pull the edges apart. It works by automatically stitching two or more adjacent surfaces together. Even though the surfaces become stitched, they remain as separate entities. A Global Stitch node is created to maintain the relationship between the surface edges. Global Stitch can also close small gaps in adjacent surfaces as part of the stitch operation.

For example, if you create a human face from multiple surfaces, then use clusters and lattices to deform facial characteristics, Global Stitch can be used to prevent the surfaces from splitting apart as you deform the face.

To stitch surfaces together

1 Model your surfaces so that adjacent surface edges and corners are touching. That is, ensure that edges have positional continuity across their shared boundaries as much as possible to ensure best results. Avoid overlapping corners with other surfaces. If necessary, you can have the surface normals face opposite directions.

2 Select the surfaces.

3 Select Edit NURBS > Stitch > Global Stitch > .

4 Set the options.

5 Click Global Stitch.

Global Stitch stitches the surfaces. You can adjust the stitch attributes in the Attribute Editor if you need to enhance or change any stitch settings.
How do I? > Manually stitch surface edges together

Notes
- If the surfaces to be joined have position gaps or dissimilar tangency, the stitched surface might be wavy in the stitch region. You can also align the surfaces prior to stitching to minimize this.
- If the parameter range on surfaces is small, there may be problems when applying a global stitch to such surfaces. Rebuild the surfaces to have a parameter range running from 0 to the number of spans.

Lock a stitched surface to its original shape
You can “lock” certain surfaces so they won’t deform (the surfaces stitched to them will deform more to maintain stitching).
1. Make note of the name of the surface you want to lock.
2. Select the stitch node.
3. In the attribute editor, find the “input surface” number that corresponds to the surface you want to lock.

4. In the Lock Surfaces section, click the checkbox for the surface number you want to lock.

Related topics
- "Manually stitch surface edges together" on page 78
- "Manually stitch surface points together" on page 79
- "Edit NURBS > Stitch > Global Stitch" on page 171

Manually stitch surface edges together

To stitch surface edges
1. Select Edit NURBS > Stitch > Stitch Edges Tool.
2. Select the edge isoparms on each surface you want to stitch together.
How do I? > Manually stitch surface points together

1 Select the points on the first surface.
2 Select the points on the second surface.

A temporary stitch surface is created.

3 You can drag the manipulators to edit the extent of the stitching.

4 Press Enter to finish the stitch.

Related topics
- “Stitch multiple surfaces together” on page 77
- “Manually stitch surface points together” on page 79
- “Edit NURBS > Stitch > Stitch Edges Tool” on page 169

Manually stitch surface points together

To stitch surfaces together at individual points

1 Select the points on the first surface.
2 Select the points on the second surface.
3 Select Edit NURBS > Stitch > Stitch Surface Points.

You can control how much each surface pulls toward the stitched point on the other surface. Select the stitchSrf node attached to the surface you want to control. Edit the bias attribute to control how much the surface is pulled to the other surface. Higher values pull toward the meeting point with the other surface more. A value of 1 touches the other surface. A value of 0 means the stitching doesn’t affect the surface at all.

Related topics
- “Stitch multiple surfaces together” on page 77
- “Manually stitch surface edges together” on page 78
- “Edit NURBS > Stitch > Stitch Surface Points” on page 169
7 Sculpting surface meshes

About

Using the Sculpt Geometry Tool for NURBS

The Sculpt Geometry Tool lets you manually sculpt NURBS, polygons, or subdivision surfaces quickly with the stroke of a brush. You simply paint the surface mesh using the Sculpt Geometry Tool to push or pull CVs (NURBS) or vertices (polygons and subdivision surfaces) to achieve the shape you want.

The Sculpt Geometry Tool is based on the Maya® Artisan™ tools. For more information, see “How Artisan brush tools work” in the Artisan guide and the related topics listed below which are found in the Polygon Modeling guide.

Related topics
• “The Sculpt Geometry Tool” on page 125
• “Sculpt a NURBS or polygon surface mesh” on page 128
• “Smooth a surface mesh” on page 131
• “Relax a surface mesh” on page 132
• “Erase surface sculpting to an earlier state” on page 134
• “Sculpt according to an attribute map on NURBS” on page 134
• “Sculpt across seams and surface edges on NURBS” on page 135
• “Keyframe sculpting changes” on page 135
• “Mesh > Sculpt Geometry Tool” on page 205
7 | Sculpting surface meshes
About > Using the Sculpt Geometry Tool for NURBS
Reference  Edit Curves

Edit Curves > Duplicate Surface Curves

Creates a new NURBS curve from the selected surface edge, isoparm, or curve-on-surface.

Related topics
- “Create a curve from a surface edge, isoparm, or curve-on-surface” on page 26
- “Edit Curves > Offset > Offset Curve, Offset Curve on Surface” on page 95

Edit Curves > Duplicate Surface Curves > Group With Original

Creates the duplicated curve as a child of the surface from which it was created. This affects transformations applied to the curve (or surface).

For example, duplicate a cylinder isoparm, move the middle CV of the resulting curve in X, then rotate the cylinder 90 degrees about Z. If this option is turned on, the center CV of the curve is moved in X. If off, the center CV is moved in Y.

Visible Surface Isoparms

Lets you duplicate all isoparms of an object in the U, V, or U and V directions. This option works only when the entire surface is selected.

U specifies all isoparms in the U direction.

V specifies all isoparms in the V direction.

Both specifies both U and V directions (all isoparms).

Edit Curves > Attach Curves

Joins NURBS curves together at their endpoints to form a new curve. You can select two or more curves for attaching.

Related topics
- “Join curves or surfaces together” on page 58
**Edit Curves > Attach Curves > □**

**Attach Method**
- **Connect**: Joins the curves with minimal curvature smoothing at the join point.
- **Blend**: Smooths the curvature at the join point based on the Blend Bias value.

**Multiple Knots**
- **Keep**: Creates multiple knots at the join points. This lets you break the curvature continuity at the join points.
- **Remove**: Discards multiple knots at the join points. This creates smooth curvature at the join points.

**Blend Bias**
- Tunes the continuity at the join point.

**Insert Knot**
- This option is available only when you use the Blend option. In conjunction with the Insert Parameter value, Insert Knot lets you match the blend region to the original curves more closely.

- This option has significant effect only if the original curves are not aligned precisely (they approach each other at an angle) and have lengthy distances between the last two knots on each original curve near the join points.

- Insert Knot creates two extra knots near the join points. Each is within one span of the points being joined from the original curves. You can adjust the positioning of the extra knots with the Insert Parameter value.

**Insert Parameter**
- Adjusts the positioning of the knots added when you turn on Insert Knot. The closer the value is to 0 (without reaching 0), the closer the blend shape resembles the curvature of the original curves at the join point. This occurs because the added knots are inserted closer to the end knots nearest the blend point. Valid values are from 0 to 1.

- The following figures show the same blended curve resulting from two identical input curves. The top blended curve has Insert Knot turned off. The bottom blended curve has Insert Knot turned on with an Insert Parameter value of 0.3. The closer Insert Parameter is to 0, the closer the blended curve resembles the end shape of the original curves.
To adjust this option interactively, create the blended curve with "Insert Knot" turned on. Then select the curve, display the Channel Box, select "attachCurve" in the INPUTS section, and edit the Parameter option.

**Keep Originals**

Keeps the original curves after creating the attached curve. Do not turn this option off if construction history is on; the attached curve might deform oddly if you scale or otherwise modify it.

If you want to scale the attached curve without altering its basic shape, make sure construction history and Keep Original are both off, or both on.

**Editing the resulting curve attributes**

To view and edit the options of an attached curve, select the curve, display the Channel Box, and select "attachCurve" in the INPUTS section. The following option is the only one not available in the options window:

**Reverse 1 & 2**

Attach Curves attaches the two ends of the curves that are closest. You can use these options to change which ends are attached. Turn the options on and off in various combinations until you get the desired result.

**Edit Curves > Detach Curves**

Splits a curve into two new curves.

**Related topics**

- “Split a curve or surface (detach)” on page 59

**Edit Curves > Detach Curves > □**

**Keep Original**

Retains the original curve when you detach part of it.
Edit Curves > Align Curves

Aligns the endpoints of curves.

Related topics

- "Align a curve with a curve or surface" on page 51

Edit Curves > Align Curves > □

Attach

Joins the curves. If you turn this option on, turn Construction History off or the curve might deform oddly when you transform it.

Multiple Knots

Keep creates multiple knots at the attached region, which lets you break the curvature continuity there.

Remove deletes as many knots as possible without changing the shape of the attached region.

Continuity

Position causes the two points to meet exactly.

Tangent causes the tangency at the two points to match.

Curvature causes the two points to meet with the same arch in curvature. When this option is selected, the curvature scale sliders are available.

Modify Position

First moves the entire first curve to the second curve.

Second moves the entire second curve to the first curve.

Both moves both curves halfway.

Modify Boundary

First moves the selected point of the first curve to the second curve.

Second moves the selected point of the second curve to the first curve.
Both moves the selected points of both curves halfway.

Modify Tangent
- First adjusts the tangent of the first curve selected.
- Second adjusts the tangent of the second curve selected.

Tangent Scale
First and Second
- First increases or decreases the tangent magnitude of the first curve selected.
- Second increases or decreases the tangent magnitude of the second curve selected.

Curvature Scale
First and Second
- First increases or decreases the curvature of the first curve selected.
- Second increases or decreases the curvature of the second curve selected.

Keep Original
- Retains the original curves and aligns copies of the curves.

Edit Curves > Open/Close Curves
Converts a curve between open and closed/periodic.

Related topics
- "Periodic, closed, and open geometry" on page 15
- "Make a curve or surface open or closed" on page 67

Edit Curves > Open/Close Curves > □
Shape
- Ignore does not preserve the shape of the original curve.
- Preserve adds or deletes control vertices as necessary to preserve the shape of the original curve. This is the default setting.
- Blend tries to create continuity on the resulting curve. It uses the Blend Bias for the amount of smoothing.

Blend Bias
- Alters the amount of continuity for the resulting curve. Large values might distort the tangency of the original curve.
Insert Knot

Inserts a knot at the join point and lets you set a value for the Insert Parameter. This option is available only if you select Blend.

Insert Parameter

Sets the amount of influence the inserted knot has on the curve shape.

Keep Original

Retains the original curve after opening or closing the curve.

Edit Curves > Move Seam

Moves the join point of a closed/periodic curve to the selected edit point.

Related topics

● "Make a curve or surface open or closed" on page 67

Edit Curves > Cut Curve

Splits curves wherever they cross a cutting curve in the view.

Related topics

● "Split a curve or surface (detach)" on page 59

Edit Curves > Cut Curve > □

Cut

At All Intersections cuts curves at all intersecting points of selected curves.

Using Last Curve cuts only the last curve selected.

Keep

Longest Segments deletes all but the longest piece of each cut curve.

All Curve Segments keeps all curves after the cut.

Segments with Curve Points keeps all curve segments that have curve points selected on them. If no curve points are selected for a curve, no segments are discarded.

Keep Original

Keeps the original curves and creates new curves from the cut.
Edit Curves > Intersect Curves

Use Edit Curves > Intersect Curves to create curve point locators where two or more independent curves touch or cross one another in a view or direction. Intersect Curves is commonly used with Cut Curve, Detach Curve, and Snap to Point.

Related topics

- "Align a curve with a curve or surface" on page 51

Edit Curves > Intersect Curves > □

Find Intersections

- In 2D and 3D creates intersection points where the curves cross one another in the active view.
- In 3D Only creates intersections only where curves actually touch one another.

Use Direction

- Specifies which axis or view to use to create intersection points.
- X, Y, and Z create intersections along the direction of the axis chosen.
- Active View create intersections in the active camera view.
- Free lets you specify the axis of intersection in the Direction boxes.

Intersect

- All Curves creates intersections for all selected curves.
- With Last Curve Only creates intersections for only the last curve selected. Turn this on to create intersections where several curves overlap one curve.

Use Tolerance

- Global uses the Positional Tolerance value in the Settings part of the Preferences window.
- Local lets you enter a value to override the value in the Preferences window.

Note

Several NURBS menu items provide Use Tolerance as way to increase how precisely Maya creates a curve or surface. For example, you can create a revolved surface with a preset number of sections or you can enter a low Tolerance value to create more surface sections.
Edit Curves > Curve Fillet

Trim

Keeps only the parts of the original curves that flow toward the fillet curve ends. Other parts are deleted.

![Freeform fillet with Trim turned off](image1) ![Same fillet with Trim turned on](image2)

Join

Joins the trimmed curves to the fillet curve, thereby creating a single curve. Available only when Trim is on.

![When Join is turned off, the trimmed curves are not joined to the fillet curve.](image3) ![When Join is turned on, the trimmed curves and the fillet curve are joined.](image4)

Keep Original

Retains the original curves used to create the fillet. This allows you to create a curve fillet again for the curves but with different settings.

Construction

Circular creates a semicircular arc.

Freeform creates a curve that's determined by the curve points you selected before the Curve Fillet operation.

Radius

Sets how sharply a circular fillet arcs.

Freeform Type

Tangent puts the freeform fillet's apex near the intersection corner.

Blend puts the freeform fillet's apex near the midpoint between the curve points you selected before the Curve Fillet operation.

Blend Control

Adjusts the fillet shape curvature by enabling Depth and Bias. Note that if Blend Control is on for a circular fillet, the fillet will not be circular.
Depth
The higher the Depth, the deeper the fillet curve is positioned in the intersection corner.

Bias
Controls whether the fillet curve warps in the direction of one curve or the other. A value of 1 warps the fillet curve toward one curve, -1 toward the other curve. A value of 0 puts the fillet curve evenly between the two. (You can use a value below 0 in the Attribute Editor, not in the options window.)

Input Curve
Gives you access to the history of the curves you used to create the fillet. Click the arrow buttons to select one of these curves if you want to edit it.

Curve Parameters
The Curve Parameter1 and Curve Parameter2 define the region between the two curves where the fillet curve is created.

Edit Curves > Insert Knot
Inserts an edit point at the selected curve point.

Related topics
- "Insert additional edit points/isoparms in a curve or surface to add more CVs" on page 60
Edit Curves > Insert Knot > □

Insert Location
At Selection inserts the knot exactly at the selected curve point.
Between Selections inserts the knot halfway between a pair of selected curve points.

Multiplicity
Set to inserts an absolute number of knots according to the Multiplicity value. For example, if Multiplicity is 3 and At Selection is on, three knots will be inserted at the point whether or not it has an existing knot. Multiple knots at any position lets you create a sharp corner there.
Increase by adds extra knots to the point according to the Multiplicity value.
If you turn on Between Selections and set Multiplicity higher than 1, Maya creates multiple knots at each knot, with even spacing between the positions.

Keep Original
Keeps the original curve in addition to creating the curve with new knots.

Tip
You can drag a manipulator to reposition a new knot after you insert it. Select the Show Manipulator Tool and turn on Keep Original before using Insert Knot.

Edit Curves > Extend > Extend Curve

Related topics
- "Extend a curve" on page 56
- "Edit Curves > Add Points Tool" on page 102

Edit Curves > Extend > Extend Curve > □

Extend Method
Distance lets you enter a value for the length of the Extension Type.
Point extends to a world space position you specify in Point To Extend To.

Extension Type
Linear extends the curve in a straight line:
Circular extends the curve as an arc:

Extrapolate maintains the tangent of the selected curve.

**Extend Curve At**
- Start extends the curve from its start point.
- End extends the curve from its end point.
- Both extends the curve at both ends.

**Join to Original**
Attaches the curve extension to the original curve. If off, the input curve and the curve extension are independent objects. You can transform the extension separately.
Remove Multiple Knots

Removes the multiple knots that Maya creates when Join To Original is turned on.

Keep Original

Keeps the original curve after the extension is created. If both Keep Original and Join to Original are off, the extension curve replaces the original curve.

Input Curve

Input Curve information is read-only. It gives you access to the input curve you extended. Click the arrow button to select the curve and open that section of the Attribute Editor.

Input Point

This is the same as Point To Extend To in the options window.

Edit Curves > Extend > Extend Curve on Surface

Related topics

- "Extend a curve" on page 56
- "Edit Curves > Extend > Extend Curve" on page 92

Extend Method

Specifies how to extend the curve in the surface’s UV space:

- **Parametric**
  - **Distance**
    - Linear extends the curve in a straight line.
    - Circular extends the curve in an arc direction.
    - Extrapolate extends the curve by deducing the direction and tangency of the curve.

The Parametric Distance value specifies the length of the extension. The value specifies a percentage of the surface length in the direction the curve runs. For
instance, a value of 0.5 extends the curve length by roughly half the length of the surface in the direction the curve runs.

**UV Point**

Lets you specify an extend position in the UV Point To Extend To entry box. To use actual UV values rather than estimates, select Create > Measure Tools > Parameter Tool, drag on the surface, and release the mouse button to display the UV coordinates at the pointer.

**Notes**

- Extend curve on surface may appear to temporarily slow down Maya while editing the extension distance. The computation can take a longer period of time than expected.

**Edit Curves > Offset > Offset Curve, Offset Curve on Surface**

Creates a copy of the selection, offset from the original by a certain distance.

**Related topics**

- “Create an offset copy of a curve or surface” on page 61

**Edit Curves > Offset > Offset Curve/Curve on Surface > □**

**Normal Direction**

The Geometry Average and Active View options select the method Maya uses to position the offset. It’s easiest to learn how each works by simply creating the offset and adjusting its positioning with the Show Manipulator Tool.

Geometry Average is the more intuitive method. For a planar curve, imagine you are standing at the start point of the curve looking in the direction of the initial curve direction. Geometry Average puts the offset curve to the left of the curve. It scales down the curve where it arcs left, and scales up the curve where it arcs right.

For a 3D curve, Geometry Average takes into account the normals of the average plane in which the points of the curve are located.

For both planar and 3D curves, Active View takes into account the camera viewing direction.

**Offset Distance**

Specifies the distance between the original curve and the offset curve.

**Connect Breaks**

If you create an offset curve from a curve that has multiple knots or CVs with multiplicity greater than 1, Maya might create the offset curve with sharp corners or it might break the curve into multiple discontinuous curves.
Circular creates a continuous curve by inserting circular arcs at the break points.

Linear creates a continuous curve by connecting the break points with a straight line.

Off leaves the offset curve broken into multiple discontinuous curves.

If you select Circular or Linear, Maya inserts multiple knots on the curve to preserve the curve shape. If you adjust the curve near the multiple knot locations, tangent breaks might occur on the curve.

Loop Cutting

Sets whether any loops in a planar curve are trimmed. Looping occurs if the distance from the original curve exceeds the minimum bend radius (curvature) of the curve being offset. For example, if a curve has a 20 cm radius and you try to offset more than 20 cm inward, the offset curve crosses over itself and creates a loop. Use Circular to insert arcs at trimmed loops.

Cutting Radius

When Loop Cutting is on, the Cutting Radius value is used. If the Cutting Radius value is greater than 0, instead of getting a sharp corner at the point where the loop has been cut, you get an arc of the specified radius.
Max Subdivision Density

Specifies the maximum number of times the offset geometry may be subdivided within the current tolerance. The default is 5, which means any single span on the curve may be subdivided up to 5 times.

Use Tolerance

If you select Global tolerance, Maya uses the Positional value you set in the Settings part of the Preferences window.

If you select Local tolerance, you can directly enter a new value that overrides the Positional tolerance value of the Preferences window.

Tolerance

Specifies the accuracy in which the offset curve is placed at a specified distance. The default is accurate to within 0.05 units. The default unit is in centimeters. Offsetting is an iterative process that continues until the current offset comes within the tolerance value or the maximum subdivision limit.

Curve Range

Complete creates the offset curve for the entire original curve.

Partial lets you create an offset curve for only part of the original curve. It creates a subCurve node you can edit to alter the offset distance after creation.

Input Curve

Lists the history node of the offset curve or isoparm. Click the arrow button next to the Input Curve name to edit the length of the curve.

Edit Curves > Reverse Curve Direction

Reverses the direction of the selected curve(s).

Related topics

- "Reverse the direction of a curve or surface normals" on page 62

Edit Curves > Reverse Curve Direction > Keep Original

Retains the original curve after the Reverse Curve operation. If you turn on Keep Original (and construction history is on), you can use the Show Manipulator Tool to click a manipulator to reverse the curve direction.

Edit Curves > Rebuild Curve

Performs various operations to transform the selected curve.
Related topics

- “Reduce the complexity of a curve or surface” on page 62
- “Control multi-knots and CV hardness” on page 63
- “Automatically add spans to areas of a curve with high curvature” on page 65
- “Convert a curve or surface to uniform parameterization” on page 65
- “Convert a surface to non-rational geometry” on page 66
- “Change a curve or surface’s degree or number of spans/patches” on page 66
- “Match the topology of one curve to another” on page 68

Edit Curves > Rebuild Curve > □

Rebuild Type

Uniform rebuilds a curve with uniform parameterization. With this option, you can change the Number of Spans and Degree of the curve.

Reduce removes knots if their removal does not cause any remaining knots to move by a distance greater than the tolerance setting. A higher tolerance setting removes more knots.

Match Knots rebuilds a curve by matching the curve degree, knot values, and number of spans of another curve. Before you rebuild the curve, select the curve to be rebuilt first and Shift-select the curve to be matched. The Keep options become available when you select Match Knots.

No Multiple Knots removes any extra knots created during the rebuild operation. The curve has the same curve degree as the original. The Keep options are not available when you select this option.

Curvature inserts more knots in the areas of higher curvature. The curve is the same degree as the original. The Keep options are not available when you select this option, however, the Use Tolerance options are displayed.

End Conditions rebuilds the positioning of the curve’s end CVs and knots. If you select End Conditions, two extra options appear for the End Conditions: No Multiple knots and Multiple knots.
With No Multiple Knots turned on, the rebuilt curve doesn’t pass through the end CVs. This makes the curve harder to control in some cases, but makes other operations easier. For example, it’s easier to create smooth joins between adjacent curves. (If you rebuild both curves with No Multiple knots, you can snap CVs together to get exact tangency across the boundary.)

If you turn on Multiple Knots, the curve touches the end CVs, making it easier to control the curve boundaries and related tangency.

A curve rebuilt with End Conditions has the same degree as the original.

**Parameter Range**

- 0 to 1 sets the resulting curve’s parameter range from 0 to 1.
- Keep matches the rebuilt curve’s parameter range to the original curve.
- 0 to # spans creates integer knot values that make numerical input easier. If you are using the Uniform Rebuild Type, 0 to # spans always creates integer knot values. This is useful if you’ll be entering knot parameter values with curve options. For example, if you enter a knot value for the Detach Surfaces operation, it’s easier to type the number 2 than a number like 0.362.

**Keep**

- Turn on Ends, Tangents, CVs, or NumSpans if you want the rebuilt curve to have the original’s end points, tangents, CVs, or number of spans.
- NumSpans is available only with the Uniform option.

**Number of Spans**

- Specifies the number of spans in the resulting curve.

**Degree**

- The higher the Degree, the smoother the curve. The default setting (3 Cubic) works well for most curves.
Keep Original

Keeps the original curve and creates a new curve as the rebuilt curve. This is useful for comparing various curves with different options.

Use Tolerance

If the Rebuild Type is Reduce or Curvature, the Use Tolerance options appear in the options window. These options let you rebuild the curve within a specified tolerance of the original curve. Global uses the tolerance setting from the Maya’s Preferences window. Local lets you enter a tolerance directly in the options window.

Input Curve

The Input Curve information is read-only. It gives you access to the history of the original curve you rebuilt. Click the arrow button to select the curve and open its section of the editor.

Match Curve

The Match Curve read-only information is available only if there is more than one curve and Match Knots was selected in the options window.

Edit Curves > Fit B-spline

Fits a degree 3 (cubic) curve to a degree 1 (linear) curve. Typically you use Fit B-spline after you import curves, surfaces, and digitized data from other products in which the curves have curve degree 1.

Related topics

❖ “Create a degree 3 curve to match degree 1 (scan) data” on page 29

Edit Curves > Fit B-spline > □

Use Tolerance

The tolerance sets how much accuracy is maintained between the original and fit of interpolated curves.

If set to Global, the fit is accurate to within 0.010 units, by default.

Local lets you change the tolerance value in the Positional Tolerance box.

Input Curve

The Input Curve information is read-only. You can click the arrow button to select the curve and edit it with the Attribute Editor.

Tolerance

See Use Tolerance above for details.
Edit Curves > Smooth Curve

Smoothes out kinks in the selected curve(s). Select the command again to smooth more.

Related topics

- "Smooth a curve" on page 54

Edit Curves > CV Hardness

Sets the multiplicity of the selected CVs.

Related topics

- "Control multi-knots and CV hardness" on page 63

Edit Curves > CV Hardness > □

Multiplicity

By default, when you create a cubic curve, the end knots have a multiplicity factor of 3 and the arcs in between have a multiplicity factor of 1.

Full changes the multiplicity of the interior CVs from 1 to 3. To change a multiplicity factor from 1 to 3, there must be at least two CVs on each side of the CV being modified that have a multiplicity factor of 1.

Off changes the multiplicity of the interior CVs from 3 to 1.

The following figure shows a text object before and after using CV Hardness > □ with Multiplicity turned off. The text loses its hard edges.

Keep Original

Keeps the original curve after you change the multiplicity setting.

hardenPointCurve node

If you turned on Keep Original when you adjusted CV hardness, you can use the Attribute Editor to edit the CV hardness any time later. See also hardenPointCurve.
Input Curve
The Input Curve information is read-only. It gives you access to the history of the curve you changed. Click the arrow button to select the curve and open its section of the editor.

Multiplicity
Enter a value in the Multiplicity box, or use the slider, to specify the number of knots you want to insert when adjusting the CVs.

Edit Curves > Add Points Tool
Lets you add points to the end of the selected curve.

Related topics
- "Extend a curve" on page 56
- "Edit Curves > Extend > Extend Curve" on page 92

Edit Curves > Curve Editing Tool
Shows a manipulator on the curve you click that lets you change the position and direction at arbitrary points along the curve.

Related topics
- "Reshape a curve or surface manually" on page 49

Edit Curves > Project Tangent
Makes the end of a curve tangent or curvature continuous with another curve or surface.

Related topics
- "Align a curve with a curve or surface" on page 51

Edit Curves > Project Tangent > □
Tangent modifies the curve by projecting its tangent vector where it intersects the surface onto the tangent plane of the surface. This means that only necessary modifications are made to the start or end of the curve where it intersects the surface.

Curvature makes the curve tangent and the curvature continuous with the surface in the direction of the tangent vector. An extra manipulator is displayed on the curve to let you adjust the Curvature Scale value. (The Curvature Scale slider is also displayed in the options window when this option is selected).
Tangent Align Direction

The Tangent Align Direction options provide a convenient way to either:

- Reverse the direction of the curve’s tangent vector.
- Aligns the tangent vector with the U or V parameter directions of the intersecting surface or two curves.

U and V pick the tangent you want to use for the adjustment. U is the U direction of the surface, or it’s the second selected curve. V is the V direction of the surface, or it’s the third selected curve.

Normal is the normal vector of the tangent plane. Select the Normal option to make a curve normal to or perpendicular to a surface or two curves. When selected, the curve is no longer tangent to the surface since it is perpendicular to the surface.

When you select Normal, it becomes the mode you are working in for the current curve modification. To return to the general project tangent operation, select either the U or V tangent align direction.

Reverse Direction

Turn Reverse Direction on or off to change the direction of the tangent vector so that it points in the opposite direction. Reverse Direction simply multiplies the current tangent scale factor by -1.0.

Tangent Scale

The Tangent Scale slider displays the current tangent scale factor. Scaling the tangent adjusts the length of the tangent vector without changing its direction. A negative scale factor reverses the direction of the tangent vector.

Tangent Rotation

The Tangent Rotation slider displays the current tangent rotation angle. Adjusting the rotation rotates the tangent vector on the tangent plane defined by the surface intersection.

Tangent rotation is not available when the Tangent Align Direction is Normal. If you change the Tangent Rotation value, the curve is no longer tangent to the surface or two other curves.

Curvature Scale

Project tangent works by selecting a curve to modify then by selecting a surface or two other curves that intersect with either of its end points. The curve is modified by projecting its tangent vector where it intersects the surface onto the tangent plane of the surface.

If Curvature is selected as the construction type, the curve is made tangent and the curvature is made continuous with the surface or curves in the direction in which the tangent vector is going.

Adjusting the Curvature Scale value modifies the curve in such a way that the tangent or curvature doesn’t change at the curve or surface intersection point. For example, if you modify a curve at its end point, the curvature slider
moves the third CV from the end of the curve along a line that joins the end
two CVs of the curve (for instance, along the tangent vector line). Such a
modification doesn’t change the curvature at the end of the curve, it just
adjusts the tangent vector.

**Keep Original**
Keeps the original curve after the projection is performed.

---

**Edit Curves > Modify Curves > Lock Length**

When you select Edit Curves > Modify Curves > Lock Length, the selected curve
(or selected CVs) will maintain a constant hull length. If you then modify the
curve, for example, by moving a CV, the shape of the curve will adjust so that it
maintains a constant hull length (that is, CVs other than the one you move will
also move).

When you select Edit Curves > Modify Curves > Lock Length, a Lock Length
attribute is added to the curveShape node.

**Notes**
- You can use the l (lower-case L) key as a momentary hotkey. Press and hold
down the l key to lock the length of the selected curve. Release the l key to
unlock the length of the curve.
- Lock Length is useful for modeling purposes. Because modifying a curve with
Lock Length turned on behaves similar to a dynamic simulation, animating a
curve in this way (with keyframes) may produce unexpected results.
- If you turn on Lock Length, move a CV and then select Undo, only the CV you
moved will return to its original position.
- If you turn on Lock Length and modify the curve, the curve’s first CV will not
move (unless you explicitly move the first CV). For example, if you move the
curve’s first CV, the curve will respond differently than if you move the curve’s
last CV.

**Related topics**
- “Lock or unlock the length of a curve” on page 54
- “Edit Curves > Modify Curves > Unlock Length” on page 104

---

**Edit Curves > Modify Curves > Unlock Length**

When you select Edit Curves > Modify Curves > Unlock Length, the selected curve
(or selected CVs) will no longer maintain a constant hull length. If you then modify
the curve, for example, by moving a CV, the curve’s hull length will not remain
constant (and only the CV you move will actually move).
When you select Edit Curves > Modify Curves > Unlock Length, the curveShape’s Lock Length attribute is turned off.

Related topics
- "Lock or unlock the length of a curve” on page 54
- "Edit Curves > Modify Curves > Lock Length” on page 104

**Edit Curves > Modify Curves > Straighten**

Makes the selected curves (or selected CVs) straighter (in the direction of the curve’s first segment). The curve’s first CV will maintain its original position.

Related topics
- "Straighten, smooth, curl or bend a curve” on page 55

**Edit Curves > Modify Curves > Straighten > □**

**Straightness**

Determines how much each segment of the selected curves will be straightened. The higher the Straightness, the greater the effect. The effect will be greater on a curve with many CVs than on a curve with few CVs because the Straightness affects each segment.

When Straightness is 0, selected curves will not be straightened at all. When Straightness is 1, selected curves will become entirely straight. When Straightness is 2, selected curves will be flipped so they have the opposite curvature.

**Preserve Length**

The selected curve will remain the same length after straightening. The curve’s first CV will maintain its original position, but its last CV will change position. (If you are applying Straighten to selected CVs with Preserve Length on, then some non-selected CVs may also be affected.)

If preserve Length is off, the curve’s first and last CVs will both maintain their original positions.
Edit Curves > Modify Curves > Smooth

Makes the selected curves (or selected CVs) smoother. The curve’s first and last CVs will maintain their original positions.

**Related topics**

- “Straighten, smooth, curl or bend a curve” on page 55

**Edit Curves > Modify Curves > Smooth > □**

**Smooth Factor**

Determines how much each segment of the selected curves will be smoothed. The higher the Smooth Factor, the greater the effect. The effect will be greater on a curve with many CVs, than on a curve with few CVs, because the Smooth Factor affects each segment.

**Edit Curves > Modify Curves > Curl**

Makes the selected curves (or selected CVs) curly so they resemble a helix. The curve’s first CV will maintain its original position.

<table>
<thead>
<tr>
<th>Tip</th>
</tr>
</thead>
<tbody>
<tr>
<td>Do not apply Curl to a curve twice. The second Curl will produce poor results because it is trying to curl a curve that is already curly.</td>
</tr>
</tbody>
</table>

**Edit Curves > Modify Curves > Curl > □**

**Curl Amount**

Determines how much each segment of the selected curves will be curled. The higher the Curl Amount, the greater the effect. The effect will be greater on a curve with many CVs than on a curve with few CVs because the Curl Amount affects each segment.

**Curl Frequency**

Determines how many curls the selected curves will be curled into.

**Edit Curves > Modify Curves > Bend**

Makes the selected curves (or selected CVs) bend in one direction. The curve’s first CV will maintain its original position.
Related topics
❖ "Straighten, smooth, curl or bend a curve” on page 55

**Edit Curves > Modify Curves > Bend > □**

**Bend Amount**

Determines how much each segment of the selected curves will be bent. The higher the Bend Amount, the more the curve will be bent. A curve with many CVs will be bent more than a curve with few CVs because the Bend Amount affects each segment.

**Twist**

Controls the direction in which the selected curves will be bent.

**Edit Curves > Modify Curves > Scale Curvature**

Makes the selected curves (or selected CVs) straighter or exaggerates their existing curvature, depending upon the Scale Factor and Max Curvature values.

**Related topics**
❖ "Straighten, smooth, curl or bend a curve” on page 55

**Edit Curves > Modify Curves > Scale Curvature > □**

**Scale Factor**

Determines how much each segment of the selected curves will be straightened or have their existing curvature exaggerated. The higher the Scale Factor, the greater the effect. The effect will be greater on a curve with many CVs than on a curve with few CVs because the Scale Factor affects each segment.

If Scale Factor is less than 1, the selected curves will become straighter.

If Scale Factor is greater than 1, the selected curves will have their existing curvature exaggerated (by exaggerating the curvature of each segment in the same direction as its existing curvature).

**Max Curvature**

Controls the maximum angle allowed between adjacent segments.

If Max Curvature is 1, then the maximum angle allowed between adjacent segments is 180 degrees. If Max Curvature is 0.5, then the maximum angle allowed between adjacent segments is 90 degrees.
**Note**
If the selected curve already has adjacent segments with an angle greater than that allowed by the Max Curvature value, and you apply Scale Curvature with a Scale Factor greater than 1 (that is, to exaggerate the curvature of the curve), the curve may actually become straighter. This is because the Max Curvature value is reducing the angle between adjacent segments.

---

**Edit Curves > Selection > Select Curve CVs**

Selects all CVs on the selected curves.

**Tip**
You can also access this command by pressing Ctrl + the right mouse button and choosing To CVs.

**Related topics**
- “Select curve CVs: first, last or all” on page 58

**Edit Curves > Selection > Select First CV on Curve**

Selects the first CV on the selected curve.

**Tip**
You can also access this command by pressing Ctrl + the right mouse button and choosing To First CV.

**Related topics**
- “Select curve CVs: first, last or all” on page 58

**Edit Curves > Selection > Select Last CV on Curve**

Selects the last CV on the selected curve.

**Tip**
You can also access this command by pressing Ctrl + the right mouse button and choosing To Last CV.
Related topics

- “Select curve CVs: first, last or all” on page 58

**Edit Curves > Selection > Cluster Curve**

Creates a cluster for each CV on the curve, for example, when building a character’s back with spline IK.

| Tip | You can also access this command by pressing Ctrl + the right mouse button and choosing Cluster. |

Related topics

- Pose joints with spline IK curves in the Animation book

**Surfaces**

**Surfaces > Revolve**

Sweeps out a surface by revolving a profile curve around a pivot point.

Related topics

- “Create a surface using Revolve” on page 41

**Surfaces > Revolve > □**

**Axis Preset**

Specifies the revolution axis. The default is Y. In the following figure, a profile curve (drawn in the front view) is revolved using each revolution axis in the perspective view.
If you set the Axis Preset to Free, you can enter values in the Axis X, Y, or Z boxes to specify the axes about which the profile curve is revolved. The following figure shows a surface resulting from a value of 1 for Axis X, Y, and Z.

**Pivot**

If you set Pivot to Object, the revolve is performed from the default pivot location (0, 0, 0). This is the default.

If you select Preset, you can change the X, Y, or Z location of the pivot point by entering values in the Pivot Point boxes.

The following figure shows how a revolved surface is created with default pivot values and with values of 5 for X, Y, and Z.
Surface Degree

The Surface Degree options determine whether the V parameter direction of the surface is created with linear (degree 1) or cubic (degree 3) geometry.

If you select Linear, the surface is constructed with flat facets all around.

If you select Cubic, the smooth profiles are defined by the original profile curve. This is the default.

Start and End Sweep Angle

Use the Start Sweep Angle and End Sweep Angle values to specify the angle of revolution in degrees. The default is 360, with a valid range of 0 to 360.

Use Tolerance

The Use Tolerance options control the accuracy of the resulting revolved surface. You can apply tolerance globally or locally.

If you select None you can change the segments value.

If you select Global tolerance, Maya uses the Positional and Tangential values in the Settings part of the Preferences window.

If you select Local tolerance, you can directly enter a new value that overrides the Positional tolerance of the Preferences window. This lets you create the revolved surface closer to the actual surface of revolution.
Segments

The Segments value determines how many sections are used to create the surface of revolution. With a sweep of 360 degrees, six or eight sections are usually sufficient. In the following figure, the left surface shows the revolve with eight segments. The right shows 20 segments.

If Use Tolerance is not set to None, the Segments value is automatically computed so that the result differs from the default revolved surface by less than the specified tolerance value.

If Local is set as the Use Tolerance option, the tolerance value of the revolved surface is closer to the actual surface of revolution.

Tip

If animating the sweep angle, change the Segments value instead of the tolerance value to change the numbers of CVs of the surface.

Curve Range

Select Complete as the Curve Range to create the revolved surface along the entire profile curve. This is the default.

Select Partial if you want to use a segment of the curve for the revolve.

If you set the Curve Range to Partial before you create the revolved surface, a subCurve is created. By lessening the length of the subCurve, you lessen the length of the revolved surface.
To edit the length of the subCurve, select the revolved surface, select the subCurve in the Channel Box, select the Show Manipulator Tool, then drag the curve segment manipulator or edit the Min and Max Value in the Channel Box.

For more details on editing subCurves, see “Editing the subCurve attributes” on page 113.

**Output Geometry**

Specifies the type of geometry created. (Subdiv means subdivision surfaces.)

**Input Curve**

The Input Curve information is read-only. It gives you access to the history of the curve you used to create the revolved surface.

**Editing the subCurve attributes**

If you set the Curve Range to Partial in the options window when the revolve was created, you can edit the length of the curve. Select the revolved surface, then use the Show Manipulator tool or Channel Box to edit the subCurve attributes.

**Surfaces > Loft**

Skins a surface along a series of profile curves.

**Related topics**

- "Skin a surface across profile curves" on page 35

**Surfaces > Loft > □**

**Parameterization**

This modifies the parameterization of the lofted surface (see “Parameterization of NURBS curves and surfaces” on page 12).

Uniform knot spacing makes the profile curves run parallel to the V direction. The parameter values of the resulting surface in the U direction are equally spaced. The first profile curve corresponds to the isoparm on the surface at U[0], the second to U[1], and so on.
Chord Length spacing causes the parameter values on the resulting surface in the U direction to be based on the distance between the start points of the profile curves.

**Tip**

If the curves have the same curve degree and number of edit points, the lofted surface will have the same number of spans in the U direction. The surface will be easier to manipulate and texture. A convenient way to accomplish this is to make copies of a single curve and transform CVs on the copies as necessary to get the desired profile curves.

If the parameterization of the curves differs, the lofted surface might have more spans than any of the profile curves. If you create the curves as Edit Point curves with Chord Length, the surface will be more complex and harder to work with.

**Auto Reverse**

If Auto Reverse is off, the curves are used as they are, which may result in a twisted surface. If on, the curves are automatically reversed.

In the following example, the two top curves and the two bottom curves are going in different directions.

If Auto Reverse is off, the result is a twisted lofted surface. If on, the curves are automatically reversed.

If Auto Reverse is off, you can use the Show Manipulator Tool to reverse the curve direction of the original profile curves as needed. Simply click the manipulator handle to reverse the curve direction.
Close

The Close option sets whether the created surface is periodic in one dimension (U or V). Close is off by default. See "Periodic, closed, and open geometry" on page 15.

Surface Degree

You can set the Surface Degree to either Linear or Cubic. This sets the lofted surface to linear or cubic in the U direction. Linear creates surfaces that appear faceted. Cubic creates smooth surfaces.

Section Spans

This option sets the number of spans between the lofted curves. Higher numbers give finer control of surface deformations at the expense of extra processing time.

Curve Range

If you select Partial, you can use the Show Manipulator Tool after the loft operation to change the length of the subCurves used to create the surface. This changes the length of the surface.
NURBS menus
Reference > Surfaces > Loft

Output Geometry
Specifies the type of geometry created. (Subdiv means subdivision surfaces.)

Input Curves
The options in the Loft History section of the Attribute Editor gives you access to the history of the lofted surface you constructed. This information is read-only. Click the arrow buttons to select the surface, isoparms, or curves, then open its section of the editor.

Reverse Curve
If you turned Auto Reverse off when you lofted the surface, a Reverse Curve option is displayed for each curve, primitive, or surface isoparm you used to create the lofted surface. Select the Show Manipulator Tool to display the reverse manipulators. Click the options to reverse the direction of the input curves, or click the manipulators.

In the following illustration, the first curve used to create the lofted surface is selected for reversal.

Editing the subCurves in the Attribute Editor
If you set the Curve Range to Partial in the options window when the loft was created, you can use the Attribute Editor for the resulting subCurves.
Surfaces > Planar

Creates a planar (flat) surface within a boundary curve.

Related topics

- "Create a flat surface inside a curve" on page 33

Surfaces > Planar > □

Degree

Select either Linear (degree 1) or Cubic (degree 3) for the Degree if the output is a NURBS surface. Cubic is the default.

Curve Range

Complete creates the planar surface along the entire curve.

Partial lets you display manipulators on the planar surface with the Show Manipulator Tool and edit the resulting planar surface along part of the input curve. Click the input curve or isoparms’s heading in the Channel Box to display the options.

Output Geometry

Specifies the type of geometry created.

Limitations

Although the boundary of a planar surface can be manipulated to change the shape of the surface, the surface must remain planar at all times.

Although a planar surface can include cut-out areas or holes, the curves that define the holes must be co-planar with the main surface.
Creating trimmed surfaces from open curves

You do not necessarily need a single boundary curve to create a trimmed surface, however, you do need an enclosed region. This can be created by intersecting several curves. You can create trimmed surfaces using curves with overlapping boundaries. Select the curves and use Surfaces > Planar to create the trimmed surfaces.

![Original curves](image1)

![Planar trimmed surface](image2)

Surfaces > Extrude

Creates a surface by sweeping a profile curve along a path curve.

Related topics

- "Sweep a profile curve along a path curve" on page 36

Surfaces > Extrude > Style

Style

Flat maintains the orientation of the cross section as it moves along the extrusion path.

![Original curves](image3)

![Planar trimmed surface](image4)
Tube sweeps the cross section along the path with the reference vector staying tangent to the path.

With Tube, the extrusion sweeps along the profile curve and pushes out as it follows the path.

Distance extrudes the profile in a straight line. Do not select a path curve when you turn on this option. When Distance is on, the options window provides extra options: Extrude Length, Direction, and Surface Degree.

**Extrude Length**

Specifies how far the extrusion goes.

![Extrude Length examples](Length = 1.0, Length = 5.0)

**Direction**

Profile Normal sets the direction of the path to the normal of the profile curve. If the profile curve is not planar, the average normal is used.
Specify lets you choose a Direction Vector for the extrusion: X Axis, Y Axis, Z Axis, or Free. For example, if you click the Z Axis button, the extrusion will be linear in the Z direction.

If you select Free, you can enter values in the X, Y, and Z boxes to specify a vector as the direction for the extrusion.

**Surface Degree**

Linear gives the surface sharp edges between isoparms. Cubic gives smooth edges.

**Result Position**

This option is available only if you set Style to Flat or Tube.

At Profile creates the extruded surface at the location of the profile curve.

At Path creates the extruded surface at the location of the path curve.
Pivot

The Pivot options are available only if you set the Style to Tube. If you select At Path as the Result Position, you can choose the profile curve then position it at the pivot point on the extrusion path.

If you select Closest End Point, the path end point closest to the center of the bounding box of the profile curves is used. This end point is used as the pivot point for all the profile curves. If you are doing a multiple extrusion, the resulting surfaces are offset from the path.

If you select Component, the pivot point of each individual profile curve is used to extrude the profile curve. The extrusion occurs along the components of the profile curve.
Orientation

The Orientation options are only available if Style is set to Tube.

If you choose Path Direction, the direction of the extrusion is set by the direction of the path curve. By default, the direction of the extrusion is set by the Profile Normal direction—the normal of the profile curve.

Orientation examples

In the following example, Result Position is set to At Profile and Orientation is set to Profile Normal. The path curve is moved and rotated to match the profile curve. This is the default setting.

In this following example, Result Position is set to At Path and Orientation is set to Path Direction.
In the following example, Result Position is set to At Profile and Orientation is set to Profile Normal. The profile curve is moved and rotated to match the path curve.

**Rotation**

Rotates the profile curve as it is extruded along the path curve. Higher values cause the surface to stray from the path, especially with scaling.

**Scale**

Scales the profile curve as it is extruded along the path curve. Higher values cause the surface to stray from the path, especially with rotation.
Curve Range

Complete extrudes the entire profile along the entire path.
Partial extrudes only part of the profile along part of the path. If construction history is turned on, this creates a subCurve node that you can edit to change the extruded surface. See "Editing the extruded surface using manipulators" on page 124.

Output Geometry

Specifies the type of geometry created. (Subdiv means subdivision surfaces.) Note that the Profile Curve and Path Curve boxes let you access the input curves as well as statistical information about these curves. Click the arrows beside the boxes to select the input curves. Click the tab to open the Attribute Editors for them.

Editing the extruded surface using manipulators

After you extrude the surface, select the surface, display the Channel Box, and select the Show Manipulator Tool. Click each of the subCurve nodes in the Channel Box to display the different manipulators available.

Experiment with the manipulators to see their effect on the surface. They let you change the length and sweep of the extrusion.

Surfaces > Birail

Creates a surface by sweeping between a series of profile curves along two path curves. The resulting surface can maintain continuity with other surfaces. The Birail Tool has options for sweeping 1, 2, or 3 (or more) cross sectional curves along the two path (rail) curves. The resulting surface is interpolated through the profile curves.

Related topics

* "Sweep one or more profile curves along two path curves (birail)" on page 37
Surfaces > Birail > Birail 1/2/3+ Tool > □

Transform Control

Select Proportional or Non Proportional to choose how to scale the profile curve sweep along the rails.

Example of using Transform Control

Construct rail curves in the XZ plane. Construct the profile curve so that the internal CVs are at some constant Y. By scaling nonproportionally, the internal CVs of the birail surface also preserve the constant Y as the profile.

1 In the top view, create the two rail curves. Select Display > NURBS Components > Edit Points to display the edit points on the curves.

2 Click the Snap to points icon on the Status Line, place the first point of the profile curve, and click Snap to points again to turn snapping off.

3 In the front view, continue to place the points to create the profile curve. Select the Snap to points icon to snap the last point to the last rail curve (remember to turn snapping off afterward).

4 Build the birail surface. While it is active, click the Transform Mode box of the Channel Box and select Non Proportional, then Proportional. The following figure shows the birail surface for each transform mode.
Profile Blend Value
(Birail 2 only)

This option sets the influence the profile curves have on the intermediate profiles of the created surface. A value of 1.0 means the first selected profile curve has a greater influence than the second profile curve. A value of 0 has the opposite effect. By default, both selected profiles have an equal influence value of 0.5. This option is available only for a surface created with the Birail 2 Tool.

Continuity

This makes the resulting surface tangent continuous to the surface underlying the profile curve.

Because you use multiple profile curves for the Birail 2 and 3+ Tools, the Continuity option has Profile and Rail options for each curve you use.

Rebuild

Turn on one of the Rebuild options to rebuild the profile or rail curves before they are used to create the surface. Because you use multiple profile curves for the Birail 2 and 3+ Tools, the Rebuild option has Profile and Rail options for each curve you use.

Profile rebuilds the profile curve.

First Rail rebuilds the first rail curve you select when you build the surface.

Second Rail refers to the second curve you select.

When you turn on any of the Rebuild options, Maya displays the Rebuild Curve options explained in “Edit Curves > Rebuild Curve” on page 97.

Output Geometry

Specifies the type of geometry created. (Subdiv means subdivision surfaces.)

Tool Behavior

Exit On Completion ends tool usage after you create the birail surface. If off, you can do another birail operation without having to select the tool again.

Auto Completion displays prompts at each step of the birail tool’s usage. If off, you must pick the curves in the correct order then select the birail tool to complete the operation. Pick the profile curve first, then the two rail curves.

Input Profile &
Input Rail

The Input Profile and Input Rail information boxes list the curves you used as profile and rail curves. Click the arrow buttons next to the curve names if you want to edit the curves.
Tangent Continuity Profile

The Tangent Continuity Profile options let you turn tangent continuity on or off for the input profile curve. This option is valid if the profile curve is a surface curve (isoparm, trimmed edge, curve-on-surface).

Surfaces > Boundary

Creates a surface by filling between boundary curves.

Related topics

- “Create a surface within bounding curves” on page 38

Surfaces > Boundary > □

Curve Ordering

Automatic creates the boundary with an internal decision process. As Selected causes the curve selection order to determine the resulting surface.

In the following figure, the first surface is created by selecting the curves while Automatic is selected. The second surface is created when As Selected is the option setting and you select the curves in a different order.

If Automatic is on and you select the curves, you get this result.

If As Selected is set, curve selection in a different order produces a different result.

Common End Points

The Common End Points options let you decide whether the end points should match before the boundary surface is created.

If you select Optional, the surface is created even if the ends of the curves don’t match. This is the default.
If you select Required, the boundary surface is only built if the end points of the curves match exactly.

To make sure the end points match, remember to select a snap mode from the Status Line when drawing your curves.

To match the end points after you draw the curves:

1. Turn on a snap mode, for instance, as Snap to grids.
2. Select the edit point or CV you want to move.
3. Select the Move Tool and drag to snap to the same position.

End Point Tolerance

If you select Required as the Common End Point option, you can change the End Point Tolerance value of the end points to set how close they must be in order to be considered coincident.

Global tolerance causes Maya to use the Positional value in the Settings part of the Preferences window.

Local tolerance lets you enter a new value to override the value in the Preferences window.

Surfaces > Square

Creates a four-sided surface by filling a region defined by four intersecting boundary curves. The resulting surface can maintain continuity with surrounding surfaces depending on the options set.
In order for a square surface to be created, the following conditions must exist:

- The four boundary curves must intersect. You can ensure the curves intersect by snapping their end points to a common grid line, or by magnet snapping the end point of one curve to the end point of another.
- You must select the curves in either a clockwise or counter-clockwise direction.

Related topics

- "Create a four-sided surface with continuity (Square)" on page 40

**Surfaces > Square > □**

**Continuity Type**

- Sets the type of surface tangency created.
  - Fixed Boundary does not ensure continuity at the surface curves.
  - Tangent builds a smooth, continuous surface from the selected surface curves. When Tangent is on, the Curve Fit Checkpoints option becomes available. It specifies how accurately the Square surface will be built.
  - Implied Tangent creates a surface tangency based on the normal of the plane where the selected curve resides.

**Curve Fit Checkpoints**

- Sets how many isoparms are used to achieve continuity across the surface curve. Larger values might create continuity with more precision, but the surfaces might be less useful. This is especially likely when the surface curves intersect acutely.

**End Point Tolerance**

- Global tolerance means the Positional value you set in the Preferences window is used. Positional tolerance sets how close the end points need to be in order to be considered coincident.
- Local tolerance lets can enter a new value to override the Positional tolerance value you set in Preferences.

**Rebuild**

- Rebuild provides an option to rebuild the surface curves used to generate the Square surface. This can improve curve parameterization in some cases.

**Output Geometry**

- Specifies the type of geometry created. (Subdiv means subdivision surfaces.)

**Surfaces > Bevel**

Creates beveled transition surfaces from a profile curve.
Related topics
- "Extrude and bevel a surface from a curve" on page 42
- "Surfaces > Bevel Plus" on page 133

Surfaces > Bevel > □
 Attach Surfaces

This option attaches each part of the bevel surface. If off, the surfaces are not attached. For example, if Attach Surfaces is off and you create a bevel with Bevel set to Both, three surfaces are created. These surfaces are independent and can be selected and modified as such.

Bevel

Specifies whether the beveled surface area is applied to the top, bottom, or both sides of the original curve or isoparm. The following example uses a NURBS circle primitive curve using each method.

Top Side
The bevel is created from the top of the circle.

Bottom Side
The bevel is created from the bottom of the circle.
Bevel Width
The Bevel Width value specifies the initial width of the bevel as viewed from the front of the curve or isoparm.

Bevel Depth
The Bevel Depth value sets the initial depth of the bevel part of the surface. The combination of Bevel Width and Bevel Depth sets the bevel angle.

Extrude Height
The Extrude Height value specifies the height of the extruded portion of the surface, not including the bevel surface area.

Bevel Corners
The Bevel Corners options specify how corners in the original construction curves are handled in the beveled surface. Note that if the curves are degree 1 or 2, the bevel’s surface is cubic (degree 3).

Note
Selecting the Bevel Off option disables the bevel option controls (Width, Depth, Corners, and Cap Edge). If you do this, you can use Bevel for simple extrusions.
Bevel Cap Edge

The Bevel Cap Edge options set the shape of the beveled part of the surface.

- **Circular Arcs**
  The bevel is created with rounded, or circular arc corners.

- **Convex**
  The bevel is created with a convex edge.

- **Concave**
  The bevel is created with a concave edge.

- **Straight**
  The bevel is created with a straight edge.

**Use Tolerance**

The Use Tolerance options let you create a bevel within a specified tolerance of the original input curves.

- **Global tolerance**
  When this option is set, Maya uses the Positional value in the Settings part of the Preferences window.

- **Local tolerance**
  Local tolerance lets you enter a new value to override the value in the Preferences window.

**Curve Range**

Use the Curve Range options if you are creating a bevel from a curve.

- **Complete**
  This option uses the entire curve for the bevel operation.

- **Partial**
  This option lets you use a segment of the curve for the bevel.

**Output Geometry**

Specifies the type of geometry created. (Subdiv means subdivision surfaces.)
Input Curve

The Input Curve information is read-only. It gives you access to the history of the curves or isoparms you used to create the bevel surface. Click the arrow buttons to select the curve and open its section of the editor.

Surfaces > Bevel Plus

Lets you create beveled transition surfaces with a much higher degree of control than regular Bevel.

Related topics

- “Extrude and bevel a surface from a curve” on page 42
- “Surfaces > Bevel” on page 129

Surfaces > Bevel Plus >  □

As you edit the Bevel Plus options, refer to the following figure, showing the parts of the surface created by Bevel Plus:

Attach Surfaces

This option is enabled if you set the Output Geometry option to NURBS. When Attach Surfaces is on, Maya attaches the beveled areas and the extruded area together to form one NURBS surface. When it is off, Maya creates separate NURBS patches for each area.

For example, you might turn off Attach Surfaces so you can easily apply a different material to the patches in the beveled area than the patch in the extruded area.

Create Bevel: At Start, At End

Turns beveling on or off at either end of the resulting surface. At Start controls the portion closest to the curve and At End controls the portion furthest from the curve.
Bevel Width

Specifies the width of the beveled area as viewed from the front of the resulting surface.

Bevel Depth

Specifies the depth of the beveled area as viewed from the top or side of the resulting surface.

Extrude Distance

Specifies the distance of the extruded portion of the geometry, excluding the beveled areas.

Create Cap: At Start, At End

Turns on or off the creation of surfaces that cap the center area on either end of the beveled surface. At Start controls the portion closest to the curve and At End controls the portion furthest from the curve.

Outer Bevel Style, Inner Bevel Style

The bevel style controls the overall look of the beveled surface. For example, Straight Out creates a straight beveled edge extending outward from the original curve.

You can switch between styles and compare the results by accessing the outerStyleCurve or innerStyleCurve attribute from the Attribute Editor or Channel Box.

The following figure illustrates some of the terms used in the bevel style names:

Convex Out  Concave Out  Straight Side Edge  Straight Front Edge
Same as Outer Style

The Outer and Inner style are for letters or art that have an outer curve and an inner curve, such as the letter O. By default, they share the same bevel style, but you can make them different by turning off the Same As Outer Style option.

Use Tolerance

This option is enabled if you set the Output Geometry option to NURBS. Tolerance determines the degree of accuracy that is maintained between the original curve and the beveled surface. Choose from the following options:

- **Global**: Maya uses the Positional value in the Settings section of the Preferences window (Window > Settings/Preferences > Preferences > Settings).
- **Local**: Lets you enter a new value to override the value set in the Preferences window.

Tolerance

If you choose Local, set the degree of accuracy between the original curve and the beveled surface. A low value creates a surface that closely follows the curve. A high value creates a surface that loosely follows the curve.

Output Options

Click the Output Options tab to specify the resulting geometry type and topology.

Output Geometry

Specifies whether to use NURBS or polygons for the resulting beveled surface.

**Note**

If you choose NURBS, Maya creates trimmed surfaces for the cap areas of the beveled surface. Some external applications, such as game exporters, may not handle trimmed surfaces.

Tessellation Method

Controls the smoothness of the resulting beveled surface using two different methods. Count lets you specify the number of polygons; see “Count tessellation method” on page 135. Sampling lets you specify different degrees of tessellation in different areas of the beveled surface; see “Sampling Controls” on page 136.

Count tessellation method

By setting Tessellation Method to Count, you can specify the number of faces created in the resulting beveled surface.
Face Count
Enter a face count and Maya tessellates the surface to match or approximate the count. For optimum performance, set a value that gives enough smoothness while maintaining a low polygon count.

| Note | The actual number of faces will be higher than the Face Count value, because number of faces created for the beveled areas and caps are not included. |

Sampling Controls
If the Tessellation Method is set to Sampling (the default), the following options are available. Sampling lets you specify different degrees of tessellation in different areas of the beveled surface.

Along Extrusion
Use these settings to control the tessellation along the direction of the extrusion.

Section
Use this option if you want the space between tessellated subdivisions to be different for the beveled areas versus the extruded area. With Section turned on, the tessellation occurs separately for each section of the beveled surface: the front beveled area, the back beveled area, and the non-beveled extruded area. Each section will have the same number of subdivisions, as specified in the Samples setting.

Complete
Use this option if you want the tessellated subdivisions to be more evenly spaced across the surface. With Complete turned on, the tessellation occurs along the entire beveled surface, from one surface cap to the other.

Samples
The number of subdivisions in the resulting tessellation.

Along Curve
Use these settings to control the tessellation along the direction of the source curve.

Span
Use this option if you want the space between tessellation subdivisions to be different for long spans versus short spans. (A span is the part of a curve between two edit points.) With Span turned on, the tessellation occurs between each span of the source curve. Each span will have the same number of subdivisions, as specified in the Samples setting.
Complete
Use this option if you want the tessellation subdivisions to be evenly spaced across the surface. With Complete turned on, the tessellation occurs along the entire beveled surface, from the curve’s start point to the end point.

Samples
The number of subdivisions in the resulting tessellation.

Edit NURBS

Edit NURBS > Duplicate NURBS Patches
Creates new surfaces from the selected NURBS patches.

Related topics
- "Duplicate NURBS surface patches" on page 44

Edit NURBS > Duplicate NURBS Patches > □
Group With Original
If on, the duplicate surface is parented under the original object that contains the patches. If off, the resulting surface is independent of the original object.

Note
Unlike polygonal facets, you cannot move, rotate, or scale a NURBS patch that is a component of an object. You can move, rotate, or scale a NURBS patch that is a new object created with Duplicate NURBS Patches.

Edit NURBS > Project Curve on Surface
Creates curves-on-surface by projecting a 3D curve onto a surface.

Related topics
- "Create a curve-on-surface" on page 71

Edit NURBS > Project Curve on Surface > □
Project Along
Specifies whether the projection will be normal to the active view or to the surface normal direction.
Active View, the default, means that the projection occurs in the direction of the normals in the active view. For example, if the front view is active, the curve is projected along the Z axis (the axis normal to the front view).

**Making sure the projection works in the active view**

If you project curves using the Active View option, you have to decide which view you want active before you use Project Curve On Surface. It is important to make sure the selected curve (or set of curves) is projected along the perpendicular (normal) axis of the current view.

In the following figure, the projection was attempted while the perspective view was active. As you can see, the curve is not projected correctly.

Projecting while the front view is active works because the perpendicular direction of the projection is relative to the surface normals of the front view.

Surface Normal lets you project a curve onto the selected surface in one view and then use the same curve to project onto additional surfaces in any other view. The active view is not important if you project while this option is selected.

If you select Surface Normal, make sure you move the curve to the outside of the surface.
The curve lies on the axis of revolution inside the surface. If the curve is inside the surface, the projection will either take a long time to complete or it will fail.

**Use Tolerance**

The Use Tolerance options let you project the curve within a specified tolerance of the original curve. You can apply tolerance globally or locally.

Global tolerance causes Maya to use the Positional value in the Settings part of the Preferences window.

Local tolerance lets you enter a new value to override the value in the Preferences window.

**Curve Range**

Complete projects the entire curve onto the surface.

Partial lets you project only part of the curve onto the surface. This creates a subCurve (initially the whole curve) that can then be edited using the Show Manipulator Tool.

**Editing projected curves in the Channel Box**

Click the projectCurve heading in the INPUTS section of the Channel Box to display the projected curve’s attributes.

Enter values in the boxes to change the X, Y, Z direction of the projection, or adjust the local tolerance value. You can type on to set the projection along the surface normals instead of in the active view. These options are also available in the options window and the Attribute Editor.

**Note**

If the Project Along mode is set to Surface Normal, the Direction values in the Channel Box have no effect.

**Input Surface & Input Curve**

The Input Surface and Input Curve information is read-only. It gives you access to the history of the surfaces and curves you used to project the curve. Click the arrow buttons to select the surface or curve then click the tab to open its section of the editor.
Use Normal

Turn on Use Normal if you choose to project the curve along the surface normals.

Edit NURBS > Intersect Surfaces

Creates curves on surface wherever two surfaces intersect.

Related topics

- “Create a curve-on-surface” on page 71

Edit NURBS > Intersect Surfaces > □

Create Curves for

First Surface causes only the first surface selected (the target surface) to receive a curve-on-surface.

Both Surfaces causes the target surface and the surface selected as the intersecting surface to both receive curves-on-surface. This is the default.

| Note | If you select many surfaces, the last selected is the target surface. For example, if you select 10 surfaces, the first nine are intersected with the tenth. |

Curve Type

Curve On Surface creates a curve-on-surface as the intersection curve. This is the default.

3D World creates a NURBS curve in 3D world space. The curve is not a curve-on-surface and cannot be used to trim the surface later on.

| Note | Text cannot be intersected with a target surface because text is a collection of curves. You cannot intersect a surface and curve. To intersect text, you must create the text as trim surfaces. |

Use Tolerance

The Use Tolerance options let you intersect within a specified tolerance of the default intersection. You can apply tolerance globally or locally.

Global tolerance causes Maya to use the Positional value in the Settings part of the Preferences window.

Local tolerance lets you enter a new value to override the value in the Preferences window.
Edit NURBS > Trim Tool

Hides parts of the surface defined by curves-on-surface.

Related topics

- "Trim or untrim a NURBS surface" on page 73

Edit NURBS > Trim Tool > □

Selected State
If you want to keep the region you trimmed away, select Keep. To discard the region you trimmed away, select Discard. The default is Keep.

Shrink Surface
Causes the underlying surface to shrink to just cover the retained regions. This permanently changes the surface geometry and cannot be restored by untrimming, but Undo will still work.

Fitting Tolerance
Specifies how precisely the Trim Tool uses the shape of the curve-on-surface when it trims the surface. The default value works well in most cases, but you can use a smaller value to increase precision.

Keep Original
The original surface is retained after the trim is performed. If the surface and the curve-on-surface were created with construction history turned on, you must keep the original geometry.

Edit NURBS > Untrim Surfaces

Undoes the last trim or all trims to a surface.

Related topics

- "Trim or untrim a NURBS surface" on page 73

Edit NURBS > Untrim Surfaces > □

Keep Original
If you set Keep Original to On, the untrimmed surface is created and the original trimmed surface is retained. If you select Off, the untrimmed surface replaces the trimmed surface.

Untrim
Select All to remove all trimming information from the surface. All curves-on-surface are also displayed again. All is the default.
Select Last to cancel the last trim operation. For example, if a surface had been trimmed three times, this option shows the result as if it had only been trimmed the first two times.

**Edit NURBS > Booleans > Union Tool, Difference Tool, Intersection Tool**

Trims two surfaces to create the appearance of boolean operations.

**Related topics**

- “Perform boolean operations on surfaces” on page 74

**Edit NURBS > Booleans > Union/Difference/Intersection Tool > □**

**Delete Inputs**

Maya can keep a construction history input from the original surfaces so you can transform them to change the resulting boolean surface. If you do not want to keep this history input, turn on Delete Inputs. Also, construction history must be turned off in the scene. If construction history is on, Maya keeps the history inputs, regardless of this option.

**Tool Behavior**

Exit On Completion, when turned on, takes you out of the Boolean tool after the Boolean operation is calculated. If turned off, the boolean tool remains the current tool so you can continue to perform other Boolean operations.

The Hierarchy Selection option ensures that you can successfully perform a Boolean on the result from a prior Boolean operation. When on, Maya selects and performs the Boolean operation on the root of any given hierarchy. You must turn off Hierarchy Selection if you want to perform a Boolean operation on objects that are within the same group.

**Edit NURBS > Attach Surfaces**

Joins two surfaces together into a single surface.

**Related topics**

- “Join curves or surfaces together” on page 58

**Edit NURBS > Attach Surfaces > □**

**Attach Method**

Connect attaches the selected surfaces without distorting them.
Blend creates a continuous surface joining the original surfaces. It yields a less obvious attachment, but also might add some distortion as the blend tries to achieve continuity across the attachment.

**Multiple Knots**

The Multiple Knots options are used to specify whether the multiple knots at the join point are kept or removed after the attach is done.

Use Keep to keep the multiple knots created at the join point as a result of the attach. This is the default.

Use Remove to remove the multiple knots at the join point. The shape of the geometry can be changed if required.

**Blend Bias**

Use Blend Bias to alter the amount of continuity for the new surface; high values may distort the tangency of the original surfaces.

**Insert Knot**

This option is available only if you select the blend method of attachment. In conjunction with the Insert Parameter value, Insert Knot lets you make the blend region match the original surface curvature more closely.

This option has significant effect only if the original surfaces are not aligned precisely and have lengthy distances between the last two spans on each original surface near the attachment area.

Insert Knot creates two additional spans near the attachment area. Each is within one span of the points being joined from the original surfaces. You can adjust the positioning of the extra spans with the Insert Parameter value.

**Tip**

If you create the initial surfaces carefully, an attach usually gives the desired results without knot insertion. If you do an attach with Multiple Knots set to Remove but need more local control, you can undo and repeat the attach with Keep turned on.

**Insert Parameter**

This option adjusts the positioning of the spans added when you turn on Insert Knot. The closer the value is to 0 (without reaching 0), the closer the blend shape resembles the curvature of the original spans in the attachment area. This occurs because the added spans are inserted closer to the spans closest to the blend points. Valid values are from 0 to 1.

To adjust this option interactively, first create the blended surface with Insert Knots turned on. Next, select the blended surface, display the Channel Box, and select attachSurface in the INPUTS section. Try different values for Parameter until you see the desired surface curvature.
Keep Original
Retains the original surface after the attach is performed. Do not turn this option off if construction history is turned on. If you do, the attached surface might deform oddly if you manipulate it later.

Notes
• Attach Surfaces does not work if the surfaces have the same name. Rename surfaces to have unique names prior to using Attach Surfaces

Edit NURBS > Attach Without Moving
Attaches the selected curves or surfaces by reshaping their ends, rather than moving the objects.

Related topics
❖ “Join curves or surfaces together” on page 58
❖ “Edit NURBS > Attach Surfaces” on page 142

Edit NURBS > Detach Surfaces
Splits a surface into multiple surfaces at the selected isoparms.

Related topics
❖ “Split a curve or surface (detach)” on page 59

Edit NURBS > Detach Surfaces >  
Keep Original
If Keep Original is on when you perform the detach, the original curve or surface is retained.

Input Surface
The Input Surface information is read-only. It gives you access to the history of the surface you detached. Click the arrow button to select the surface and open its section of the editor.

Direction
Use the Direction pop-up menu items to specify the direction of the detachment.

Keeping the geometry in U or V
The Keep section lets you specify whether original geometry is kept in U or V when you perform the detachment.
Changing the detach direction and position

You can change the direction of the detachment by selecting U or V from the Direction pop-up menu in the Channel Box or Attribute Editor. You can also enter a parameter value to change where the detachment occurs.

In the following figure, a V isoparm is selected, moved, then detached twice. The first detachment moves the seam of the cone, which is periodic in V.

If you change the parameter value, the detachment area is increased or decreased. In the following example, the parameter value is increased to 1.5.

To change the detach direction, select U from the Direction pop-up menu to detach the isoparm from a parameter value of 1.5 in the U direction.

Note that you can edit the area of detachment with the Show Manipulator Tool. Select the detached curve and the detachSurface node in the Channel Box, then select the Show Manipulator Tool.
Edit NURBS > Align Surfaces

Makes the edges of surfaces tangent or curvature continuous.

Related topics

- "Align surface edges" on page 53

Edit NURBS > Align Surfaces > Attach

Select Attach if you want to attach the surfaces as well as align.

Multiple Knots

When objects are joined, Multiple Knots are created at the Join Parameter. Select Keep to retain these knots.

Select Remove to remove as many knots as possible without changing the shape of the object when the attach is performed.

Continuity

Continuity means that two surfaces share a boundary. Continuity options let you specify how to achieve continuity for the two surfaces.

Positional continuity means that the ends of two surfaces meet exactly. The following figure shows a side view of how surfaces are aligned with each Modify Position option (First, Second, and Both). The alignment occurs depending on which surface is selected first (white) and last (green).
Tangent continuity exists when two surfaces are placed end to end, and the tangents at the endpoints also match. An example side view of aligned surfaces follows:

Curvature continuity exists when two surfaces that meet with tangent continuity also have the same curvature at the joint. When this option is selected, the curvature scale sliders are enabled.

**Modify Position, Modify Boundary, Modify Tangent**

You can choose the order you want the surface modified. The following tables show what is modified with the different Modify options.

<table>
<thead>
<tr>
<th>Modify Position</th>
<th>Surfaces</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>First</strong></td>
<td>The entire first surface moves so its end boundary coincides with the start boundary of the second surface. Some adjustments are made to the first surface end boundary CVs.</td>
</tr>
<tr>
<td>Only the shape of the first surface you select is modified.</td>
<td></td>
</tr>
<tr>
<td><strong>Second</strong></td>
<td>The entire second surface moves so its start boundary coincides with the end boundary of the first surface. Some adjustments are made to the second surface start boundary CVs.</td>
</tr>
<tr>
<td>Only the shape of the second surface you select is modified.</td>
<td></td>
</tr>
<tr>
<td><strong>Both</strong></td>
<td>The entire first and second surfaces move so that the end boundary of the first surface and the start boundary of the second surface coincide. The adjacent boundary CVs move halfway along the line of minimum distance.</td>
</tr>
<tr>
<td>The shapes of both the first and second surfaces you select are modified.</td>
<td></td>
</tr>
</tbody>
</table>
## Modify Boundary

<table>
<thead>
<tr>
<th>Modify Boundary</th>
<th>Surfaces</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>First</strong></td>
<td>All the end boundary CVs of the first surface move to coincide with the adjacent start boundary CVs of the second surface.</td>
</tr>
<tr>
<td>Only the shape of the first surface you select is modified.</td>
<td></td>
</tr>
<tr>
<td><strong>Second</strong></td>
<td>All the start boundary CVs of the second surface move to coincide with the adjacent end boundary CVs of the first surface.</td>
</tr>
<tr>
<td>Only the shape of the second surface you select is modified.</td>
<td></td>
</tr>
<tr>
<td><strong>Both</strong></td>
<td>All the end boundary CVs of the first surface and the start boundary CVs of the second surface move to coincide with each other. The adjacent CVs move halfway along the line of minimum distance.</td>
</tr>
<tr>
<td>The shapes of both the first and second surfaces you select are modified.</td>
<td></td>
</tr>
</tbody>
</table>

## Modify Tangent

<table>
<thead>
<tr>
<th>Modify Tangent</th>
<th>Surfaces</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>First</strong></td>
<td>The tangents at the end boundary of the first surface adjust to coincide with the tangents at the start boundary of the second surface.</td>
</tr>
<tr>
<td>Only the shape of the first surface you select is modified.</td>
<td></td>
</tr>
<tr>
<td><strong>Second</strong></td>
<td>The tangents at the start boundary of the second surface adjust to coincide with the tangents at the end boundary of the first surface.</td>
</tr>
<tr>
<td>Only the shape of the second surface you select is modified.</td>
<td></td>
</tr>
</tbody>
</table>

**Note**
Curvature continuity is applied to the surface that is modified for tangent continuity (see the table above).

## Tangent Scale, Curvature Scale

The values in the Tangent Scale and Curvature Scale boxes increase or decrease the tangent magnitude or curvature at the end of the surface. You can enter a value in the box or drag the slider bar. The following table shows what happens when the tangent and curvature is scaled.
## Keep Originals

If Keep Originals is off, the original surfaces are replaced with the aligned surfaces. If on, two new surfaces are created and the originals are retained.

## Input Surface

The Input Surface information is read-only. It gives you access to the history of the surfaces you aligned. Click the arrow buttons to select an input surface and open its section of the editor.

## Join Parameter

The Join Parameter slider becomes available depending on the Positional Continuity Type you select. Use Join Parameter to define the parameter on the first/second surface at which the alignment is performed.

## Reverse/Swap

The Reverse and Swap options for surfaces define whether the surfaces have to be reversed and or swapped before performing the alignment (remember, align uses the end of the first surface and the start of the second). The reverse is done in the direction defined by Direction U (on or off) in the Channel Box.

<table>
<thead>
<tr>
<th>Tangent Scale</th>
<th>Surfaces</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>First</strong></td>
<td>The tangent magnitude at the end boundary of the first surface adjusts.</td>
</tr>
<tr>
<td>Only the shape of the first surface you select is scaled.</td>
<td></td>
</tr>
<tr>
<td><strong>Second</strong></td>
<td>The tangent magnitude at the start boundary of the second surface adjusts.</td>
</tr>
<tr>
<td>Only the shape of the second surface you select is scaled.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Curvature Scale</th>
<th>Surfaces</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>First</strong></td>
<td>The curvature at the end boundary of the first surface adjusts.</td>
</tr>
<tr>
<td>Only the shape of the first surface you select is scaled.</td>
<td></td>
</tr>
<tr>
<td><strong>Second</strong></td>
<td>The curvature at the start boundary of the second surface adjusts.</td>
</tr>
<tr>
<td>Only the shape of the second surface you select is scaled.</td>
<td></td>
</tr>
</tbody>
</table>
Twist

If Twist is turned on, the second surface is also reversed in the opposite direction of Direction U. Turn this on if your aligned surface is twisted.

For example, if you align the surfaces and the surface boundaries are going in different directions, the following results.

Surface boundaries are not going in the same direction.

When you select the surfaces, the align result is twisted. Turn Twist on either from the Attribute Editor or in the Channel Box to correct the problem.

The other alternative is to check the surface U/V direction before you align the surfaces. Use Edit NURBS > Reverse Surfaces to reverse the surface directions if necessary.
Interior Blending

The Interior Blending sections are the same as the Tangent Scale options in the options window. The sliders become available depending on which type of continuity you select.

**Note**

Align Surfaces computes the twist values for edges, so you do not need to align surfaces then turn on the twist attribute to get a clean join.

**Edit NURBS > Open/Close Surfaces**

Converts a surface between open and closed/periodic.

**Related topics**

- "Make a curve or surface open or closed" on page 67

**Edit NURBS > Open/Close Surfaces > □**

**Surface Direction**

The Surface Direction options, U, V, and Both, let you choose the direction in which a surface is open or periodic. The following figure shows how these options are used to close a beveled curve.
Shape

Ignore does not preserve the shape of the original selection.
Preserve adds or deletes control points as necessary to preserve the shape of the original surface. This option is the default setting.
Blend tries to impose continuity on the input surfaces, using the Blend Bias setting to determine the amount of smoothing that will take place.

Note
If the ends are touching and you close them with the Preserve setting on, you might get CVs that cross over each other and cause a loop in the surface when you move the CVs. In these situations, turn on the Blend setting instead.

Blend Bias

Alters the amount of continuity for the new surface; higher values may result in increased distortion of the tangency of the original surfaces.

Insert Knot

This option is available only when you select the Blend option for Shape. It inserts a knot along the join seam and lets you set a value for the Insert Parameter.

Insert Parameter

Controls the amount of influence the inserted knot has on the blended shape.

Keep Original

Sets whether the original curves or surfaces are retained after Open/Close.

Selecting an isoparm to change the periodic direction

You can select the direction in which you want the surface to be periodic from the options window, or you can click to select isoparms on the surface. When you do this, you override the Surface Direction setting in the options window.
Edit NURBS > Move Seam

Moves the seam of a closed/periodic surface to the selected isoparm.

Related topics

- "Make a curve or surface open or closed" on page 67

Edit NURBS > Insert Isoparms

Adds an edit point isoparm at the selected isoparm.

Related topics

- "Insert additional edit points/isoparms in a curve or surface to add more CVs" on page 60

Edit NURBS > Insert Isoparms > □

Insert Location

At Selection lets you create isoparms at the current position, effectively creating a subdivision of the surface. This option enables the Multiplicity options.

Between Selections creates isoparms between your choice of selected isoparms, or between all U or V isoparms. For instance, if you select a pair of isoparms and turn on Between Selections, Maya creates the isoparm halfway between the pair.
Note that if you turn on Between Selections and set Multiplicity (see the following option) to a value greater than 1, Maya creates the multiple isoparms spaced out evenly between the selected isoparms.

**Use all Surface Isoparms**

If you select the entire surface and select Between Selections, you must turn on U or V for the Use all Surface Isoparms option. U creates isoparms between all U isoparms; V creates isoparms between all V isoparms. If you select a pair of specific isoparms rather than the entire object, Maya ignores whether you choose U or V. Isoparms will be inserted only between the selected isoparms.

**Multiplicity**

Lets you insert multiple isoparms at the selected positions as described in the following paragraphs. The new isoparms do not change the shape of the surface.

The Set to option lets you insert an absolute number of isoparms according to the Multiplicity value. For example, if Multiplicity is 3 and At Selection is turned on, three isoparms will be inserted at the position regardless of whether it already has an isoparm.

The Increase by option lets you add an additional number of isoparms to the position according to the Multiplicity value.

**Keep Original**

Turn on Keep Original if you want to keep the original surface in addition to the surface with new isoparms.

**Tip**

To use a manipulator to reposition the new isoparm(s) after you insert it, turn on Keep Original. Click the Insert button in the Insert Isoparms options window, then select the Show Manipulator Tool and reposition the large yellow square. When you finish positioning the isoparm, deselect the curve.

**Input Surface**

This information is read-only. It shows the surface for which you inserted the isoparm. The Insert Between and Add Knots attributes affect the location of inserted knots.
Direction
This positions the isoparm in U or V.

Parameter
This sets a value that repositions the isoparm on the surface.

Number of Knots
This specifies how many isoparms you want to insert. This is the same as the Multiplicity option in the options window.

Edit NURBS > Extend Surfaces
Extends an edge of a surface.

Related topics
- “Extend a surface” on page 57

Edit NURBS > Extend Surfaces > □

Extension Type
Tangent adds new isoparms to the extended surface.
Extrapolate rebuilds the surface according to the direction and distance specified, but without adding new isoparms.

Distance
Sets the length of extension.

Extend Side
Specifies the sides that will be extended; the start is the U0 and V0 location on the surface. This option is available in the Channel Box after you extend the surface. Select the extendSurface node to display the option.

Extend Direction
Specifies the U, V, or U and V directions for the extension to be built. This option is available in the Channel Box after you extend the surface. Select the extendSurface node to display the option.

Join to Original
You can turn off this option only when the Extend Side and Extend Direction options are not set to Both. Maya disables the selection of Both for Extend Side and Direction, and causes Extend Surfaces to create an unattached and separate surface.

Keep Original
This option causes Extend Surfaces to keep the original surface when it builds the new one. Turn this off if you prefer to discard the original surface.
Edit NURBS > Offset Surfaces

Creates a copy of the selected surface, offset a certain distance.

Related topics

- "Create an offset copy of a curve or surface" on page 61

Edit NURBS > Offset Surfaces > □

Method

- Surface Fit creates an offset surface that preserves the surface curvature.
- CV Fit will create an offset surface that represents the offset of the CV positions along their normals.

Offset Distance

- This is the distance that the new surface will be offset. Concave surfaces might produce overlapping and intersecting areas.

Edit NURBS > Reverse Surface Direction

Reverses or swaps the U and V directions of the selected surface.

Related topics

- "Reverse the direction of a curve or surface normals" on page 62

Edit NURBS > Reverse Surface Direction > □

Surface Direction

- Select U to reverse the CVs along the U parametric direction. U is the default surface direction.
- Select V to reverse the CVs along the V parametric direction.
- Select Swap to exchange U and V parameterization. Selecting an item a second time using the same direction restores the original CV sequence. Reversing the sequence of CVs for a surface reverses the surface normals.
- Select Both to reverse the CVs and normals along both U and V parametric directions.

Keep Original

- Turn Keep Original on to keep the original curves after reversing the surface.

Edit NURBS > Rebuild Surfaces

Performs various operations on the selected surface.
Related topics

- “Reduce the complexity of a curve or surface” on page 62
- “Control multi-knots and CV hardness” on page 63
- “Convert a curve or surface to uniform parameterization” on page 65
- “Convert a surface to non-rational geometry” on page 66
- “Change a curve or surface’s degree or number of spans/patches” on page 66

Edit NURBS > Rebuild Surfaces >  

Rebuild Type

The Rebuild Surface options window displays different options depending on the Rebuild Type option you select:

Uniform

Use the Uniform option to rebuild the surface with uniform parameterization. With this option, you can change the Number of Spans and Degree of the surface.

Reduce

If you select the Reduce option, Maya removes knots if their removal does not cause any remaining knots to move by a distance greater than the Tolerance setting. A higher Tolerance setting removes more knots.

Match Knots

Rebuilds a surface by matching the curve degree, knot values, and number of spans and sections of another surface. Before you rebuild the surface, select the surface to be rebuilt first and Shift-select the surface to be matched. The Keep options become available when you select Match Knots.

Setting Rebuild Method to Match can produce better quality surfaces.

No Multiple Knots

Removes any extra knots created during the rebuild operation. The resulting surface has the same curve degree as the original. The Keep options are not available when you select this option.

Non-Rational

Select Non-Rational to rebuild a rational surface into a non-rational surface. The CVs of a rational surface have weights that are not all equal to 1. The CVs of a non-rational surface all have weights equal to 1. The resulting surface has the same degree as the original surface. The Keep options are not available when you select this option.

Maya creates surfaces with all CVs weighted at 1 by default. Other software packages, especially design packages, might create surfaces with CVs not weighted at 1. The Non-Rational option is useful if you import surfaces from such packages.
The reason some design packages use weights not equal to 1 is because they allow finer surface precision. As Maya is used mainly for entertainment, extreme precision is typically not essential. If you rebuild an imported surface to have equal weighting, Maya processes your subsequent work on the surface faster, while still providing accurate precision.

End Conditions

Rebuilds the positioning of the surface’s end CVs and knots. If you select End Conditions, two extra options appear for the End Conditions: No Multiple knots and Multiple knots.

With No Multiple Knots turned on, the rebuilt surface doesn’t pass through the end CVs. This makes the surface harder to control in some cases, but makes other operations easier. For example, it’s easier to create smooth joins between adjacent surfaces. (If you rebuild both surfaces with No Multiple knots, you can snap CVs together to get exact tangency across the boundary.)

If you turn on Multiple Knots, the surface touches the end CVs, making it easier to control the surface boundaries and related tangency.

A surface rebuilt with End Conditions has the same degree as the original.

Trim Convert

Rebuilds a single-region trimmed surface (with four boundary curves) into a non-trim surface.

Bezier

Rebuilds the surface as a Bezier surface. If you prefer working with Bezier surfaces rather than NURBS surfaces, consider using this option to convert the surface.

Parameter Range

The three Parameter Range options are used to specify how U and V parameters are affected during the rebuild.

Select 0 to 1 if you want the resulting surface’s U and V parameters to run from 0 to 1.

Select Keep if you want the rebuilt surface’s U and V parameter ranges to match those of the original surface.

Select 0 to #Spans if you want the resulting surface’s spans to give you integer knot values. These values make it easier for numerical input. If using the Uniform rebuild type, this option always gives you integer knot values. For example, if you want to use Detach and you prefer to type a value, it is easier to enter the number 2 than something like 0.362.
Direction
The Direction options, U, V, U and V, are used to determine the parametric direction of the surface for which knots will be removed. For example, if U is selected and the rebuild type is No Multiple Knots, only the multiple knots in the U direction are removed when the surface is rebuilt. U and V is the default.

**Note** Performing uniform surface rebuild on a periodic surface will always rebuild the surface to uniform in both direction, regardless of the setting for the surface direction.

Keep
Rebuilding a surface may change the surface in 3D. Use the Keep options to ensure the rebuilt surface conforms to the input (or original) surface.

Turn Corners on to ensure that the corners of the new surface are at the same 3D point as the original corners. Turn on CVs to specify whether or not you want to keep the CVs of the original surface.

NumSpans gives the rebuilt surface the same number of spans as the original.

Rebuild Method
Setting Rebuild Method to Match can produce better quality surfaces, especially if the rebuild or reference surface is periodic or if either surface does not have multiple knots at the ends.

Setting Rebuild Method to Classic produces the same results as in Maya 5.0 and earlier.

Number of Spans U/V
If Uniform is the rebuild type, the number of spans in the resulting surface can be set by the value you enter in the Number of Spans U/V boxes.

Degree U/V
The degree of the resulting surface is determined by the Degree U or Degree V you select.

If you turn on Original, the U/V degree of the rebuilt surface is the same as the original surface.

Note that you can turn on Degree U/V Original and Keep NumSpans to create a uniform rebuild for several surfaces that have a different number of spans.
Keep Original

Retains the original surface after it is rebuilt. If Keep Original is on, you can see the deviation of the resulting surface from the original surface.

Use Tolerance

This option is available only when you turn on Non-Rational or Reduce. It sets the longest distance between any point on the original and rebuilt surfaces. The smaller the tolerance, the more the rebuilt surface resembles the original. A small tolerance might create many patches, which slows processing time as you work with the surface.

Global uses the Positional value in the Preferences window. Local lets you enter the tolerance directly in the window.

Output Geometry

Specifies the type of geometry created. (Subdiv means subdivision surfaces.)

Input Surface

The Input Surface information is read-only. It gives you access to the history of the surfaces you rebuilt. Click the arrow buttons to select the surface, then open the appropriate section of the Attribute Editor.

Match Surface

If there is more than one surface and Match Knots was turned on when you rebuilt the surface, you can also access the Match Surface rebuilt surface.

Edit NURBS > Round Tool

Creates rounded transition surfaces along the edges between existing surfaces.

Related topics

* "Round off the meeting point between two edges" on page 44

Edit NURBS > Round Tool > □

Radius

Specifies the fillet radius the tool uses when you select edge pairs.
Tolerance Value

Override tolerance means the Positional value you set in the Preferences window is used. Positional tolerance is used to determine how close the end points need to be to be considered coincident. The default is Override.

User Preferences tolerance lets you enter a new value to override the Positional tolerance value you set in Preferences.

Edit NURBS > Surface Fillet > Circular Fillet

Creates a circular fillet surface between two existing surfaces.

Related topics

- "Create a fillet between two surfaces" on page 45
- "Edit NURBS > Surface Fillet > Freeform Fillet" on page 163
- "Edit NURBS > Surface Fillet > Fillet Blend Tool" on page 164

Edit NURBS > Surface Fillet > Circular Fillet > □

Create Curve On Surface

Turn on Create Curve On Surface to create curves-on-surface when the fillet is constructed. The curves are placed on the surface at the point where they intersect with the fillet.

When Create Curve On Surface is off, curves-on-surface are not constructed on the original surface. The default is off.

Reverse Surface Normals

During the fillet construction, the surfaces are offset in the direction of the normals by the Radius value you specify. By reversing the surface normals, you can construct the desired fillet. Click the Show Manipulator icon to see the surface normals.

Before you create the fillet, choose to reverse either the primary surface normal (the first selected surface), or the second surface normal (the second selected surface). The following examples show both primary and secondary reverse methods with a radius value of 0.75.
To reverse surface normals by selecting surface points:

You can also reverse surface normals by selecting points on the surfaces and constructing the fillet. For example, the normals on the secondary surface are reversed if the point selected on the primary surface does not lie on the same side as its surface normal.

1. Select a point then Shift-select another point.

2. Select either Reverse Primary Surface Normal or Reverse Secondary Surface Normal, then click the Fillet button. Click the Show Manipulator icon to see the surface normals.
Editing the circular fillet normals using manipulators

1. To display the surface normals and radius manipulator after you create the fillet, select the fillet surface and display the Show Manipulator Tool.

2. Drag a radius manipulator handle.

Use Tolerance

The Use Tolerance options let you apply a circular fillet within a specified tolerance value. You can apply tolerance globally or locally.

Global tolerance causes Maya to use the Positional and Tangential values from the Settings part of the Preferences window.

Local tolerance lets you enter a new value to override the values in the Preferences window.

Edit NURBS > Surface Fillet > Freeform Fillet

Creates a fillet surface with configurable bias between two existing surfaces.

Related topics

- "Create a fillet between two surfaces" on page 45
- "Edit NURBS > Surface Fillet > Circular Fillet" on page 161
- "Edit NURBS > Surface Fillet > Fillet Blend Tool" on page 164

Edit NURBS > Surface Fillet > Freeform Fillet > ◯

Bias

The Bias value scales the end tangents across the two surface curves.
Depth
The Depth value controls the curvature of the filleted surface.

Use Tolerance
The Use Tolerance options let you reapply a free-form fillet within a specified
tolerance value.
Global tolerance causes Maya to use the Positional and Tangential values
from the Settings part of the Preferences window.
Local tolerance lets you enter a new value to override the values in the
Preferences window.

Output Geometry
Specifies the type of geometry created. (Subdiv means subdivision surfaces.)

Edit NURBS > Surface Fillet > Fillet Blend Tool
Creates a fillet surface between two existing surfaces.

Related topics
- "Create a fillet between two surfaces" on page 45
- "Edit NURBS > Surface Fillet > Circular Fillet" on page 161
- "Edit NURBS > Surface Fillet > Freeform Fillet" on page 163

Edit NURBS > Surface Fillet > Circular Fillet > □
Auto Normal Dir
Turns on automatic orientation of the blended surface’s junctures with the
original objects. If off, you must choose the surface orientation. For example,
suppose you create the following fillet-blended surface (the middle object)
from a pair of planes:
Where the blended surface meets the top plane, notice how the curvature curls towards the left-most part of the plane. If you rotate the top plane 180 degrees around its z-axis, the curvature still curls towards the same part of the plane.

If Auto Normal Dir is off, the curl of your surface may point in the opposite direction after the rotation. In the above example, the blended surface would curl toward the left end (former right end) of the top plane.

In most cases, turning on Auto Normal Dir creates the desired orientation automatically when you rotate the surfaces.

Auto Normal Dir is called Auto Normal in the Channel Box and Attribute Editor.

**Multiple Knots**

When on, Maya creates the blended surface with multiple knots at each knot position. This displays the surface with greater precision. Be aware that using multiple knots might break the tangency between the blended and original surfaces as you deform the surface. For example, you might see a sharp break in curvature on the surface as you deform it.

If you’re uncertain how to set this option, leave it off. If you will not be deforming the blended surface, turn this option on to create a better fit with the surfaces. Also, if you select Bezier as the output geometry, you can leave this option on because the conversion creates multiple knots anyway.

Note that the number of multiple knots increases with a lower Positional Tolerance number. See “Use Tolerance” on page 168.
If Multiple Knots is on, Auto Normal Dir is off regardless of its setting. If Multiple Knots is off, Auto Normal Dir is on regardless of its setting.

Reverse Normal Left/Right

If Auto Normal Dir is off, you can turn on Reverse Normal Left or Reverse Normal Right to correct a situation where the blended surface curls towards one of the original surfaces improperly. Reverse Normal Left reverses the curl towards the first surface you selected when you used the Fillet Blend tool. Reverse Normal Right reverses the curl towards the second surface.

If you’re uncertain about how to use these settings, use the Attribute Editor to experiment with different settings for Left or Right (or both) until you get the desired result.

Left means the first surface you selected. Right is the second surface. The two terms do not refer to spatial placement in the workspace.

The Reverse Normal Left/Right attributes are named Flip Left/Right Normal in the Channel Box and Attribute Editor.

Reverse Direction Left/Right

If Auto Normal Dir is off, you can use these options to correct a blended surface that has an undesired twist after creation. If you turn on either of these options, the blended surface responds as though you were reversing the direction of a curve that joins the blended shape to the surface. (The curves are not actually reversed.) By experimenting with these settings in the Attribute Editor, you can untwist the blended surface.

The Reverse Direction Left/Right attributes are named Reverse Left/Right in the Channel Box and Attribute Editor.
Auto Closed Rail Anchor

This option prevents a blended surface from twisting when you rotate the original surface. The Auto Closed Rail Anchor option is relevant mainly for working with a blended surface created from periodic curves.

For instance, suppose you’ve created a blended surface from a pair of cylinders as shown in the following figure. The blended surface is the curving cylinder sandwiched between the top and bottom cylinders:

If Auto Closed Rail Anchor is off and you rotate the top or bottom cylinder around its Y-axis, the blended surface (middle cylinder) twists as if it’s glued to the cylinders:

If Auto Closed Rail Anchor is on and you rotate the top or bottom cylinder, the middle cylinder slides along the bordering rings. No twisting occurs, so the middle cylinder retains its original shape. The middle cylinder will rotate if you rotate the top or bottom cylinders.

The Auto Closed Rail Anchor attribute is named Auto Anchor in the Channel Box and Attribute Editor.
Tip

To set your own anchor point for the adjoining surfaces, turn off Auto Closed Rail Anchor when you use the Fillet Blend tool. Display the ffBlendSrf node in the Attribute Editor to edit the Left/Right Anchor, Left/Right Start, or Left/Right End. Left/Right Anchor sets an anchor position (in U) for the curve from which the blended shape was created. This is used with the Left/Right Start or Left/Right End to specify a range of curve length along which the blended surface joins the adjacent surfaces. Note that you also can use the Show Manipulator Tool to adjust this option. Be aware that twisting will still occur when you rotate the adjoining surfaces.

Left Anchor = 0
Left Start = 0.6
Left End = 0.8

Use Tolerance

Global tolerance causes Maya to use the Positional and Tangential values from the Settings part of the Preferences window.

Local tolerance lets you enter a new value in the options window to override the values in the Preferences window.

Positional tolerance sets how snugly the blended surface fits the original surfaces. Tangential tolerance sets how precisely the tangency at the edges of the blended surface merge with the tangency at the edges of the original surfaces.

For Positional and Tangential tolerance, lower values increase accuracy at the expense of longer rendering time.

Unless you’re modeling for manufacturing output, it’s probably unimportant to display the surfaces in the workspace with perfect fit. They’ll still likely render well. To enhance the rendering quality, you can adjust the Tessellation options of the blended surface shape node.

Output Geometry

Specifies the type of geometry created. (Subdiv means subdivision surfaces.)
Tool Behavior

If you turn off Exit On Completion, Maya remains focused on the Fillet Blend tool after each usage. Turn off Exit On Completion if you want to use the tool repeatedly.

Edit NURBS > Stitch > Stitch Surface Points

Related topics

- “Manually stitch surface points together” on page 79

Edit NURBS > Stitch > Stitch Surface Points > □

These are the options you see in the Stitch Surface Points Options window.

Keep Original

If Keep Original is on, the stitch surface is created on top of the original input surfaces. This lets you move the resulting surface if you are not satisfied with the result. You can re-stitch a new surface with different option settings.

Assign Equal Weights

If Assign Equal Weights is on, a weighted average of the selected points is performed both in position and normal using an average NurbsSurfacePoint node.

If turned on, all the points are assigned a weight of 0.5. When turned off, the first selected point is assigned a weight of 1.0 and the rest 0. The default is on.

Cascade Stitch Node

If Cascade Stitch Node is on, the stitch operation ignores any prior stitch operations on the surface. If turned off and the surface has had a stitch operation performed on it, the stitch node from the previous operation is used. The default is on.

Edit NURBS > Stitch > Stitch Edges Tool

Related topics

- “Manually stitch surface edges together” on page 78

Edit NURBS > Stitch > Stitch Edges Tool > □

These are the options you see in the Stitch Edges Tool window.

Blending

- Position stitches the surfaces with position continuity.
- Tangent stitches the surfaces with tangent continuity.
Weighting on Edge

Before stitching the edges, the two selected isoparms are averaged in a weighted mode. The two surfaces are modified to meet along this averaged isoparm with tangent continuity. You can assign weights to the selected isoparms.

By default, weights of 1.0 and 0.0 are assigned to the first and second selected isoparms. In effect, this modifies the CVs on the second surface so the surface has tangent continuity with the first surface. If you assign a nonzero weight to the two selected isoparms, the CVs on both surfaces are modified to achieve tangent continuity.

You can modify the weights after creating the stitch with construction history turned on. Select the avgCurve node created during stitching, then display the Attribute Editor.

You can drag the manipulators to selectively alter the portions along the isoparms to be weighted together. These are the portions on the two surfaces that will be stitched together.

Tip

To see the curve computed by the average node, select the Show Manipulator Tool on the average node. This manipulator provides a visual clue only and cannot be edited.
Samples Along Edge

The CVs for the stitched surface are determined by sampling the edge along the surface that needs to be modified for tangent continuity. You can explicitly set Samples Along Edge to close any position gaps on the stitched surface. The higher the count, the slower the performance. This is the same as Step Count for the stitchSrf node in the Channel Box and Attribute Editor.

Cascade Stitch Node

If Cascade Stitch Node is on, the stitch operation ignores any prior stitch operations on the surface. If turned off and the surface has had a stitch operation performed on it, the stitch node from the previous operation is used. The default is on.

Keep Original

If Keep Original is on, the stitch surface is created on top of the original input surfaces. This way, you can move the resulting surface if you are not satisfied with the result and re-stitch a new surface with different option settings.

If off, the stitch operation replaces the surface being stitched.

Edit NURBS > Stitch > Global Stitch

Related topics

- "Stitch multiple surfaces together” on page 77

Edit NURBS > Stitch > Global Stitch > □

These are the options you see in the Global Stitch Options window.

Stitch Corners

The Stitch Corners options specify where a surface corner is stitched to an adjacent corner or surface edge. Regardless of which option you choose, stitching occurs only if the points are within the Max Separation distance.

Stitching occurs at a point between two corners or between a corner and a point on the surface edge. Where a corner would stitch to a point on an edge rather than a corner, the following options are available.

- **Closest Point** stitches a corner to the closest point on the edge.
- **Closest Knot** stitches a corner to the closest knot on the edge.
- **Off** does no explicit corner stitching.
Stitch Edges

The Stitch Edges options specify where adjacent edges are stitched together. Regardless of which option you choose, stitching occurs only if the edges are within the Max Separation distance. Stitching occurs along the midpoint between the edges.

**Closest Point** stitches the closest points on the edges while ignoring parameterization differences between the edges. Because the number of patches may differ, an exact join might not occur.

**Match Params** stitches points on the surface edges that have equivalent UV increments along each edge. The number of spans is ignored. To achieve the best possible fit with this type of stitching, make sure the two edges have the same UV values, the same number of spans, and lined-up knots.

**Off** does no explicit edge stitching. If you turn on one of the Stitch Corners options (other than Off) and set Stitch Edges to Off, the corners will be stitched together, but not the edges.
Stitch Smoothness

**Tangents**
- Bends isoparms so they are perpendicular where they meet the stitched edge. This yields the best continuity between the surfaces.

**Normals**
- Does not require the isoparms to be perpendicular, though the surfaces still join smoothly.

**Off**
- Turns off smoothing and doesn’t ensure tangency of the edge regions.

**Note**
You can use Stitch Corners, Stitch Edges, and Stitch Smoothness in any combination to create a variety of stitching results. If Stitch Smoothness is Off but one of the Stitch Edges options is on, the edges will touch, but the stitched region between the edges might not be smooth.
Stitch Partial Edges

If this option is on, Maya joins any parts of an edge pair that are within the Max Separation distance. The same pair of edges may therefore join and separate a number of times along their length. If this option is off, no part of the edge pair will be stitched if any points along the edges exceed the Max Separation distance.

Do not turn on Stitch Partial Edges when unnecessary. This option takes extra processing time.

Max Separation

Specifies how close surface edges and corners must be for them to be stitched. High values might stitch more points than you want. Low values might cause the stitch operation to fail.

Modification Resistance

Specifies how much the surface CVs hold their positions when you stitch the surfaces. Increase this value to smooth waviness in the stitched surface. Don’t increase the value too much or the surface joins might not be smooth.

Sampling Density

Sets how many points along each edge Maya samples during the stitch operation. Increasing the Sampling Density might improve the fit, but it slows the stitch operation. Start with the lowest value (1) and increase it only if the fit is poor. Values over 5 are typically unnecessary.

Lock surfaces

The Lock Surfaces section of the Attribute Editor displays two or more attributes named Lock surface n. Where n represents one of the surfaces stitched. For example, Lock surface 1, Lock surface 2, and so on.
If you turn on this option for any surface, that surface doesn’t change shape in the resulting stitched surface. Instead, the surface stitched to this surface is altered.

If you turn on this option for two adjacent stitched surfaces, they might appear unstitched. They’re still part of the globalStitch node, so you can turn off Lock surface for either surface and the stitching is displayed again.

**Keep Originals**

If Keep Originals is on, the stitch surface is created on top of the original input surfaces. This way, you can move the resulting surface if you are not satisfied with the result and re-stitch a new surface with different option settings.

If off, the stitch operation replaces the surface being stitched.

| Note | After you stitch surfaces, you can move the original surfaces outside the Max Separation range without breaking the stitch. Loss of continuity and distortion might occur if you separate the surfaces too much.

If the original surfaces are far apart and you edit attributes on the globalStitch node, the stitch will be recomputed based on the new positions of the surfaces. Edges formerly stitched may fail to produce results. Return surfaces to their original positions before editing attributes that specify how the surfaces are stitched.

**Edit NURBS > Sculpt Geometry Tool**

Use this tool to sculpt NURBS, polygons, and subdivision surfaces. This tool is based on the Maya Artisan tools. For more information, see “How Artisan brush tools work” in the Artisan guide or refer to the related topics listed below.

For a description of the Sculpt Geometry Tool options see Edit Polygons > Sculpt Geometry Tool in the *Polygon Modeling* guide.

**Related topics**

- “The Sculpt Geometry Tool” on page 125
- “Sculpt a NURBS or polygon surface mesh” on page 128
- “Smooth a surface mesh” on page 131
- “Erase surface sculpting to an earlier state” on page 134
- “Sculpt according to an attribute map on NURBS” on page 134
- “Sculpt across seams and surface edges on NURBS” on page 135
- “Keyframe sculpting changes” on page 135
Edit NURBS > Surface Editing > Surface Editing Tool, Break Tangent, Smooth Tangent

Attaches a manipulator to the surface you click that lets you set the position and shape at arbitrary points on the surface.

Related topics
- “Reshape a curve or surface manually” on page 49

Edit NURBS > Surface Editing > Surface Editing Tool > □

Tangent Manip. Size
Controls the length of the tangent direction handle on the manipulator.

Edit NURBS > Selection

Grow CV Selection
Expands your CV selection in all directions around the surface.

Shrink CV Selection
Subtracts from your CV selection in all directions around the surface.

Select CV Selection Boundary
Keeps the outer CVs you have selected and deselect the inner CVs.

Select Surface Border
Selects CVs along the surface borders. The borders are defined by U and V values. By default, this operation selects CVs along all borders. In the options window for this operation, you can choose which border CVs you want to select: First U, Last U, First V, or Last V.
Reference

StitchSrf node
These are the stitchSrf options. The options that appear in the Attribute Editor depend on which stitch operation was used.

Stitch Surface History
These are the options in the Stitch Surface section.

Input Surface
The Input Surface is a read-only attribute that lists the original object that was stitched.

Bias
Use the Bias value to blend the CVs between the input surface to the stitch node and the result from the stitch operation. A value of 0 has no effect.

Fix Boundary
You can use the Fix Boundary option only if the Cascade Stitch Nodes option and tangent continuity were on during the stitch operation.

When Fix Boundary is on, the boundary edges remain fixed while Maya solves for tangent continuity.

<table>
<thead>
<tr>
<th>Note</th>
</tr>
</thead>
<tbody>
<tr>
<td>Other attributes displayed in the Attribute Editor depend on the type of surface points you stitched. Information on the possible attributes follows.</td>
</tr>
</tbody>
</table>

Setting point constraint options for stitched edit points
If you stitched edit points together, the Point Constraints options are available.

Parameter U/V
Enter values in the Parameter U and Parameter V boxes to adjust the U or V parameters of the edit points you used to stitch the surface.

Position/Normal
The Position and Normal information is read-only. These values indicate in which XYZ direction the edit points and surface normals are located.

Setting CV positions for stitched CVs
If CVs are stitched together, the Override CV Position options are available.
CV Index boxes
The CV Index boxes in the Override CV position section let you override the
default position of the CVs you used to stitch a surface together.

CV Position
The CV Position values indicate in which XYZ direction the CVs are located.

Continuity
Type on or off in the Continuity boxes to set position or tangent continuity for
the stitch surface.

Step Count
Step Count is the same as Samples Along Edge in the options window.

Bias
Use the Bias value to blend the CVs between the input surface to the stitch
node and the result from the stitch operation. A value of 0 has no effect.

Tolerance Controls
If Toggle Tolerance is off (the default setting), the Step Count (Samples Along
Edge) is used as the tolerance value. If on, you can set a specific tolerance
value.
Symbols
29

Numerics
0 to # spans
  Rebuild Surfaces option 158
0 to 1 spans
  Rebuild Surfaces option 158
3D text 43
3D World
  Intersect Surfaces option 140

A
Active View
  Offset Curve option 95
    Project Curve On Surface option 138
Add Points Tool (Edit Curves menu) 102
Align Curves (Edit Curves menu) 86
  align surfaces 53
Align Surfaces (Edit NURBS menu) 146
  align the ends of two curves 52
All Curves
  Intersect Curves option 89
Along Curve
  Bevel Plus option 136
Along Extrusion
  Bevel Plus options 136
arc
  edit 27
    three-point, create 27
      two-point, create 26
As Selected
  Boundary option 127
Assign Equal Weights
  Stitch Surface Points option 169
At All Intersections
  Cut Curve option 88
At End
  Bevel Plus option 133
At Path
  Extrude option 120
At Profile
  Extrude option 120
At Start
  Bevel Plus option 133
Attach
  Align Curves option 86
    Align Surfaces option 146
Attach Curves (Edit Curves menu) 83
  attach curves or surfaces together 58
Attach Method
  Attach Curves option 84
    Attach Surfaces option 142
Attach Surfaces
  Bevel option 130
    Bevel Plus option 133
Attach Surfaces (Edit NURBS menu) 142
Attach Without Moving (Edit NURBS menu) 144
Attribute Editor
  viewing loft history 116
Auto Anchor
  Fillet Blend attribute 167
Auto Closed Rail Anchor
  Fillet Blend Tool option 167
Auto Completion
  Birail option 126
Auto Normal
  Fillet Blend Tool option 165
Auto Normal Dir
  Fillet Blend Tool option 164
Auto Reverse
  Loft option 114
Automatic
  Boundary option 127
Axis
  Extrude option 120
    axis
      rotate curve around to create a surface 41
Axis Preset
  Revolve option 109

B
Bend (Modify Curves tool) 106
Bend Amount 107
Index

Bevel (Surfaces menu) 129
bevel a surface from a curve 42
Bevel Cap
Bevel options 132
Bevel Corners
Bevel options 131
Bevel Depth
Bevel option 131
Bevel Plus option 134
Bevel Plus
about 43
Bevel Plus (Surfaces menu) 133
Bevel Style
Bevel Plus options 134
Bevel Width
Bevel option 131
Bevel Plus option 134
Bezier
Rebuild Surfaces option 158
Bias
Curve Fillet option 91
Freeform Fillet option 163
Stitch Edges Tool option 177, 178
Birail (Surfaces menu) 124
Birail action 37
Blend
Attach Curves option 84
Attach Surfaces option 143
Curve Fillet option 90
Open/Close Surfaces option 152
Blend Bias
Attach Curves option 84
Attach Surfaces option 143
Open/Close Curve option 87
Open/Close Surfaces option 152
Blend Control
Curve Fillet option 90
Blend Shape
Open/Close Curve option 87
Boolean operations
perform on surfaces 74
Booleans (Edit NURBS menu) 142

Both
Bevel option 130
Reverse Surface Direction option 156
Both Surfaces
Intersect Surfaces option 140
Bottom Side
Bevel option 130
Boundary (Surfaces menu) 127
boundary curves
create surface from 40
create surface within 38
fillet between 46
Break Tangent 64
B-splines
fitting 100

C
cap, extruded surface 37
caps
bevels 132
Cascade Stitch Node
Stitch Edges Tool option 171
Stitch Surface Points option 169
Chord Length
knot spacing for Loft option 114
parameterization, about 13
Circular
Curve Fillet option 90
Extend Curve on Surface option 94
Extend Curve option 93
Offset Curve option 96
Circular Arcs
Bevel corner option 131
circular fillet
create 45
curve, create 28
Circular Fillet (Edit NURBS > Surface Fillet) 161
Close
Loft option 115
closed curves
about 15
creating 67

NURBS Modeling
180
closed surfaces
  about 16
  creating 67
Closest End Point
  Extrude pivot option 121
Closest Knot (Corners)
  Global Stitch option 171
Closest Point (Corners)
  Global Stitch option 171
Closest Point (Edges)
  Global Stitch option 172
Cluster Curve 109
Common End Points
  Boundary options 127
Complete curve range
  Bevel 132
  Extrude option 124
  Offset Curve option 97
  Planar option 117
  Project Curve On Surface 139
  Revolve option 112
complexity, reduce for a curve or surface 62
Component
  Extrude pivot option 121
Concave
  Bevel cap option 132
Connect
  Attach Curves option 84
  Attach Surface option 142
Connect Breaks
  Offset Curve options 95
Construction
  Curve Fillet options 90
Continuity
  Align Curves option 86
  Align Surfaces options 146
  Birail option 126
  Stitch Edges Tool option 178
continuity
  about 18
  curvature 12
  maintain for Square operation 40
  positional, change for stitch 169
  tangent, change for stitch 169
Continuity Type
  Square options 129
control hull 19
control vertices (CVs) 19
Convex
  Bevel cap option 132
  copy and offset a curve or surface 61
  Corners
    Rebuild Surfaces option, keep 159
Create Bevel
  Bevel Plus option 133
Create Cap
  Bevel Plus options 134
Create Curve On Surface
  Circular Fillet option 161
Create Curves for
  Intersect Surfaces option 140
creating
  NURBS primitives 32
  cross knot insertion 22
Cubic
  Planar option 117
  Revolve option 111
  surface degree Extrude option 120
cubic curves 12
Cubic surface degree
  Loft option 115
Curl (Modify Curves tool) 106
Curl Amount 106
Curl Frequency 106
Curvature
  about 17
  Align Curves option 86
  Align Surfaces option 147
  Project Tangent option 102
  Rebuild Curve option 98
curvature (G2) continuity 18
curvature continuity 12
  align curves with 86
  align surfaces with 147
curvature continuous
  make a curve with a curve intersection 52
  make a curve with a surface 51
  make a curve with another curve 52

NURBS Modeling
181
Index

Curvature Scale
   Align Curves option 87
   Align Surfaces option 148
   Project Tangent option 103
Curve Editing tool
   options 102
   reshape curve with 49
Curve Fillet (Edit Curves menu) 90
Curve Fit Checkpoints
   Square options 129
Curve Parameters
   Curve Fillet option 91
Curve Range
   Bevel options 132
   Extrude options 124
   Loft option 115
   Offset Curve options 97
   Planar options 117
   Project Curve On Surface options 139
   Revolve option 112
curve-on-surface
   creating 71
   creating with intersection 140
   definition 70
   extend a certain distance 56
   extend to exact coordinates 56
   use to create a curve 26
## Index

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>curves</td>
<td>183</td>
</tr>
<tr>
<td>add spans</td>
<td>65</td>
</tr>
<tr>
<td>add to a lofted surface</td>
<td>35</td>
</tr>
<tr>
<td>align ends</td>
<td>52</td>
</tr>
<tr>
<td>align with a curve or surface</td>
<td>51</td>
</tr>
<tr>
<td>attach</td>
<td>58</td>
</tr>
<tr>
<td>bounding, create surface</td>
<td>38</td>
</tr>
<tr>
<td>change degree, number of spans/patches</td>
<td>66</td>
</tr>
<tr>
<td>closed</td>
<td>15</td>
</tr>
<tr>
<td>convert to uniform parameterization</td>
<td>65</td>
</tr>
<tr>
<td>create from a surface component curve</td>
<td>26</td>
</tr>
<tr>
<td>create from Degree 1 curve</td>
<td>29</td>
</tr>
<tr>
<td>create on intersection of surfaces</td>
<td>72</td>
</tr>
<tr>
<td>creating trimmed surfaces</td>
<td>118</td>
</tr>
<tr>
<td>cubic</td>
<td>12</td>
</tr>
<tr>
<td>detach</td>
<td>59</td>
</tr>
<tr>
<td>draw by placing CVs</td>
<td>25</td>
</tr>
<tr>
<td>draw by placing edit points</td>
<td>25</td>
</tr>
<tr>
<td>draw freehand</td>
<td>25</td>
</tr>
<tr>
<td>extend a certain distance</td>
<td>56</td>
</tr>
<tr>
<td>extend to exact coordinates</td>
<td>56</td>
</tr>
<tr>
<td>extend with move CVs</td>
<td>56</td>
</tr>
<tr>
<td>extrude and bevel a surface from</td>
<td>42</td>
</tr>
<tr>
<td>fillets, create from two curves</td>
<td>27</td>
</tr>
<tr>
<td>fillets, trim</td>
<td>90</td>
</tr>
<tr>
<td>intersecting</td>
<td>89</td>
</tr>
<tr>
<td>linear</td>
<td>12</td>
</tr>
<tr>
<td>make open or closed</td>
<td>67</td>
</tr>
<tr>
<td>match end points</td>
<td>128</td>
</tr>
<tr>
<td>match topology</td>
<td>68</td>
</tr>
<tr>
<td>offset copy</td>
<td>61</td>
</tr>
<tr>
<td>open</td>
<td>15</td>
</tr>
<tr>
<td>periodic</td>
<td>15</td>
</tr>
<tr>
<td>planning for surfaces</td>
<td>22</td>
</tr>
<tr>
<td>profile, used to make surfaces</td>
<td>35</td>
</tr>
<tr>
<td>project on surface along surface normals</td>
<td>72</td>
</tr>
<tr>
<td>projecting on surface</td>
<td>72</td>
</tr>
<tr>
<td>quadratic</td>
<td>12</td>
</tr>
<tr>
<td>quality</td>
<td>21</td>
</tr>
<tr>
<td>reduce complexity</td>
<td>62</td>
</tr>
<tr>
<td>reshape</td>
<td>49</td>
</tr>
<tr>
<td>resulting, editing attributes</td>
<td>85</td>
</tr>
<tr>
<td>reverse normals</td>
<td>62</td>
</tr>
<tr>
<td>seam</td>
<td>15</td>
</tr>
<tr>
<td>simplest</td>
<td>21</td>
</tr>
<tr>
<td>smoothing</td>
<td>54</td>
</tr>
<tr>
<td>trimming</td>
<td>89</td>
</tr>
<tr>
<td>use revolve to create a surface</td>
<td>41</td>
</tr>
<tr>
<td>Curves On Surface</td>
<td></td>
</tr>
<tr>
<td>Intersect Surfaces option</td>
<td>140</td>
</tr>
<tr>
<td>Cut Curve</td>
<td>60</td>
</tr>
<tr>
<td>Cut Curve (Edit Curves menu)</td>
<td>88</td>
</tr>
<tr>
<td>Cutting Radius</td>
<td></td>
</tr>
<tr>
<td>Offset Curve option</td>
<td>96</td>
</tr>
<tr>
<td>CV Hardness (Edit Curves menu)</td>
<td>101</td>
</tr>
<tr>
<td>CV Index</td>
<td></td>
</tr>
<tr>
<td>Stitch Surface Points option</td>
<td>178</td>
</tr>
<tr>
<td>CV Position</td>
<td></td>
</tr>
<tr>
<td>Stitch Surface Points option</td>
<td>178</td>
</tr>
<tr>
<td>CVs</td>
<td></td>
</tr>
<tr>
<td>about</td>
<td>19</td>
</tr>
<tr>
<td>add more by inserting edit points/isoparms</td>
<td>60</td>
</tr>
<tr>
<td>add to end of curve</td>
<td>56</td>
</tr>
<tr>
<td>control multiplicity</td>
<td>63</td>
</tr>
<tr>
<td>move on a curve or surface</td>
<td>49</td>
</tr>
<tr>
<td>multiplicity</td>
<td>21</td>
</tr>
<tr>
<td>Rebuild Curve, Keep option</td>
<td>99</td>
</tr>
<tr>
<td>Rebuild Surfaces option, keep</td>
<td>159</td>
</tr>
<tr>
<td>use to draw a curve</td>
<td>25</td>
</tr>
<tr>
<td>versus edit points</td>
<td>21</td>
</tr>
</tbody>
</table>

### D

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Degree</td>
<td></td>
</tr>
<tr>
<td>Planar option</td>
<td>117</td>
</tr>
<tr>
<td>Rebuild Curve</td>
<td>option 99</td>
</tr>
<tr>
<td>degree</td>
<td></td>
</tr>
<tr>
<td>about</td>
<td>12</td>
</tr>
<tr>
<td>change for curves, surfaces</td>
<td>66</td>
</tr>
<tr>
<td>of a polynomial equation</td>
<td>11</td>
</tr>
<tr>
<td>Degree 1 (linear) curves</td>
<td>12</td>
</tr>
<tr>
<td>Degree 2 (quadratic) curves</td>
<td>12</td>
</tr>
<tr>
<td>Degree 3 (cubic) curves</td>
<td>12</td>
</tr>
<tr>
<td>Degree 3 curve</td>
<td></td>
</tr>
<tr>
<td>create to match scan data</td>
<td>29</td>
</tr>
<tr>
<td>Degree U/V</td>
<td></td>
</tr>
<tr>
<td>Rebuild Surfaces option</td>
<td>159</td>
</tr>
<tr>
<td>Delete Inputs</td>
<td></td>
</tr>
<tr>
<td>Booleans option</td>
<td>142</td>
</tr>
</tbody>
</table>

---

NURBS Modeling
183
Index

NURBS Modeling

184
edit points
  about 20
  add to a curve 60
  add to end of curve 56
  moving 21
  use to draw a curve 25
editors
  Curve Editing Tool 102
  Curve Editing tool 49
  Surface Editing tool 50
End Conditions
  Rebuild Curve type 98
  Rebuild Surfaces option 158
End Point Tolerance
  Boundary option 128
  Square options 129
end points
  match for Boundary surfaces 128
End Sweep Angle
  Revolve option 111
Ends
  Rebuild Curve, Keep option 99
equation for a curve 11
Exit On Completion
  Birail option 126
Exit on Completion 33
extend
  curves with more CVs 56
  surfaces 57
Extend Curve
  (Edit Curves > Extend) 92
Extend Curve At
  Extend Curve options 93
Extend Curve on Surface
  (Edit Curves > Extend) 94
Extend Direction
  Extend Surfaces option 155
Extend Method
  Extend Curve on Surface option 94
  Extend Curve option 92
Extend Side
  Extend Surfaces option 155
Extend Surfaces
  Edit NURBS menu 155

Extension Type
  Extend Curve option 92
  Extend Surfaces option 155
Extrapolate
  Extend Curve on Surface option 94
  Extend Curve option 93
Extrude
  (Surfaces menu) 118
  extrude a surface from a curve 42
Extrude action 36
Extrude Distance
  Bevel Plus option 134
Extrude Height
  Bevel option 131
Extrude Length
  Extrude option 119

F
Face Count
  Bevel Plus option 136
faceted surfaces 115
fillet
  between two surfaces 45
  blend 46
  circular 45
  curve, create from two curves 27
  for curves 90
  freeform 46
Fillet Blend Tool
  (Edit NURBS > Surface Fillet) 164
Find Intersections
  Intersect Curves option 89
First Rail
  Birail Rebuild option 126
First Surface
  Intersect Surfaces option 140
Fit B-spline
  (Edit Curves menu) 100
Fitting tolerance
  Trim Tool 141
Fix Boundary
  Stitch Edges Tool option 177
Flat
  Extrude style option 118
  flat surfaces, create 33
Index

Flip Left/Right Normal
  Fillet Blend Tool option 166
flying logos
  creating 43
Free
  Extrude option 120
  Revolve option 110
freeform
  Curve Fillet option 90
  drawing of a curve 25
  fillet curve, create 28
  fillet, create 46
Freeform Fillet (Edit NURBS > Surface Fillet) 163
Freeform Type
  Curve Fillet options 90

G
  G0, G1, G2 continuity 18
geometry
  non-rational, convert to 66
Geometry Average
  Offset Curve option 95
Global Stitch
  change options 77
Global Stitch (Edit NURBS > Stitch) 171
Global tolerance
  Bevel option 132
  boundary option 128
  Circular Fillet option 163
  Fillet Blend option 168
  Fit B-spline option 100
  Freeform Fillet option 164
  Intersect Surfaces option 140
  Project Curve On Surface option 139
  Revolve option 111
  Square option 129
Group With Original
  Duplicate NURBS Patches option 137
  Duplicate Surface Curves option 83
Grow CV Selection
  NURBS selection option 176

H
  holes
    create by trimming 69
  hulls
    about 20
    control 19

I
  Ignore
    Open/Close Surfaces option 152
  Ignore Shape
    Open/Close Curve option 87
  implicit representation 11
  In 2D and 3D
    Intersect Curves option 89
  In 3D Only
    Intersect Curves option 89
  Increase by
    Insert Isoparms option 154
    Insert Knots option 92
  Inner Bevel Style
    Bevel Plus option 134
Input Curve
  Bevel option 133
  Curve Fillet option 91
  CV Hardness option 102
  Extend Curve option 94
  Fit B-spline option 100
  Offset Curve option 97
  Rebuild Curve option 100
  Revolve option 113
Input Curves
  Loft History options 116
Input Point
  Extend Curve option 94
Input Profile/Input Rail
  Birail option 126
Input Surface
  Align Surfaces option 149
  Detach Surfaces option 144
  Insert Isoparms option 154
  Rebuild Surfaces option 160
  Stitch Surface Points option 177

NURBS Modeling
186
Index

Input Surface/Input Curve
  Project Curve On Surface option 139
Insert Isoparms (Edit NURBS menu) 153
Insert Knot
  Attach Curves option 84
  Attach Surfaces option 143
  Open/Close Curve option 88
  Open/Close Surfaces option 152
Insert Knot (Edit Curves menu) 91
Insert Location
  Insert Isoparms option 153
  Insert Knot options 92
Insert Parameter
  Attach Curves option 84
  Attach Surfaces option 143
  Open/Close Curve option 88
  Open/Close Surfaces option 152
interactive creation
  snapping 33
interactive NURBS creation 32
Interior Blending
  Align Surfaces option 151
interpolated curves, fit 100
Intersect Curves (Edit Curves menu) 89
Intersect Surfaces (Edit NURBS menu) 140
intersection of objects 74
irregular shapes, create with trimming 69
isoparms
  add to a surface 60
  insert 153
  use to create a curve 26

J
Join
  Curve Fillet option 90
join
  curves or surfaces together 58
    smooth 12
Join Parameter
  Align Surfaces option 149
Join to Original
  Extend Curve option 93
  Extend Surfaces option 155

K
Keep
  Align Curves multiple knots option 86
  Align Surfaces multiple knots option 146
  Attach Curves option 84
  Attach Surfaces multiple knots option 143
  Cut Curve options 88
  Rebuild Curve option 99
  Rebuild Surfaces option 158
  Trim Tool option 141
Keep Original
  Align Curves option 87
  Align Surfaces option 149
  Attach Curves option 85
  Attach Surfaces option 144
  Cut Curve options 88
  CV Hardness option 101
  Detach Curves option 85
  Detach Surfaces option 144
  Extend Curve option 94
  Extend Surfaces option 155
  Fillet Curve option 90
  Insert Isoparms option 154
  Insert Knot option 92
  Open/Close Curve option 88
  Open/Close Surfaces option 152
  Project Tangent option 104
  Rebuild Curve option 100
  Rebuild Surfaces option 160
  Reverse Curve Direction option 97
  Reverse Surface Direction option 156
  Stitch Edges Tool option 171, 175
  Stitch Surface Points option 169
  Trim Tool option 141
  Untrim Surfaces option 141
knot values
  integer values, Rebuild Surface 158
  match, with Rebuild Surfaces 157
knots
  cross insertion 22
  in fillet blends 165
  remove in specific direction 159

NURBS Modeling
187
### Index

<table>
<thead>
<tr>
<th>L</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Last</td>
<td></td>
</tr>
<tr>
<td>Untrim Surfaces option</td>
<td>142</td>
</tr>
<tr>
<td>Linear</td>
<td></td>
</tr>
<tr>
<td>Extend Curve on Surface option</td>
<td>94</td>
</tr>
<tr>
<td>Extend Curve option</td>
<td>92</td>
</tr>
<tr>
<td>Offset Curve option</td>
<td>96</td>
</tr>
<tr>
<td>Planar option</td>
<td>117</td>
</tr>
<tr>
<td>Revolve option</td>
<td>111</td>
</tr>
<tr>
<td>surface degree Extrude option</td>
<td>120</td>
</tr>
<tr>
<td>linear curves</td>
<td>12</td>
</tr>
<tr>
<td>Linear surface degree</td>
<td></td>
</tr>
<tr>
<td>Loft option</td>
<td>115</td>
</tr>
<tr>
<td>Local tolerance</td>
<td></td>
</tr>
<tr>
<td>Bevel option</td>
<td>132</td>
</tr>
<tr>
<td>Boundary option</td>
<td>128</td>
</tr>
<tr>
<td>Circular Fillet option</td>
<td>163</td>
</tr>
<tr>
<td>Fillet Blend option</td>
<td>168</td>
</tr>
<tr>
<td>Fit B-spline option</td>
<td>100</td>
</tr>
<tr>
<td>Freeform Fillet option</td>
<td>164</td>
</tr>
<tr>
<td>Intersect Surfaces option</td>
<td>140</td>
</tr>
<tr>
<td>Project Curve On Surface option</td>
<td>139</td>
</tr>
<tr>
<td>Revolve option</td>
<td>111</td>
</tr>
<tr>
<td>Square option</td>
<td>129</td>
</tr>
<tr>
<td>Lock Length</td>
<td>104</td>
</tr>
<tr>
<td>lock points or edges on NURBS surfaces</td>
<td>77</td>
</tr>
<tr>
<td>Lock surface</td>
<td></td>
</tr>
<tr>
<td>Global Stitch option</td>
<td>174</td>
</tr>
<tr>
<td>Loft (Surfaces menu)</td>
<td>113</td>
</tr>
<tr>
<td>Loft action</td>
<td>35</td>
</tr>
<tr>
<td>Loop Cutting</td>
<td></td>
</tr>
<tr>
<td>Offset Curve option</td>
<td>96</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>M</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Match Curve</td>
<td></td>
</tr>
<tr>
<td>Rebuild Curve option</td>
<td>100</td>
</tr>
<tr>
<td>match end points</td>
<td></td>
</tr>
<tr>
<td>for Boundary surfaces</td>
<td>128</td>
</tr>
<tr>
<td>Match Knots</td>
<td></td>
</tr>
<tr>
<td>Rebuild Curve option</td>
<td>98</td>
</tr>
<tr>
<td>Rebuild Surfaces option</td>
<td>157</td>
</tr>
<tr>
<td>Match Params</td>
<td></td>
</tr>
<tr>
<td>Global Stitch option</td>
<td>172</td>
</tr>
</tbody>
</table>

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Match Surface</td>
<td></td>
</tr>
<tr>
<td>Rebuild Surfaces option</td>
<td>160</td>
</tr>
<tr>
<td>Max Curvature</td>
<td></td>
</tr>
<tr>
<td>Scale Curvature tool</td>
<td>107</td>
</tr>
<tr>
<td>Max Separation</td>
<td></td>
</tr>
<tr>
<td>Global Stitch option</td>
<td>174</td>
</tr>
<tr>
<td>Max Subdivision Density</td>
<td></td>
</tr>
<tr>
<td>Offset Curve option</td>
<td>97</td>
</tr>
<tr>
<td>Method</td>
<td></td>
</tr>
<tr>
<td>Offset Surfaces option</td>
<td>156</td>
</tr>
<tr>
<td>Modification Resistance</td>
<td></td>
</tr>
<tr>
<td>Global Stitch option</td>
<td>174</td>
</tr>
<tr>
<td>Modify Boundary</td>
<td></td>
</tr>
<tr>
<td>Align Curves option</td>
<td>86</td>
</tr>
<tr>
<td>Modify Position</td>
<td></td>
</tr>
<tr>
<td>Align Curves option</td>
<td>86</td>
</tr>
<tr>
<td>Align Surfaces option</td>
<td>146</td>
</tr>
<tr>
<td>Modify Tangent</td>
<td></td>
</tr>
<tr>
<td>Align Curves option</td>
<td>87</td>
</tr>
<tr>
<td>Move Seam (Edit Curves menu)</td>
<td>88</td>
</tr>
<tr>
<td>Move Seam (Edit NURBS menu)</td>
<td>153</td>
</tr>
<tr>
<td>Multiple Knots</td>
<td></td>
</tr>
<tr>
<td>about</td>
<td>21</td>
</tr>
<tr>
<td>Align Curves option</td>
<td>86</td>
</tr>
<tr>
<td>Align Surfaces option</td>
<td>146</td>
</tr>
<tr>
<td>Attach Curves option</td>
<td>84</td>
</tr>
<tr>
<td>Attach Surfaces option</td>
<td>143</td>
</tr>
<tr>
<td>control</td>
<td>63</td>
</tr>
<tr>
<td>Fillet Blend Tool option</td>
<td>165</td>
</tr>
<tr>
<td>remove, with Rebuild Surface</td>
<td>157</td>
</tr>
<tr>
<td>multiple spans</td>
<td>19</td>
</tr>
<tr>
<td>Multiplicity</td>
<td></td>
</tr>
<tr>
<td>about</td>
<td>21</td>
</tr>
<tr>
<td>control</td>
<td>63</td>
</tr>
<tr>
<td>CV Hardness option</td>
<td>101</td>
</tr>
<tr>
<td>Insert Isoparms option</td>
<td>154</td>
</tr>
<tr>
<td>Insert Knot options</td>
<td>92</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>N</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>No Multiple Knots</td>
<td></td>
</tr>
<tr>
<td>Rebuild Curve type</td>
<td>98</td>
</tr>
<tr>
<td>Rebuild Curves option</td>
<td>99</td>
</tr>
<tr>
<td>Rebuild Surfaces option</td>
<td>158</td>
</tr>
</tbody>
</table>
Non Proportional
  Birail transform option 125
Non-Rational
  Rebuild Surfaces option 157
non-rational geometry, convert to 66
Non-Uniform Rational B-Splines
  see NURBS 9
Normal
  Global Stitch option 173
  Project Tangent option 103
  Stitch Surface Points option 177
Normal Direction
  Offset Curve options 95
normals
  about 14
  reverse direction for curves or surfaces 62
  reverse, with Circular Fillet 161
  surface, project curve along 72
Number of Knots
  Insert Isoparms option 155
Number of Spans
  Rebuild Curve option 99
  Rebuild Surfaces option 159
NumSpans
  Rebuild Surfaces options 159
NURBS
  about 9
NURBS primitives
  interactive creation 32
  single-click creation 33
NURBS surface
  see surface 33
NURBS Tool settings 32

Offset Distance
  Offset Curve option 95
  Offset Surfaces option 156
Offset Surfaces (Edit NURBS menu) 156
open curves
  about 15
  creating trimmed surfaces from 118
  making 67
open surfaces
  making 67
Open/Close Curves (Edit Curves menu) 87
Open/Close Surfaces (Edit NURBS menu) 151
Optional
  Boundary option 127
Orientation
  examples 122
  Extrude options 122
Outer Bevel Style
  Bevel Plus option 134
Output Geometry
  Bevel option 132
  Birail option 126
  Extrude option 124
  Fillet Blend Tool option 168
  Freeform Fillet option 164
  Loft option 116
  Planar option 117
  Rebuild Surfaces option 160
  Revolve option 113
  Square option 129
Output Options
  for Bevel Plus 135
Override CV Position
  Stitch Surface Points option 177
Override tolerance value
  Round Tool option 161

Parameter
  Insert Isoparms option 155
Parameter Range
  Rebuild Curve options 99
  Rebuild Surfaces options 158
Index

Parameter U/V
Stitch Surface Points option 177
parameterization
about 13, 22
convert to uniform 65
Loft options 113
uniform, for rebuild curve 98
parameters
about 12
Parametric Distance
Extend Curve on Surface option 94
parametric representations 11
Partial curve range
Bevel 132
Extrude option 124
Loft options 115
Offset Curve option 97
Planar option 117
Project Curve On Surface 139
Revolve option 112
patches
divide by inserting isoparms 66
use to create a surface 44
Path Direction
Extrude orientation option 122
periodic curves 15
periodic surfaces 16
Pivot
Extrude options 121
Revolve option 110
Planar (Surfaces menu) 117
Planar action 33
planning for surfaces 22
Point
Extend Curve option 92
Point Constraints
Stitch Surface Points option 177
points
individual, stitch surfaces at 79
lock on surfaces (stitch) 77
polygons
sculpt tool 81
polynomial equations 10

Position
Align Curves option 86
Align Surfaces option 146
Stitch Edges Tool option 169
Position/Normal
Stitch Surface Points 177
positional (GO) continuity 18
positional continuity
align curves with 86
align surfaces with 146
change for stitch 169
Positional tolerance
Fillet Blend option 168
Preserve Length 105
Preserve Shape
Open/Close Curve option 87
Open/Close Surfaces option 152
Preset
Revolve option 110
Profile
Birail Rebuild option 126
Profile Blend Value
Birail 2 Tool option 126
profile curves
skin a surface across 35
sweep along a path curve 36
sweep along two path curves 37
Profile Normal
Extrude option 119
Extrude orientation option 122
Project Along
Project Curve on Surface options 137
Project Curve On Surface
change in Channel Box 139
Project Curve on Surface (Edit NURBS menu) 137
project tangent
edit 52
Project Tangent (Edit Curves menu) 102
Proportional
Birail transform option 125

Q

quadratic curves 12

NURBS Modeling
190
quality curves 21

R

Radius
   Curve Fillet option 90
   Round Tool manipulator 45
   Round Tool option 160
Rebuild
   Birail option 126
   curve tool, about 22
   Square option 129
Rebuild Curve (Edit Curves menu) 97
Rebuild Method 159
Rebuild Surfaces (Edit NURBS menu) 156
Rebuild Type
   Rebuild Curve option 98
   Rebuild Surfaces options 157
Reduce
   Rebuild Curve option 98
   Rebuild Surfaces option 157
Remove
   Align Curves Multiple Knots option 86
   Align Surfaces Multiple Knots option 146
   Attach Curves Multiple Knots option 84
   Attach Surfaces Multiple Knots option 143
   Extend Curve Multiple Knots option 94
Required
   Boundary option 128
   reshape curves or surfaces 49
Result Position
   Extrude options 120
Reverse
   Align Surfaces option 149
Reverse 1 & 2
   Attach Curves option 85
Reverse Curve
   Loft option 116
Reverse Curve Direction (Edit Curves menu) 97
Reverse Direction
   Fillet Blend Tool option 166
   Project Tangent option 103
Reverse Normal Left/Right
   Fillet Blend Tool option 166
   reverse normals for a curve or surface 62
Reverse Surface Direction (Edit NURBS menu) 156
Reverse Surface Normals
   Circular Fillet option 161
   revolution axis
      specify 109
Revolve (Surfaces menu) 109
Rotation
   Extrude option 123
   Round Tool
      Edit NURBS menu 160
      using 44

S

Same as Outer Style
   Bevel style option 135
Samples Along Edge
   Stitch Edges Tool option 171
Sampling Controls
   Bevel Plus option 136
Sampling Density
   Global Stitch option 174
Scale
   Extrude option 123
Scale Curvature 107
Scale Factor
   Scale Curvature tool 107
Sculpt Polygons tool
   about 81
Sculpt Surfaces Tool
   options 175
seams
   curve 15
   move 153
Second Rail
   Birail Rebuild option 126
Section Spans
   Loft option 115
Sections
   Segments Revolve option 112
Segments
   Revolve option 112
Select Curve Cvs 108
Select CV Selection Boundary
   NURBS selection option 176
Select First CV on Curve 108
Select Last CV on Curve 108
Select Surface Border
   NURBS selection option 176
Select Surface Border (Edit NURBS > Selection) 109
Selected State
   Trim Tool options 141
Selection (Edit NURBS menu) 176
Set to
   Insert Isoparms option 154
   Insert Knots option 92
Shape
   irregular, create with trimming 69
   Open/Close Curve options 87
   Open/Close Surfaces option 152
Shrink CV Selection
   NURBS selection option 176
Shrink Surface
   Trim Tool option 141
single-click creation
   NURBS primitives 33
skin a surface 35
Smooth
   Modify Curves tool 106
Smooth Curve (Edit Curves menu) 101
Smooth Factor 106
smooth joins 12
smoothing
   curves 54
spans
   add to areas of a curve 65
   change number of spans/patches 66
   multiple 19
Specify
   Extrude option 120
split curves or surfaces 59
Square (Surfaces menu) 128
Square action 40
Start Sweep Angle
   Revolve option 111
Step Count
   Stitch Edges Tool option 178

Stitch Corners
   Global Stitch option 171
Stitch Edges
   Global Stitch 172
Stitch Edges Tool (Edit NURBS > Stitch) 169
Stitch Partial Edges
   Global Stitch option 174
Stitch Smoothness
   Global Stitch option 173
Stitch Surface Points (Edit NURBS > Stitch) 169
stitching
   automatic 77
   manual 78
Straight
   Bevel cap option 132
   Bevel corner option 131
Straighten 105
Straightness 105
Style
   Extrude option 118
subtraction of objects 74
Surface Degree
   change, with Rebuild Surfaces 159
   Extrude options 120
   Loft options 115
   Revolve options 111
Surface Direction
   Open/Close Surfaces option 151
   Reverse Surface Direction option 156
Surface Editing (Edit NURBS menu) 176
Surface Editing tool 50
Surface Normal
   Project Curve On Surface option 138
surface normals
   reversing, with Circular Fillet 161
surface patches
   duplicate 44

NURBS Modeling
192
surfaces
align 53
attach 58
Boolean operations on 74
change degree, number of spans/patches 66
convert to non-rational geometry 66
convert to uniform parameterization 65
create by rotating a curve 41
create flat, inside a curve 33
create from four boundary curves 40
create from patches 44
create within bounding curves 38
detach 59
extend a certain distance 57
extrude and bevel from a curve 42
faceted 115
fillet between intersecting 45
fillet between two sets of boundary curves 46
intersecting, create curves at 72
make open or closed 67
offset copy 61
periodic and closed 16
planning for 22
reduce complexity 62
reshape 49
reverse normals 62
skin across profile curves 35
stitch together 77
trim 73

Surfaces menu
Bevel 129
Bevel Plus 133
Birail 124
Boundary 127
Extrude 118
Loft 113
Planar 117
Revolve 109
Square 128

Swap
Align Surfaces option 149
Reverse Surface Direction option 156

sweep
angle, set 111
profile curve along a path curve 36
profile curves along two path curves 37

T
Tangent
Align Curves option 86
Align Surfaces option 147
Curve Fillet option 90
Project Tangent option 102
Stitch Edges Tool options 169
tangent
break at an isoparm, add or remove 64
breaking 64
continuity, align curves with 86
continuity, align surfaces with 147
edit projected 52
make a curve with a curve intersection 52
make a curve with a surface 51
make a curve with another curve 52
tangent (G1) continuity 18
Tangent Align Direction
Project Tangent option 103
Tangent Continuity Profile
Birail option 127
Tangent Manip. Size
surface editing option 176
Tangent Rotation
Project Tangent option 103
Tangent Scale
Align Curves options 87
Align Surfaces options 148
Project Tangent option 103
Tangents
Global Stitch option 173
Rebuild Curve, Keep option 99
Tessellation Method
Bevel Plus option 135
Tolerance
Bevel Plus option 135
Fit B-spline option 100
Offset Curve option 97
Revolve option 111
Tolerance Controls
Stitch Edges Tool 178
Tolerance Value
Round Tool options 161
Index

Tool Behavior
  Birail option 126
  Booleans option 142
  Fillet Blend Tool option 169
tool settings
  NURBS 32
Top Side
  Bevel option 130
topology
  match from one curve to another 68
Transform Control
  Birail option 125
transition surfaces
  Fillet Blend tool 46
  fillet tool 45
  higher control with Bevel Plus 133
  Round tool 44
Trim
  Curve Fillets option 90
trim
  curves 89
  definition 69
  surfaces 73
  surfaces from open curves 118
Trim Convert
  Rebuild Surfaces option 158
Trim Tool (Edit NURBS menu) 141
Tube
  Extrude style option 119
Twist
  Align Surfaces option 150
Twist attribute
  Bend tool 107
twisted blend surface 47

Uniform
  knot spacing, Loft option 113
  Rebuild Curve option 98
  Rebuild Surfaces option 157
uniform parameterization
  about 13
  convert to 65
union of objects 74
Unlock Length 104
Untrim
  Untrim Surfaces options 141
untrim surfaces
  about 74
  cancel last trim 142
Untrim Surfaces (Edit NURBS menu) 141
Use all Surface Isoparms
  Insert Isoparms option 154
Use Direction
  Intersect Curves options 89
Use Normal
  Project Curve On Surface option 140
Use Preferences tolerance value
  Round Tool option 161
Use Tolerance
  Bevel options 132
  Bevel Plus option 135
  Circular Fillet option 163
  Fillet Blend option 168
  Fit B-Spline option 100
  Freeform Fillet options 164
  Intersect Surfaces option 140
  Intersecting Curves option 89
  Offset Curve option 97
  Project Curve On Surface option 139
  Rebuild Curve option 100
  Rebuild Surfaces option 160
  Revolve option 111
Using Last Curve
  Cut Curve option 88
UV Point
  Extend Curve on Surface option 95

NURBS Modeling 194
Visible Surface Isoparms
  Duplicate Surface Curves option 83

Weighting on Edge
  Stitch Edges Tool option 170
  With Last Curve Only
  Intersect Curves option 89